summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-10-30 05:40:43 +0000
committerPeter Volkov <pva@gentoo.org>2008-10-30 05:40:43 +0000
commit5b275881950c09fd0df827dc8ba50d8657cdd88e (patch)
tree125bc7858ef743b003fb887f3fdad510fba7dc25
parentBug #244946 - Use different syntax to pipe find output into while loops inside (diff)
downloadgentoo-2-5b275881950c09fd0df827dc8ba50d8657cdd88e.tar.gz
gentoo-2-5b275881950c09fd0df827dc8ba50d8657cdd88e.tar.bz2
gentoo-2-5b275881950c09fd0df827dc8ba50d8657cdd88e.zip
Build fails without zlib, this patch fixes it, bug #244931, thank emos696 AT hotmail.com for this work.
(Portage version: 2.2_rc12/cvs/Linux 2.6.26-openvz.git-35f41f1 i686)
-rw-r--r--net-analyzer/wireshark/ChangeLog7
-rw-r--r--net-analyzer/wireshark/files/wireshark-1.0.4-zlib-build.patch12
-rw-r--r--net-analyzer/wireshark/wireshark-1.0.4.ebuild3
3 files changed, 20 insertions, 2 deletions
diff --git a/net-analyzer/wireshark/ChangeLog b/net-analyzer/wireshark/ChangeLog
index cfd385c5c7c1..423c6bccd2f0 100644
--- a/net-analyzer/wireshark/ChangeLog
+++ b/net-analyzer/wireshark/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/wireshark
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/ChangeLog,v 1.131 2008/10/22 18:36:49 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/ChangeLog,v 1.132 2008/10/30 05:40:43 pva Exp $
+
+ 30 Oct 2008; Peter Volkov <pva@gentoo.org>
+ +files/wireshark-1.0.4-zlib-build.patch, wireshark-1.0.4.ebuild:
+ Build fails without zlib, this patch fixes it, bug #244931, thank emos696
+ AT hotmail.com for this work.
22 Oct 2008; Guy Martin <gmsoft@gentoo.org> wireshark-1.0.4.ebuild:
hppa stable, #242996
diff --git a/net-analyzer/wireshark/files/wireshark-1.0.4-zlib-build.patch b/net-analyzer/wireshark/files/wireshark-1.0.4-zlib-build.patch
new file mode 100644
index 000000000000..ccc8b60bf128
--- /dev/null
+++ b/net-analyzer/wireshark/files/wireshark-1.0.4-zlib-build.patch
@@ -0,0 +1,12 @@
+http://anonsvn.wireshark.org/viewvc?view=rev&revision=26524
+
+--- trunk-1.0/wiretap/file_access.c 2008/10/23 14:30:35 26523
++++ trunk-1.0/wiretap/file_access.c 2008/10/23 16:38:52 26524
+@@ -978,6 +978,7 @@
+ static FILE *wtap_dump_file_fdopen(wtap_dumper *wdh _U_, int fd)
+ {
+ return fdopen(fd, "wb");
++}
+ #endif
+
+ /* internally writing raw bytes (compressed or not) */
diff --git a/net-analyzer/wireshark/wireshark-1.0.4.ebuild b/net-analyzer/wireshark/wireshark-1.0.4.ebuild
index a13f393706b5..71ea33a4e9a3 100644
--- a/net-analyzer/wireshark/wireshark-1.0.4.ebuild
+++ b/net-analyzer/wireshark/wireshark-1.0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-1.0.4.ebuild,v 1.6 2008/10/22 18:36:49 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-1.0.4.ebuild,v 1.7 2008/10/30 05:40:43 pva Exp $
EAPI=1
WANT_AUTOMAKE="1.9"
@@ -62,6 +62,7 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}"/${PN}-0.99.7-asneeded.patch
epatch "${FILESDIR}"/${PN}-0.99.8-as-needed.patch
+ epatch "${FILESDIR}"/${P}-zlib-build.patch #244931
cd "${S}"/epan
epatch "${FILESDIR}"/wireshark-except-double-free.diff