summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2014-10-10 02:13:38 +0000
committerYixun Lan <dlan@gentoo.org>2014-10-10 02:13:38 +0000
commit5b8c48f6fb4b1b13d2ac825999b9951534d08bef (patch)
tree274b7bdc0cbe11338da0c574dd7cc94556832914
parentFix ChangeLog (diff)
downloadgentoo-2-5b8c48f6fb4b1b13d2ac825999b9951534d08bef.tar.gz
gentoo-2-5b8c48f6fb4b1b13d2ac825999b9951534d08bef.tar.bz2
gentoo-2-5b8c48f6fb4b1b13d2ac825999b9951534d08bef.zip
version bump, drop IUSE flags per discussion, bug 524818
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key 0xAABEFD55)
-rw-r--r--www-apps/joomla/ChangeLog7
-rw-r--r--www-apps/joomla/joomla-3.3.6.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/www-apps/joomla/ChangeLog b/www-apps/joomla/ChangeLog
index 2a4367c56d9c..774420e3a1e1 100644
--- a/www-apps/joomla/ChangeLog
+++ b/www-apps/joomla/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/joomla
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/joomla/ChangeLog,v 1.62 2014/09/05 16:54:18 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/joomla/ChangeLog,v 1.63 2014/10/10 02:13:38 dlan Exp $
+
+*joomla-3.3.6 (10 Oct 2014)
+
+ 10 Oct 2014; Yixun Lan <dlan@gentoo.org> +joomla-3.3.6.ebuild:
+ version bump, drop IUSE flags per discussion, bug 524818
05 Sep 2014; William Hubbs <williamh@gentoo.org> joomla-3.3.3.ebuild:
qa: after speaking with Brian from the db team, do not depend on a database
diff --git a/www-apps/joomla/joomla-3.3.6.ebuild b/www-apps/joomla/joomla-3.3.6.ebuild
new file mode 100644
index 000000000000..c601501fdbc4
--- /dev/null
+++ b/www-apps/joomla/joomla-3.3.6.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/joomla/joomla-3.3.6.ebuild,v 1.1 2014/10/10 02:13:38 dlan Exp $
+
+EAPI=5
+inherit webapp depend.php
+
+MAGIC_1="19822"
+MAGIC_2="161256"
+
+DESCRIPTION="Joomla is a powerful Open Source Content Management System"
+HOMEPAGE="http://www.joomla.org/"
+SRC_URI="http://joomlacode.org/gf/download/frsrelease/${MAGIC_1}/${MAGIC_2}/Joomla_${PV}-Stable-Full_Package.zip"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+need_httpd_cgi
+need_php_httpd
+
+S="${WORKDIR}"
+
+DEPEND="${DEPEND}
+ app-arch/unzip"
+RDEPEND=">=dev-lang/php-5.3.10[json,zlib,xml]
+ || ( dev-lang/php[mysql] dev-lang/php[postgres] )"
+
+src_install () {
+ webapp_src_preinst
+
+ dodoc installation/CHANGELOG installation/INSTALL README.txt
+
+ touch configuration.php
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ local files=" administrator/cache administrator/components
+ administrator/language administrator/language/en-GB
+ administrator/manifests/packages
+ administrator/modules administrator/templates cache components images installation
+ images/banners language language/en-GB media modules plugins
+ plugins/authentication plugins/content plugins/editors plugins/editors-xtd
+ plugins/search plugins/system plugins/user plugins tmp templates"
+
+ for file in ${files}; do
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/${file}
+ done
+
+ webapp_configfile "${MY_HTDOCSDIR}"/configuration.php
+ webapp_serverowned "${MY_HTDOCSDIR}"/configuration.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_postinst_txt sv "${FILESDIR}"/postinstall-sv.txt
+ webapp_src_install
+}