summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-02-07 07:26:39 +0000
committerTim Harder <radhermit@gentoo.org>2012-02-07 07:26:39 +0000
commit5e0a3d69f837c70114f0086996db618d81e2ca73 (patch)
tree16e14fcf168fa88688cf9c6ab6a33c617ab7e5d0
parentRemove old. (diff)
downloadgentoo-2-5e0a3d69f837c70114f0086996db618d81e2ca73.tar.gz
gentoo-2-5e0a3d69f837c70114f0086996db618d81e2ca73.tar.bz2
gentoo-2-5e0a3d69f837c70114f0086996db618d81e2ca73.zip
Version bump.
(Portage version: 2.1.10.44/cvs/Linux x86_64)
-rw-r--r--sys-fs/fuse/ChangeLog9
-rw-r--r--sys-fs/fuse/fuse-2.8.7.ebuild83
2 files changed, 90 insertions, 2 deletions
diff --git a/sys-fs/fuse/ChangeLog b/sys-fs/fuse/ChangeLog
index 92a5b4cd833c..92b94e21cf23 100644
--- a/sys-fs/fuse/ChangeLog
+++ b/sys-fs/fuse/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/fuse
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.152 2011/12/11 17:35:35 armin76 Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.153 2012/02/07 07:26:39 radhermit Exp $
+
+*fuse-2.8.7 (07 Feb 2012)
+
+ 07 Feb 2012; Tim Harder <radhermit@gentoo.org> +fuse-2.8.7.ebuild:
+ Version bump.
11 Dec 2011; Raúl Porcel <armin76@gentoo.org> fuse-2.8.6.ebuild:
alpha/ia64/sparc stable wrt #392949
diff --git a/sys-fs/fuse/fuse-2.8.7.ebuild b/sys-fs/fuse/fuse-2.8.7.ebuild
new file mode 100644
index 000000000000..d2201f560f4f
--- /dev/null
+++ b/sys-fs/fuse/fuse-2.8.7.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.8.7.ebuild,v 1.1 2012/02/07 07:26:39 radhermit Exp $
+
+EAPI=4
+inherit libtool linux-info
+
+MY_P=${P/_/-}
+DESCRIPTION="An interface for filesystems implemented in userspace."
+HOMEPAGE="http://fuse.sourceforge.net"
+SRC_URI="mirror://sourceforge/fuse/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-linux"
+IUSE="kernel_linux kernel_FreeBSD static-libs"
+
+PDEPEND="kernel_FreeBSD? ( sys-fs/fuse4bsd )"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ if use kernel_linux ; then
+ if kernel_is lt 2 6 9 ; then
+ die "Your kernel is too old."
+ fi
+ CONFIG_CHECK="~FUSE_FS"
+ FUSE_FS_WARNING="You need to have FUSE module built to use user-mode utils"
+ linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ # fix building with glibc-2.14 #370411
+ sed -i '1i#define _GNU_SOURCE' util/fusermount.c || die
+
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ INIT_D_PATH="${EPREFIX}/etc/init.d" \
+ MOUNT_FUSE_PATH="${EPREFIX}/sbin" \
+ UDEV_RULES_PATH="${EPREFIX}/lib/udev/rules.d" \
+ $(use_enable static-libs static) \
+ --disable-example
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc AUTHORS ChangeLog Filesystems README \
+ README.NFS NEWS doc/how-fuse-works \
+ doc/kernel.txt FAQ
+ docinto example
+ dodoc example/*
+
+ if use kernel_linux ; then
+ newinitd "${FILESDIR}"/fuse.init fuse
+ elif use kernel_FreeBSD ; then
+ insinto /usr/include/fuse
+ doins include/fuse_kernel.h
+ newinitd "${FILESDIR}"/fuse-fbsd.init fuse
+ else
+ die "We don't know what init code install for your kernel, please file a bug."
+ fi
+
+ find "${ED}" -name "*.la" -delete
+ rm -rf "${D}/dev"
+
+ dodir /etc
+ cat > "${ED}"/etc/fuse.conf <<-EOF
+ # Set the maximum number of FUSE mounts allowed to non-root users.
+ # The default is 1000.
+ #
+ #mount_max = 1000
+
+ # Allow non-root users to specify the 'allow_other' or 'allow_root'
+ # mount options.
+ #
+ #user_allow_other
+ EOF
+}