summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-06-22 08:55:38 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-06-22 08:55:38 +0000
commit5ee614dbed5808366d2413e27d0f05be5f248577 (patch)
tree9dd1c3138e8aea5eec1cfcaf8ffe3b1035233993
parentnew version (diff)
downloadgentoo-2-5ee614dbed5808366d2413e27d0f05be5f248577.tar.gz
gentoo-2-5ee614dbed5808366d2413e27d0f05be5f248577.tar.bz2
gentoo-2-5ee614dbed5808366d2413e27d0f05be5f248577.zip
new version
-rw-r--r--dev-util/gcvs/ChangeLog13
-rw-r--r--dev-util/gcvs/files/digest-gcvs-1.0_beta31
-rw-r--r--dev-util/gcvs/gcvs-1.0_beta3.ebuild47
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-util/gcvs/ChangeLog b/dev-util/gcvs/ChangeLog
new file mode 100644
index 000000000000..303870d5843e
--- /dev/null
+++ b/dev-util/gcvs/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for dev-util/gcvs
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gcvs/ChangeLog,v 1.1 2002/06/22 08:55:38 rphillips Exp $
+
+*gcvs-1.0_beta3 (22 Jun 2002)
+
+ 22 Jun 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/dev-util/gcvs/files/digest-gcvs-1.0_beta3 b/dev-util/gcvs/files/digest-gcvs-1.0_beta3
new file mode 100644
index 000000000000..3e0e37a5cf19
--- /dev/null
+++ b/dev-util/gcvs/files/digest-gcvs-1.0_beta3
@@ -0,0 +1 @@
+MD5 997af3526601b45c178134dff56f888a gcvs-1.0b3.tar.gz 2548254
diff --git a/dev-util/gcvs/gcvs-1.0_beta3.ebuild b/dev-util/gcvs/gcvs-1.0_beta3.ebuild
new file mode 100644
index 000000000000..792c8382c1e7
--- /dev/null
+++ b/dev-util/gcvs/gcvs-1.0_beta3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Bruce A. Locke <blocke@shivan.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gcvs/gcvs-1.0_beta3.ebuild,v 1.1 2002/06/22 08:55:38 rphillips Exp $
+
+Z="gcvs-1.0b3"
+S=${WORKDIR}/${Z}
+DESCRIPTION="GUI frontend for CVS from the CVSGUI project"
+SRC_URI="mirror://sourceforge/cvsgui/${Z}.tar.gz"
+HOMEPAGE="http://cvsgui.sourceforge.net/"
+
+DEPEND="=x11-libs/gtk+-1.2* >=dev-lang/tcl-8.3.3 sys-devel/perl sys-devel/bison dev-util/glademm"
+RDEPEND="=x11-libs/gtk+-1.2* >=dev-lang/tcl-8.3.3 >=dev-util/cvs-1.11-r1"
+
+src_compile() {
+
+ ./make_configure || die
+ ./configure --prefix=/usr --host=${CHOST} || die
+
+ # Ladies and Gentlemen... The following is pure evil...
+ export HOME=${S}
+ # Yes, thats right... the build process ends up trying to create
+ # something in root's home directory... why? they use glade,
+ # a full blown gnome gui application to generate source code...
+
+ # more evil... without this it builds its own copy of cvs
+ # which of course installs itself on top of the real cvs package
+ mv Makefile Makefile.old
+ sed 's|cvsunix||g' Makefile.old > Makefile
+
+ emake all || die
+
+}
+
+src_install () {
+
+ make prefix=${D}/usr install
+
+ # note: html docs ignored because they focus on the mac and windows
+ # version and seem to be of questionable use with gcvs
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL README
+
+
+}
+
+