summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Gall <tgall@gentoo.org>2004-06-01 03:42:17 +0000
committerTom Gall <tgall@gentoo.org>2004-06-01 03:42:17 +0000
commit61d392345a1d5f78de4a47abc87f6e0bc0d0f969 (patch)
tree3a599b5de7371d61acfc8b3b9c3dacfceac296a3
parentfix -mcpu= filter to replace -mcpu with -mtune and then strip -mtune if gcc d... (diff)
downloadgentoo-2-61d392345a1d5f78de4a47abc87f6e0bc0d0f969.tar.gz
gentoo-2-61d392345a1d5f78de4a47abc87f6e0bc0d0f969.tar.bz2
gentoo-2-61d392345a1d5f78de4a47abc87f6e0bc0d0f969.zip
fixes bug #52617
-rw-r--r--sys-apps/coreutils/ChangeLog5
-rw-r--r--sys-apps/coreutils/coreutils-5.0.91-r4.ebuild4
-rw-r--r--sys-apps/coreutils/files/coreutils-5.0.91-ppc64-1.patch12
3 files changed, 19 insertions, 2 deletions
diff --git a/sys-apps/coreutils/ChangeLog b/sys-apps/coreutils/ChangeLog
index 89d3659c4814..59473978f8bc 100644
--- a/sys-apps/coreutils/ChangeLog
+++ b/sys-apps/coreutils/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/coreutils
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/ChangeLog,v 1.94 2004/05/18 03:25:43 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/ChangeLog,v 1.95 2004/06/01 03:42:17 tgall Exp $
+
+ 31 May 2004; Tom Gall <tgall@gentoo.org> coreutils-5.0.91-r4.ebuild:
+ added coreutils-5.0.91-ppc64-1.patch which fixes bug #52617
17 May 2004; Mike Frysinger <vapier@gentoo.org> coreutils-5.2.1.ebuild:
Fixes for uname: no more segfaults for unknown archs #36190, integrate the
diff --git a/sys-apps/coreutils/coreutils-5.0.91-r4.ebuild b/sys-apps/coreutils/coreutils-5.0.91-r4.ebuild
index 1ede31145c9e..728e91bedbef 100644
--- a/sys-apps/coreutils/coreutils-5.0.91-r4.ebuild
+++ b/sys-apps/coreutils/coreutils-5.0.91-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-5.0.91-r4.ebuild,v 1.16 2004/03/07 09:33:53 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-5.0.91-r4.ebuild,v 1.17 2004/06/01 03:42:17 tgall Exp $
inherit eutils flag-o-matic
@@ -91,6 +91,8 @@ src_unpack() {
EPATCH_SUFFIX="patch" epatch ${PATCHDIR}
use selinux && EPATCH_SUFFIX="patch" epatch ${PATCHDIR}/selinux
+
+ use ppc64 && epatch ${FILESDIR}/coreutils-5.0.91-ppc64-1.patch
}
src_compile() {
diff --git a/sys-apps/coreutils/files/coreutils-5.0.91-ppc64-1.patch b/sys-apps/coreutils/files/coreutils-5.0.91-ppc64-1.patch
new file mode 100644
index 000000000000..3af8811be619
--- /dev/null
+++ b/sys-apps/coreutils/files/coreutils-5.0.91-ppc64-1.patch
@@ -0,0 +1,12 @@
+--- src/uname.c.orig 2004-06-01 08:24:52.395946664 +0000
++++ src/uname.c 2004-06-01 08:25:12.755913616 +0000
+@@ -172,6 +172,9 @@
+ #if defined(PPC)
+ "cpu", "machine"
+ #endif
++ #if defined(__powerpc64__)
++ "cpu", "machine"
++ #endif
+ };
+
+ if(!retr)