summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-03-28 21:55:40 +0000
committerManuel Rüger <mrueg@gentoo.org>2015-03-28 21:55:40 +0000
commit6251ff0977386472cfbaa18c1719ca482d1cb763 (patch)
tree00f9639176d49e158eafefbfdcee36b3b29c0957
parentEAPI 5 (diff)
downloadgentoo-2-6251ff0977386472cfbaa18c1719ca482d1cb763.tar.gz
gentoo-2-6251ff0977386472cfbaa18c1719ca482d1cb763.tar.bz2
gentoo-2-6251ff0977386472cfbaa18c1719ca482d1cb763.zip
Proxy commit for Johan Bergström. Version bump.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key )
-rw-r--r--net-libs/http-parser/ChangeLog7
-rw-r--r--net-libs/http-parser/http-parser-2.4.2.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/net-libs/http-parser/ChangeLog b/net-libs/http-parser/ChangeLog
index 617073624f31..7af0a62d9419 100644
--- a/net-libs/http-parser/ChangeLog
+++ b/net-libs/http-parser/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/http-parser
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/http-parser/ChangeLog,v 1.12 2015/01/23 00:25:43 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/http-parser/ChangeLog,v 1.13 2015/03/28 21:55:40 mrueg Exp $
+
+*http-parser-2.4.2 (28 Mar 2015)
+
+ 28 Mar 2015; Manuel Rüger <mrueg@gentoo.org> +http-parser-2.4.2.ebuild:
+ Proxy commit for Johan Bergström. Version bump.
*http-parser-2.4.1 (23 Jan 2015)
diff --git a/net-libs/http-parser/http-parser-2.4.2.ebuild b/net-libs/http-parser/http-parser-2.4.2.ebuild
new file mode 100644
index 000000000000..f3d97b2312ed
--- /dev/null
+++ b/net-libs/http-parser/http-parser-2.4.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/http-parser/http-parser-2.4.2.ebuild,v 1.1 2015/03/28 21:55:40 mrueg Exp $
+
+EAPI=5
+
+SONAME="libhttp_parser.so.${PV}"
+
+inherit eutils toolchain-funcs multilib multilib-minimal
+
+DESCRIPTION="http request/response parser for c"
+HOMEPAGE="https://github.com/joyent/http-parser"
+SRC_URI="https://github.com/joyent/http-parser/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="static-libs"
+
+src_prepare() {
+
+ sed -i -e 's: -Werror::' \
+ -e 's:-O3 ::' \
+ Makefile || die
+ tc-export CC AR
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ emake library
+ use static-libs && emake package
+}
+
+multilib_src_install() {
+ doheader http_parser.h
+ dolib.so ${SONAME}
+ dosym ${SONAME} /usr/$(get_libdir)/libhttp_parser.so
+ use static-libs && dolib.a libhttp_parser.a
+}
+
+multilib_src_install_all() {
+ dodoc README.md
+}