summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPieter van den Abeele <pvdabeel@gentoo.org>2004-12-26 18:31:31 +0000
committerPieter van den Abeele <pvdabeel@gentoo.org>2004-12-26 18:31:31 +0000
commit626bffb9d27629c4a3849dad4ffce7a1ae5d1a30 (patch)
tree38f3f80b5b25baf9667975a78543bc6575e5ed56
parentfix libgnomecups dependency (Manifest recommit) (diff)
downloadgentoo-2-626bffb9d27629c4a3849dad4ffce7a1ae5d1a30.tar.gz
gentoo-2-626bffb9d27629c4a3849dad4ffce7a1ae5d1a30.tar.bz2
gentoo-2-626bffb9d27629c4a3849dad4ffce7a1ae5d1a30.zip
Improved fs stats and window manager detection
-rw-r--r--app-portage/basc/ChangeLog8
-rw-r--r--app-portage/basc/Manifest4
-rw-r--r--app-portage/basc/basc-1.4.0.ebuild79
-rw-r--r--app-portage/basc/files/digest-basc-1.4.01
4 files changed, 90 insertions, 2 deletions
diff --git a/app-portage/basc/ChangeLog b/app-portage/basc/ChangeLog
index c02e133863b7..02196fac370a 100644
--- a/app-portage/basc/ChangeLog
+++ b/app-portage/basc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-portage/basc
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/basc/ChangeLog,v 1.3 2004/12/23 09:14:04 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/basc/ChangeLog,v 1.4 2004/12/26 18:31:31 pvdabeel Exp $
+
+* basc-1.4.0 (26 Dec 2004)
+
+ 26 Dec 2004; Pieter Van den Abeele <pvdabeel@gentoo.org> basc-1.4.0.ebuild :
+
+ New filesystem type detection and improved windowmanager detection.
* basc-1.3.9 (23 Dec 2004)
diff --git a/app-portage/basc/Manifest b/app-portage/basc/Manifest
index 6e45f508d0b7..33b5d78b9603 100644
--- a/app-portage/basc/Manifest
+++ b/app-portage/basc/Manifest
@@ -1,6 +1,8 @@
-MD5 e4e7bce27e51f85c40986b7ef6a60b98 ChangeLog 588
+MD5 01d1a2ff192584b5cf295e4131fcd209 ChangeLog 769
MD5 01f7a8fd07110a4efa67aad2eb752185 basc-1.3.9-r1.ebuild 1863
MD5 dcb8dc246c5de4b71523851e3328623c basc-1.3.9.ebuild 1860
MD5 f771ec5e8f277ad4d47d4339d412ba85 metadata.xml 257
+MD5 6a58693a47aa43bfb86338be0fbaa110 basc-1.4.0.ebuild 1921
MD5 e2d5a46d807b9a6fc2aba48df22d2971 files/digest-basc-1.3.9 61
MD5 e2d5a46d807b9a6fc2aba48df22d2971 files/digest-basc-1.3.9-r1 61
+MD5 9caadc0bb597176ab249c93650452438 files/digest-basc-1.4.0 61
diff --git a/app-portage/basc/basc-1.4.0.ebuild b/app-portage/basc/basc-1.4.0.ebuild
new file mode 100644
index 000000000000..abff4467f96e
--- /dev/null
+++ b/app-portage/basc/basc-1.4.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/basc/basc-1.4.0.ebuild,v 1.1 2004/12/26 18:31:31 pvdabeel Exp $
+
+# ebuild contributed by Alexander Mieland and Daniel Herzog
+
+inherit eutils gcc
+
+DESCRIPTION="Buildtime And Statistics Client for http://www.gentoo-stats.org"
+HOMEPAGE="http://www.gentoo-stats.org"
+SRC_URI="http://www.gentoo-stats.org/download/${P}.tar.gz"
+
+KEYWORDS="x86 sparc ~mips ~hppa ppc amd64"
+SLOT="0"
+LICENSE="GPL-2"
+
+IUSE=""
+
+RDEPEND="app-portage/gentoolkit
+ dev-lang/perl
+ dev-perl/DateManip
+ net-misc/wget
+ sys-devel/gcc
+ sys-apps/sed
+ sys-apps/grep
+ app-arch/gzip
+ >=sys-apps/uhinv-0.4"
+
+pkg_setup() {
+ enewgroup stats
+ enewuser stats -1 /bin/false /tmp stats
+}
+
+src_compile() {
+ sed -i "s:/usr/local:/usr:g" client/basc
+ sed -i "s:/usr/local:/usr:g" client/hgenlop
+ $(gcc-getCC) ${CFLAGS} -o client/smt-detect client/smt-detect.c
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe client/basc client/hgenlop client/smt-detect
+ dodoc README ChangeLog TEAM
+ dodir /etc/basc
+ touch ${D}/etc/basc/basc.conf
+
+ fowners root:stats /etc/basc
+ fperms ug+w /etc/basc
+
+ fowners root:stats /etc/basc/basc.conf
+ fperms ug+w /etc/basc/basc.conf
+}
+
+pkg_postinst() {
+ local GU=`/usr/bin/hgenlop -nt gcc`
+ echo "GU=\"${GU}\"" >> /etc/basc/basc.conf
+
+ draw_line
+ einfo
+ einfo "The Gentoo Buildtime and Statistics client can be started by"
+ einfo "typing:"
+ einfo ""
+ einfo " \"basc -u\"."
+ einfo ""
+ einfo "Note: You have to be in the stats group to use the client!"
+ einfo ""
+ einfo "If you want to automatically launch the client every 24h,"
+ einfo "you must set up a cronjob for the stats user or a user in"
+ einfo "the stats group."
+ einfo ""
+ einfo "For example:"
+ einfo ""
+ einfo " \"0 0 * * * /usr/bin/basc -q >/dev/null 2>&1\""
+ einfo ""
+ einfo "will start the client every day at 00:00am"
+ einfo
+ draw_line
+ ebeep
+}
diff --git a/app-portage/basc/files/digest-basc-1.4.0 b/app-portage/basc/files/digest-basc-1.4.0
new file mode 100644
index 000000000000..8a86307643c6
--- /dev/null
+++ b/app-portage/basc/files/digest-basc-1.4.0
@@ -0,0 +1 @@
+MD5 de9ac8d652608d3506eed169cf2c4924 basc-1.4.0.tar.gz 14108