summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-12-01 13:53:00 +0000
committerIan Delaney <idella4@gentoo.org>2013-12-01 13:53:00 +0000
commit63eb39a0ccd8d8bc22e380bfd7825532b555a976 (patch)
tree60ec9d84775e80b409784819b1f9c30caa1341cc
parentInitial commit (diff)
downloadgentoo-2-63eb39a0ccd8d8bc22e380bfd7825532b555a976.tar.gz
gentoo-2-63eb39a0ccd8d8bc22e380bfd7825532b555a976.tar.bz2
gentoo-2-63eb39a0ccd8d8bc22e380bfd7825532b555a976.zip
bump; add IUSE doc with dep, doc build & install phases, deps & test phase updated
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
-rw-r--r--dev-python/python-neutronclient/ChangeLog9
-rw-r--r--dev-python/python-neutronclient/python-neutronclient-2.3.1.ebuild72
2 files changed, 80 insertions, 1 deletions
diff --git a/dev-python/python-neutronclient/ChangeLog b/dev-python/python-neutronclient/ChangeLog
index d6aa880d92b5..abb8e01110db 100644
--- a/dev-python/python-neutronclient/ChangeLog
+++ b/dev-python/python-neutronclient/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/python-neutronclient
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-neutronclient/ChangeLog,v 1.6 2013/11/23 10:07:21 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-neutronclient/ChangeLog,v 1.7 2013/12/01 13:53:00 idella4 Exp $
+
+*python-neutronclient-2.3.1 (01 Dec 2013)
+
+ 01 Dec 2013; Ian Delaney <idella4@gentoo.org>
+ +python-neutronclient-2.3.1.ebuild:
+ bump; add IUSE doc with dep, doc build & install phases, deps & test phase
+ updated
*python-neutronclient-2.3.0-r3 (23 Nov 2013)
diff --git a/dev-python/python-neutronclient/python-neutronclient-2.3.1.ebuild b/dev-python/python-neutronclient/python-neutronclient-2.3.1.ebuild
new file mode 100644
index 000000000000..0d6af8e34a59
--- /dev/null
+++ b/dev-python/python-neutronclient/python-neutronclient-2.3.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-neutronclient/python-neutronclient-2.3.1.ebuild,v 1.1 2013/12/01 13:53:00 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Quantum API"
+HOMEPAGE="https://launchpad.net/neutron"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( >=dev-python/hacking-0.5.6[${PYTHON_USEDEP}]
+ <dev-python/hacking-0.8[${PYTHON_USEDEP}]
+ >=dev-python/cliff-tablib-1.0[${PYTHON_USEDEP}]
+ >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-0.3.14[${PYTHON_USEDEP}]
+ >=dev-python/mox-0.5.3[${PYTHON_USEDEP}]
+ dev-python/subunit[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.17[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.32[${PYTHON_USEDEP}] )
+ doc? ( >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ )"
+RDEPEND="virtual/python-argparse[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.5.21[${PYTHON_USEDEP}]
+ <dev-python/pbr-1.0[${PYTHON_USEDEP}]
+ >=dev-python/cliff-1.4.3[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ >=dev-python/iso8601-0.1.4[${PYTHON_USEDEP}]
+ >=dev-python/simplejson-2.0.9[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/Babel-0.9.6[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -e 's:intersphinx_:#&:' -i doc/source/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && "${PYTHON}" setup.py build_sphinx
+}
+
+python_test() {
+ testr init
+ testr run || die "tests failed under python2.7"
+ flake8 neutronclient/tests || die "run by flake8 over tests folder yielded error"
+}
+
+python_install() {
+ distutils-r1_python_install
+ #stupid stupid
+ local SITEDIR="${D%/}$(python_get_sitedir)" || die
+ cd "${SITEDIR}" || die
+ local egg=( python_neutronclient*.egg-info )
+ #[[ -f ${egg[0]} ]] || die "python_quantumclient*.egg-info not found"
+ ln -s "${egg[0]}" "${egg[0]/neutron/quantum}" || die
+ ln -s neutronclient quantumclient || die
+ ln -s neutron quantumclient/quantum || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+ distutils-r1_python_install_all
+}