summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2011-01-15 17:21:22 +0000
committerSven Wegener <swegener@gentoo.org>2011-01-15 17:21:22 +0000
commit65fb069be1253c42150233808118f7978493a4ab (patch)
tree6f224ccda2de425ba1032f12b716d4aef51ef9d1
parentStable on amd64 wrt bug #351745 (diff)
downloadgentoo-2-65fb069be1253c42150233808118f7978493a4ab.tar.gz
gentoo-2-65fb069be1253c42150233808118f7978493a4ab.tar.bz2
gentoo-2-65fb069be1253c42150233808118f7978493a4ab.zip
Version bump, bug #350540.
(Portage version: 2.2.0_alpha15/cvs/Linux x86_64)
-rw-r--r--net-dns/pdns-recursor/ChangeLog9
-rw-r--r--net-dns/pdns-recursor/pdns-recursor-3.3.ebuild61
2 files changed, 68 insertions, 2 deletions
diff --git a/net-dns/pdns-recursor/ChangeLog b/net-dns/pdns-recursor/ChangeLog
index 6fe6640e56f3..7bef97753804 100644
--- a/net-dns/pdns-recursor/ChangeLog
+++ b/net-dns/pdns-recursor/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dns/pdns-recursor
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns-recursor/ChangeLog,v 1.36 2010/03/08 20:38:16 swegener Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns-recursor/ChangeLog,v 1.37 2011/01/15 17:21:22 swegener Exp $
+
+*pdns-recursor-3.3 (15 Jan 2011)
+
+ 15 Jan 2011; Sven Wegener <swegener@gentoo.org> +pdns-recursor-3.3.ebuild:
+ Version bump, bug #350540.
*pdns-recursor-3.2 (08 Mar 2010)
diff --git a/net-dns/pdns-recursor/pdns-recursor-3.3.ebuild b/net-dns/pdns-recursor/pdns-recursor-3.3.ebuild
new file mode 100644
index 000000000000..f08b039fe171
--- /dev/null
+++ b/net-dns/pdns-recursor/pdns-recursor-3.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns-recursor/pdns-recursor-3.3.ebuild,v 1.1 2011/01/15 17:21:22 swegener Exp $
+
+EAPI="3"
+
+inherit toolchain-funcs flag-o-matic eutils
+
+DESCRIPTION="The PowerDNS Recursor"
+HOMEPAGE="http://www.powerdns.com/"
+SRC_URI="http://downloads.powerdns.com/releases/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="lua"
+
+DEPEND="lua? ( >=dev-lang/lua-5.1 )"
+RDEPEND="${DEPEND}
+ !<net-dns/pdns-2.9.20-r1"
+DEPEND="${DEPEND}
+ >=dev-libs/boost-1.33.1"
+
+pkg_setup() {
+ filter-flags -ftree-vectorize
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.1.7.2-error-message.patch
+
+ sed -i -e s:/var/run/:/var/lib/powerdns: "${S}"/config.h || die
+}
+
+src_configure() {
+ true
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ OPTFLAGS="" \
+ LUA_LIBS_CONFIG="-llua" \
+ LUA_CPPFLAGS_CONFIG="" \
+ LUA="$(use lua && echo 1)" \
+ || die "emake failed"
+}
+
+src_install() {
+ dosbin pdns_recursor rec_control || die "dosbin failed"
+ doman pdns_recursor.1 rec_control.1 || die "doman failed"
+
+ insinto /etc/powerdns
+ doins "${FILESDIR}"/recursor.conf || die "doins failed"
+
+ doinitd "${FILESDIR}"/precursor || die "doinitd failed"
+
+ # Pretty ugly, uh?
+ dodir /var/lib/powerdns/var/lib
+ dosym ../.. /var/lib/powerdns/var/lib/powerdns
+}