summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2007-03-27 15:04:38 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2007-03-27 15:04:38 +0000
commit6cd15d46e2cae561770a6b411b10aecd949700ca (patch)
tree15fd561bb400d6a4ccc3f81a7d26054f60e21d9e
parentia64 stable wrt bug 157814 (diff)
downloadgentoo-2-6cd15d46e2cae561770a6b411b10aecd949700ca.tar.gz
gentoo-2-6cd15d46e2cae561770a6b411b10aecd949700ca.tar.bz2
gentoo-2-6cd15d46e2cae561770a6b411b10aecd949700ca.zip
gnome 2.18.0
(Portage version: 2.1.2.2)
-rw-r--r--gnome-extra/evolution-data-server/ChangeLog9
-rw-r--r--gnome-extra/evolution-data-server/evolution-data-server-1.10.0.ebuild131
-rw-r--r--gnome-extra/evolution-data-server/files/digest-evolution-data-server-1.10.03
-rw-r--r--gnome-extra/evolution-data-server/files/evolution-data-server-1.9.91-as-needed.patch66
4 files changed, 208 insertions, 1 deletions
diff --git a/gnome-extra/evolution-data-server/ChangeLog b/gnome-extra/evolution-data-server/ChangeLog
index 8d4c2085df22..79e827196aae 100644
--- a/gnome-extra/evolution-data-server/ChangeLog
+++ b/gnome-extra/evolution-data-server/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for gnome-extra/evolution-data-server
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-data-server/ChangeLog,v 1.110 2007/03/01 18:38:55 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-data-server/ChangeLog,v 1.111 2007/03/27 15:04:38 dang Exp $
+
+*evolution-data-server-1.10.0 (27 Mar 2007)
+
+ 27 Mar 2007; Daniel Gryniewicz <dang@gentoo.org>
+ +files/evolution-data-server-1.9.91-as-needed.patch,
+ +evolution-data-server-1.10.0.ebuild:
+ gnome 2.18.0
*evolution-data-server-1.8.3-r1 (01 Mar 2007)
diff --git a/gnome-extra/evolution-data-server/evolution-data-server-1.10.0.ebuild b/gnome-extra/evolution-data-server/evolution-data-server-1.10.0.ebuild
new file mode 100644
index 000000000000..6aa64fa3ba79
--- /dev/null
+++ b/gnome-extra/evolution-data-server/evolution-data-server-1.10.0.ebuild
@@ -0,0 +1,131 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-data-server/evolution-data-server-1.10.0.ebuild,v 1.1 2007/03/27 15:04:38 dang Exp $
+
+inherit eutils gnome2 autotools
+
+DESCRIPTION="Evolution groupware backend"
+HOMEPAGE="http://www.gnome.org/projects/evolution/"
+
+LICENSE="LGPL-2 Sleepycat"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc ipv6 kerberos keyring krb4 ldap ssl"
+
+RDEPEND=">=dev-libs/glib-2.10
+ >=gnome-base/libbonobo-2.4.2
+ >=gnome-base/orbit-2.9.8
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/gnome-vfs-2
+ >=gnome-base/libgnome-2
+ >=gnome-base/gnome-common-2
+ keyring? ( gnome-base/gnome-keyring )
+ >=dev-libs/libxml2-2
+ >=gnome-base/gconf-2
+ >=x11-libs/gtk+-2
+ >=gnome-base/libglade-2
+ >=net-libs/libsoup-2.2.90
+ sys-libs/zlib
+ =sys-libs/db-4*
+ ldap? ( >=net-nds/openldap-2.0 )
+ ssl? (
+ >=dev-libs/nspr-4.4
+ >=dev-libs/nss-3.9 )
+ kerberos? ( virtual/krb5 )
+ krb4? ( virtual/krb5 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.35.5
+ doc? ( >=dev-util/gtk-doc-1.4 )"
+
+DOCS="ChangeLog MAINTAINERS NEWS TODO"
+
+RESTRICT="confcache"
+
+pkg_setup() {
+ G2CONF="$(use_with ldap openldap) \
+ $(use_with kerberos krb5 /usr) \
+ $(use_enable ssl nss) \
+ $(use_enable ssl smime) \
+ $(use_enable ipv6) \
+ $(use_enable keyring gnome-keyring) \
+ --with-libdb=/usr/$(get_libdir)"
+
+ if use krb4 && ! built_with_use virtual/krb5 krb4; then
+ ewarn
+ ewarn "In order to add kerberos 4 support, you have to emerge"
+ ewarn "virtual/krb5 with the 'krb4' USE flag enabled as well."
+ ewarn
+ ewarn "Skipping for now."
+ ewarn
+ G2CONF="${G2CONF} --without-krb4"
+ else
+ G2CONF="${G2CONF} $(use_with krb4 krb4 /usr)"
+ fi
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Fix what ?
+ epatch ${FILESDIR}/${PN}-1.2.0-gentoo_etc_services.patch
+
+ # Fix broken libdb build
+ epatch "${FILESDIR}"/${PN}-1.7.3-libdb.patch
+
+ # Resolve symbols at execution time for setgid binaries
+ epatch "${FILESDIR}"/${PN}-no_lazy_bindings.patch
+
+ # Rewind in camel-disco-diary to fix a crash
+ epatch "${FILESDIR}"/${PN}-1.8.0-camel-rewind.patch
+
+#-------------Upstream GNOME look here -----------------#
+
+ # --as-needed fixes
+ epatch "${FILESDIR}"/${PN}-1.9.91-as-needed.patch
+
+ # fix for dep ordering so we can add libedataserverui to libexchange-storage
+ # we need to do this or: undefined reference to `e_passwords_get_password'
+ # are the kinds of errors you will get.
+
+ # move the groupwise backend and provider for addressbook, camel, and
+ # calendar to its own folder called server.deps.
+ mkdir server.deps
+ mv addressbook/backends/groupwise server.deps/addressbook
+ mv camel/providers/groupwise server.deps/camel
+ mv calendar/backends/groupwise server.deps/calendar
+
+ # now fix the autotools foo for the new directory and the removed ones
+ echo "SUBDIRS = addressbook camel calendar" > server.deps/Makefile.am
+
+ # remove groupwise folder from Makefile's since they are in a diff location
+ sed -i -e 's: groupwise::' addressbook/backends/Makefile.am camel/providers/Makefile.am calendar/backends/Makefile.am
+
+ # fix configure.in location of the Makefile's
+ sed -i -e 's:addressbook/backends/groupwise:server.deps/addressbook:' configure.in
+ sed -i -e 's:camel/providers/groupwise:server.deps/camel:' configure.in
+ # tack on the server.deps Makefile on our last edit
+ sed -i -e 's:calendar/backends/groupwise:server.deps/calendar/Makefile\nserver.deps:' configure.in
+
+ # fix file includes
+ sed -i -e 's:<backends/groupwise/e-book-backend-groupwise.h>:"server.deps/addressbook/e-book-backend-groupwise.h":' addressbook/libedata-book/e-data-book-factory.c
+
+#---------------Upstream GNOME stop here---------------
+ eautoreconf
+}
+
+src_compile() {
+ # Use NSS/NSPR only if 'ssl' is enabled.
+ if use ssl ; then
+ sed -i -e "s|mozilla-nss|nss|
+ s|mozilla-nspr|nspr|" ${S}/configure
+ G2CONF="${G2CONF} --enable-nss=yes"
+ else
+ G2CONF="${G2CONF} --without-nspr-libs --without-nspr-includes \
+ --without-nss-libs --without-nss-includes"
+ fi
+
+ cd "${S}"
+ gnome2_src_compile
+}
diff --git a/gnome-extra/evolution-data-server/files/digest-evolution-data-server-1.10.0 b/gnome-extra/evolution-data-server/files/digest-evolution-data-server-1.10.0
new file mode 100644
index 000000000000..7253efcd7ba7
--- /dev/null
+++ b/gnome-extra/evolution-data-server/files/digest-evolution-data-server-1.10.0
@@ -0,0 +1,3 @@
+MD5 390ea134306b667a2d77b7e859c8cba0 evolution-data-server-1.10.0.tar.bz2 7095934
+RMD160 75ad8b846c35ff9a6cbf7f2e12d583fff899ae3d evolution-data-server-1.10.0.tar.bz2 7095934
+SHA256 0a2ee6540ffa767d3c841993300fb4320cffc3738230e2a2ad1c566de35b1214 evolution-data-server-1.10.0.tar.bz2 7095934
diff --git a/gnome-extra/evolution-data-server/files/evolution-data-server-1.9.91-as-needed.patch b/gnome-extra/evolution-data-server/files/evolution-data-server-1.9.91-as-needed.patch
new file mode 100644
index 000000000000..3fe166fb1094
--- /dev/null
+++ b/gnome-extra/evolution-data-server/files/evolution-data-server-1.9.91-as-needed.patch
@@ -0,0 +1,66 @@
+diff --exclude-from=/home/dang/bin/scripts/diffrc -up -ruN evolution-data-server-1.9.91.orig/Makefile.am evolution-data-server-1.9.91/Makefile.am
+--- evolution-data-server-1.9.91.orig/Makefile.am 2007-01-03 09:57:27.000000000 -0500
++++ evolution-data-server-1.9.91/Makefile.am 2007-02-14 13:33:26.000000000 -0500
+@@ -5,8 +5,8 @@ if ! WITH_LIBDB
+ LIBDB = libdb
+ endif
+
+-SUBDIRS = $(LIBDB) win32 libedataserver servers camel addressbook calendar libedataserverui src docs art po
+-DIST_SUBDIRS= win32 libedataserver servers camel addressbook calendar libedataserverui src docs art po
++SUBDIRS = $(LIBDB) win32 libedataserver camel addressbook calendar libedataserverui servers server.deps src docs art po
++DIST_SUBDIRS= win32 libedataserver camel addressbook calendar libedataserverui servers server.deps src docs art po
+
+ changelogs = \
+ ChangeLog
+diff --exclude-from=/home/dang/bin/scripts/diffrc -up -ruN evolution-data-server-1.9.91.orig/configure.in evolution-data-server-1.9.91/configure.in
+--- evolution-data-server-1.9.91.orig/configure.in 2007-02-12 09:26:16.000000000 -0500
++++ evolution-data-server-1.9.91/configure.in 2007-02-14 13:31:56.000000000 -0500
+@@ -968,7 +968,7 @@ if test "x${with_krb5}" != "xno"; then
+ AC_CACHE_CHECK([for Kerberos 5], ac_cv_lib_kerberos5,
+ [
+ LDFLAGS="$LDFLAGS -L$with_krb5_libs $mitlibs"
+- AC_TRY_LINK_FUNC(krb5_init_context, ac_cv_lib_kerberos5="$mitlibs",
++ AC_TRY_LINK([#include <krb5.h>],krb5_init_context, ac_cv_lib_kerberos5="$mitlibs",
+ [
+ LDFLAGS="$LDFLAGS_save -L$with_krb5_libs $heimlibs"
+ AC_TRY_LINK_FUNC(krb5_init_context, ac_cv_lib_kerberos5="$heimlibs", ac_cv_lib_kerberos5="no")
+@@ -995,11 +995,16 @@ if test "x${with_krb5}" != "xno"; then
+ msg_krb5="yes (Heimdal)"
+ fi
+ KRB5_LDFLAGS="-L$with_krb5_libs $ac_cv_lib_kerberos5"
++ AC_MSG_RESULT(msg_krb5)
++ else
++ dnl AC_MSG_CHECKING([for Kerberos 5])
++ AC_MSG_RESULT([no])
++ AC_MSG_ERROR([You specified with krb5, but it was not found.])
+ fi
+ else
+- AC_MSG_CHECKING(for Kerberos 5)
+- AC_MSG_RESULT($with_krb5)
++ AC_MSG_WARN([krb5 support disabled])
+ fi
++
+ AM_CONDITIONAL(ENABLE_KRB5, test x$with_krb5 != xno)
+
+ AC_CHECK_HEADER([et/com_err.h],[AC_DEFINE([HAVE_ET_COM_ERR_H], 1, [Have et/comm_err.h])])
+diff --exclude-from=/home/dang/bin/scripts/diffrc -up -ruN evolution-data-server-1.9.91.orig/servers/exchange/storage/Makefile.am evolution-data-server-1.9.91/servers/exchange/storage/Makefile.am
+--- evolution-data-server-1.9.91.orig/servers/exchange/storage/Makefile.am 2007-01-03 09:56:23.000000000 -0500
++++ evolution-data-server-1.9.91/servers/exchange/storage/Makefile.am 2007-02-14 13:29:55.000000000 -0500
+@@ -80,14 +80,15 @@ libexchange_storage_1_2_la_LIBADD = \
+ $(top_builddir)/servers/exchange/lib/libexchange.la \
+ $(top_builddir)/servers/exchange/xntlm/libxntlm.la \
+ $(top_builddir)/libedataserver/libedataserver-1.2.la \
++ $(top_builddir)/libedataserverui/libedataserverui-1.2.la\
+ $(E_DATA_SERVER_LIBS) \
+ $(E_DATA_SERVER_UI_LIBS) \
+ $(LDAP_LIBS) \
+ $(SOUP_LIBS) \
+- $(SOCKET_LIBS)
++ $(SOCKET_LIBS) \
++ $(KRB5_LDFLAGS)
+
+ libexchange_storage_1_2_la_LDFLAGS = \
+- $(KRB5_LDFLAGS) \
+ $(NO_UNDEFINED) \
+ -version-info $(LIBEXCHANGE_STORAGE_CURRENT):$(LIBEXCHANGE_STORAGE_REVISION):$(LIBEXCHANGE_STORAGE_AGE)
+