summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2012-06-30 02:06:45 +0000
committerThomas Kahle <tomka@gentoo.org>2012-06-30 02:06:45 +0000
commit6dff701bc671a99e372ca8e5a6b196b1f290e26b (patch)
tree50d0dfc418b1164b8cb8c4e0315079e1de804b7e
parentVersion bump in the stable tree (diff)
downloadgentoo-2-6dff701bc671a99e372ca8e5a6b196b1f290e26b.tar.gz
gentoo-2-6dff701bc671a99e372ca8e5a6b196b1f290e26b.tar.bz2
gentoo-2-6dff701bc671a99e372ca8e5a6b196b1f290e26b.zip
Fix double declare (for gcc-4.7) in bug 424099
(Portage version: 2.1.11.3/cvs/Linux x86_64)
-rw-r--r--sci-mathematics/gfan/ChangeLog8
-rw-r--r--sci-mathematics/gfan/files/gfan-0.5-double-declare-fix.patch12
-rw-r--r--sci-mathematics/gfan/gfan-0.5.ebuild5
3 files changed, 21 insertions, 4 deletions
diff --git a/sci-mathematics/gfan/ChangeLog b/sci-mathematics/gfan/ChangeLog
index 202795250738..6a2e3e9fab6e 100644
--- a/sci-mathematics/gfan/ChangeLog
+++ b/sci-mathematics/gfan/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/gfan
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gfan/ChangeLog,v 1.9 2011/12/14 09:00:45 phajdan.jr Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gfan/ChangeLog,v 1.10 2012/06/30 02:06:45 tomka Exp $
+
+ 30 Jun 2012; Thomas Kahle <tomka@gentoo.org> gfan-0.5.ebuild,
+ +files/gfan-0.5-double-declare-fix.patch:
+ Fix double declare (for gcc-4.7) in bug 424099
14 Dec 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> gfan-0.5.ebuild:
x86 stable wrt bug #393785
diff --git a/sci-mathematics/gfan/files/gfan-0.5-double-declare-fix.patch b/sci-mathematics/gfan/files/gfan-0.5-double-declare-fix.patch
new file mode 100644
index 000000000000..239540884011
--- /dev/null
+++ b/sci-mathematics/gfan/files/gfan-0.5-double-declare-fix.patch
@@ -0,0 +1,12 @@
+diff -U 3 -dHrN gfan0.5/app_minkowski.cpp gfan0.5-new/app_minkowski.cpp
+--- gfan0.5/app_minkowski.cpp 2011-01-23 12:21:47.000000000 -0500
++++ gfan0.5-new/app_minkowski.cpp 2012-06-29 15:23:48.604280985 -0400
+@@ -160,7 +160,7 @@
+ //log0 fprintf(Stderr,"4");
+ f.insert(c);
+ //log0 fprintf(Stderr,"5\n");
+- static int i;
++ // static int i;
+ //log0 fprintf(Stderr,"inserted:%i\n",++i);
+ }
+ log1 fprintf(Stderr,"Resolving symmetries.\n");
diff --git a/sci-mathematics/gfan/gfan-0.5.ebuild b/sci-mathematics/gfan/gfan-0.5.ebuild
index dd9a24914c35..4f1ed07d1241 100644
--- a/sci-mathematics/gfan/gfan-0.5.ebuild
+++ b/sci-mathematics/gfan/gfan-0.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gfan/gfan-0.5.ebuild,v 1.6 2011/12/14 09:00:45 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gfan/gfan-0.5.ebuild,v 1.7 2012/06/30 02:06:45 tomka Exp $
EAPI="3"
@@ -22,6 +22,7 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/${PN}${PV}/"
src_prepare () {
+ epatch "${FILESDIR}/${P}-double-declare-fix.patch"
sed -i -e "s/-O2/${CXXFLAGS}/" \
-e "/GPROFFLAG =/d" \
-e "s/g++/$(tc-getCXX)/" \