summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKathryn Kulick <gothgirl@gentoo.org>2006-07-05 19:46:10 +0000
committerKathryn Kulick <gothgirl@gentoo.org>2006-07-05 19:46:10 +0000
commit6e29d52487dfcf433d68686f6fe5dd594426f90f (patch)
tree76cc7b4cf3413cb060796649ec341b4c2048df80
parentFixed RDEPEND wrt bug #134781 (diff)
downloadgentoo-2-6e29d52487dfcf433d68686f6fe5dd594426f90f.tar.gz
gentoo-2-6e29d52487dfcf433d68686f6fe5dd594426f90f.tar.bz2
gentoo-2-6e29d52487dfcf433d68686f6fe5dd594426f90f.zip
Fixed X idle time support.
(Portage version: 2.1.1_pre1-r5)
-rw-r--r--net-im/gaim/ChangeLog5
-rw-r--r--net-im/gaim/gaim-2.0.0_beta3-r1.ebuild54
2 files changed, 43 insertions, 16 deletions
diff --git a/net-im/gaim/ChangeLog b/net-im/gaim/ChangeLog
index fee7a17e5ceb..bb2aa51d1423 100644
--- a/net-im/gaim/ChangeLog
+++ b/net-im/gaim/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-im/gaim
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/ChangeLog,v 1.397 2006/07/05 12:28:27 gothgirl Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/ChangeLog,v 1.398 2006/07/05 19:46:10 gothgirl Exp $
+
+ 05 Jul 2006; gothgirl <gothgirl@gentoo.org> gaim-2.0.0_beta3-r1.ebuild:
+ Fixed X idle time support.
05 Jul 2006; gothgirl <gothgirl@gentoo.org> gaim-2.0.0_beta3-r1.ebuild:
Fixed a typo in the beta3-r1 ebuild.
diff --git a/net-im/gaim/gaim-2.0.0_beta3-r1.ebuild b/net-im/gaim/gaim-2.0.0_beta3-r1.ebuild
index ed4acf18a6c4..40bd3324a902 100644
--- a/net-im/gaim/gaim-2.0.0_beta3-r1.ebuild
+++ b/net-im/gaim/gaim-2.0.0_beta3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/gaim-2.0.0_beta3-r1.ebuild,v 1.6 2006/07/05 12:28:27 gothgirl Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/gaim-2.0.0_beta3-r1.ebuild,v 1.7 2006/07/05 19:46:10 gothgirl Exp $
inherit flag-o-matic eutils toolchain-funcs debug multilib mono autotools perl-module
@@ -14,7 +14,7 @@ SRC_URI="mirror://sourceforge/gaim/${MY_P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="avahi audiofile bonjour cjk dbus debug eds gadu gnutls meanwhile mono nas nls perl silc spell startup-notification tcltk xscreensaver custom-flags"
+IUSE="avahi audiofile bonjour cjk dbus debug eds gadu gnutls krb4 meanwhile mono nas nls perl silc spell startup-notification tcltk xscreensaver custom-flags ssl msn"
RDEPEND="
audiofile? ( media-libs/libao
@@ -29,17 +29,24 @@ RDEPEND="
perl? ( >=dev-lang/perl-5.8.2-r1 )
spell? ( >=app-text/gtkspell-2.0.2 )
gadu? ( net-libs/libgadu )
- gnutls? ( net-libs/gnutls )
- !gnutls? ( >=dev-libs/nss-3.11
- >=dev-libs/nspr-4.6.1 )
+ ssl? (
+ gnutls? ( net-libs/gnutls )
+ !gnutls? ( >=dev-libs/nss-3.11 )
+ )
+ msn? (
+ gnutls? ( net-libs/gnutls )
+ !gnutls? ( >=dev-libs/nss-3.11 )
+ )
meanwhile? ( net-libs/meanwhile )
silc? ( >=net-im/silc-toolkit-0.9.12-r3 )
eds? ( gnome-extra/evolution-data-server )
+ krb4? ( >=app-crypt/mit-krb5-1.3.6-r1 )
tcltk? ( dev-lang/tcl
dev-lang/tk )
startup-notification? ( >=x11-libs/startup-notification-0.5 )
mono? ( dev-lang/mono )
- xscreensaver? ( x11-misc/xscreensaver )"
+ xscreensaver? ( x11-misc/xscreensaver
+ x11-libs/libXScrnSaver )"
DEPEND="$RDEPEND
dev-util/pkgconfig
@@ -116,9 +123,17 @@ print_gaim_warning() {
pkg_setup() {
print_gaim_warning
+ if use krb4 && ! built_with_use app-crypt/mit-krb5 krb4 ; then
+ eerror
+ eerror You need to rebuild app-crypt/mit-krb5 with USE=krb4 in order to
+ eerror enable krb4 support for the zephyr protocol in gaim.
+ eerror
+ die "Configure failed"
+ fi
+
if use avahi && ! built_with_use net-dns/avahi howl-compat ; then
eerror
- eerror You need to rebuild net-dns/avahi with USE=howl-compat in order
+ eerror You need to rebuild net-dns/avavhi with USE=howl-compat in order
eerror to enable howl support for the bonjour protocol in gaim.
eerror
die "Configure failed"
@@ -171,14 +186,23 @@ src_compile() {
myconf="${myconf} --with-gadu-libs=."
fi
- if use gnutls ; then
- einfo "Disabling NSS, using GnuTLS"
- myconf="${myconf} --enable-nss=no"
- myconf="${myconf} --with-gnutls-includes=/usr/include/gnutls"
- myconf="${myconf} --with-gnutls-libs=/usr/$(get_libdir)"
+ if use ssl || use msn ; then
+ if use gnutls ; then
+ einfo "Disabling NSS, using GnuTLS"
+ myconf="${myconf} --enable-nss=no enable-gnutls=yes"
+ myconf="${myconf} --with-gnutls-includes=/usr/include/gnutls"
+ myconf="${myconf} --with-gnutls-libs=/usr/$(get_libdir)"
+ else
+ einfo "Disabling GnuTLS, using NSS"
+ myconf="${myconf} --enable-gnutls=no --enable-nss=yes"
+ fi
else
- einfo "Disabling GnuTLS, using NSS"
- myconf="${myconf} --enable-gnutls=no"
+ einfo "No SSL support selected"
+ myconf="${myconf} --enable-gnutls=no --enable-nss=no"
+ fi
+
+ if use xscreensaver ; then
+ myconf="${myconf} --x-includes=/usr/include/X11"
fi
econf \
@@ -188,8 +212,8 @@ src_compile() {
$(use_enable startup-notification) \
$(use_enable tcltk tcl) \
$(use_enable tcltk tk) \
- $(use_enable xscreensaver screensaver) \
$(use_enable mono) \
+ $(use_enable krb4) \
$(use_enable debug) \
$(use_enable dbus) \
$(use_enable meanwhile) \