summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2007-03-27 17:17:43 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2007-03-27 17:17:43 +0000
commit6e50c50b367cfcff11b5cf9b4bbe792fa5bcb287 (patch)
tree6a6062fb4934a946d652e4d45bf8cc24607dc202
parentgnome 2.18.0 (diff)
downloadgentoo-2-6e50c50b367cfcff11b5cf9b4bbe792fa5bcb287.tar.gz
gentoo-2-6e50c50b367cfcff11b5cf9b4bbe792fa5bcb287.tar.bz2
gentoo-2-6e50c50b367cfcff11b5cf9b4bbe792fa5bcb287.zip
gnome 2.18.0
(Portage version: 2.1.2.2)
-rw-r--r--app-accessibility/dasher/ChangeLog9
-rw-r--r--app-accessibility/dasher/dasher-4.4.0.ebuild75
-rw-r--r--app-accessibility/dasher/files/dasher-4.3.4-as-needed.patch26
-rw-r--r--app-accessibility/dasher/files/dasher-4.4.0-gnome_help.patch29
-rw-r--r--app-accessibility/dasher/files/digest-dasher-4.4.03
5 files changed, 141 insertions, 1 deletions
diff --git a/app-accessibility/dasher/ChangeLog b/app-accessibility/dasher/ChangeLog
index fae2c9ed4294..51aa16b300a0 100644
--- a/app-accessibility/dasher/ChangeLog
+++ b/app-accessibility/dasher/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-accessibility/dasher
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/dasher/ChangeLog,v 1.89 2007/02/06 01:38:51 leonardop Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/dasher/ChangeLog,v 1.90 2007/03/27 17:17:43 dang Exp $
+
+*dasher-4.4.0 (27 Mar 2007)
+
+ 27 Mar 2007; Daniel Gryniewicz <dang@gentoo.org>
+ +files/dasher-4.3.4-as-needed.patch, +files/dasher-4.4.0-gnome_help.patch,
+ +dasher-4.4.0.ebuild:
+ gnome 2.18.0
06 Feb 2007; Leonardo Boshell <leonardop@gentoo.org>
+files/dasher-4.2.2-gnome_help.patch, dasher-4.2.2.ebuild:
diff --git a/app-accessibility/dasher/dasher-4.4.0.ebuild b/app-accessibility/dasher/dasher-4.4.0.ebuild
new file mode 100644
index 000000000000..c20ccbad0a84
--- /dev/null
+++ b/app-accessibility/dasher/dasher-4.4.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/dasher/dasher-4.4.0.ebuild,v 1.1 2007/03/27 17:17:43 dang Exp $
+
+WANT_AUTOCONF="2.5"
+WANT_AUTOMAKE="1.8"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="A text entry interface, driven by continuous pointing gestures"
+HOMEPAGE="http://www.inference.phy.cam.ac.uk/dasher/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="accessibility cairo gnome"
+
+# The package claims to support 'qte', but it hasn't been tested.
+# Any patches from someone who can test it are welcome.
+# <leonardop@gentoo.org>
+RDEPEND=">=dev-libs/glib-2.6
+ dev-libs/expat
+ >=x11-libs/gtk+-2.6
+ >=gnome-base/gconf-2
+ >=gnome-base/libglade-2
+ gnome? (
+ >=gnome-base/libgnome-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/gnome-vfs-2 )
+ accessibility? (
+ app-accessibility/gnome-speech
+ >=gnome-base/libbonobo-2
+ >=gnome-base/orbit-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-extra/at-spi-1
+ dev-libs/atk )
+ cairo? ( >=x11-libs/gtk+-2.8 )
+
+ x11-libs/libX11"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9
+ gnome? (
+ >=app-text/gnome-doc-utils-0.3.2
+ app-text/scrollkeeper )
+
+ x11-proto/xextproto
+ x11-proto/xproto
+ x11-libs/libXt"
+
+DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README"
+
+
+pkg_setup() {
+ G2CONF="--disable-scrollkeeper \
+ $(use_enable accessibility a11y) \
+ $(use_enable accessibility speech) \
+ $(use_with cairo) \
+ $(use_with gnome)"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ sed -i -e 's:gtk-update-icon-cache:true:' ./Data/Makefile.am
+
+ epatch "${FILESDIR}/${PN}-4.3.4-as-needed.patch"
+
+ # Patch to fix compilation when USE=-gnome is used (bug #165154)
+ epatch "${FILESDIR}/${P}-gnome_help.patch"
+
+ eautoreconf
+}
diff --git a/app-accessibility/dasher/files/dasher-4.3.4-as-needed.patch b/app-accessibility/dasher/files/dasher-4.3.4-as-needed.patch
new file mode 100644
index 000000000000..8ed7d58e6789
--- /dev/null
+++ b/app-accessibility/dasher/files/dasher-4.3.4-as-needed.patch
@@ -0,0 +1,26 @@
+diff --exclude-from=/home/dang/bin/scripts/diffrc -up -ruN dasher-4.3.4.orig/Src/Makefile.am dasher-4.3.4/Src/Makefile.am
+--- dasher-4.3.4.orig/Src/Makefile.am 2007-02-12 13:09:31.000000000 -0500
++++ dasher-4.3.4/Src/Makefile.am 2007-02-16 20:36:34.000000000 -0500
+@@ -24,17 +24,17 @@ AM_CXXFLAGS = \
+ -DPACKAGE_LOCALE_DIR=\"$(datadir)/locale\"
+
+ dasher_LDADD = \
+- $(GTK2BUILD_LIBS) \
+- -lexpat \
+- $(POPT_LIBS) \
+- $(GPELIB) \
+ Common/libdashermisc.a \
+ Gtk2/libdashergtk.a \
+ Gtk2/libdashercontrol.a \
+ DasherCore/libdashercore.a \
+ DasherCore/LanguageModelling/libdasherlm.a \
+ DasherCore/Alphabet/libdasheralphabet.a \
+- Common/libdashermisc.a
++ Common/libdashermisc.a \
++ $(GTK2BUILD_LIBS) \
++ -lexpat \
++ $(POPT_LIBS) \
++ $(GPELIB)
+ endif
+
+ if DOQTE
diff --git a/app-accessibility/dasher/files/dasher-4.4.0-gnome_help.patch b/app-accessibility/dasher/files/dasher-4.4.0-gnome_help.patch
new file mode 100644
index 000000000000..d8ee607b0ddc
--- /dev/null
+++ b/app-accessibility/dasher/files/dasher-4.4.0-gnome_help.patch
@@ -0,0 +1,29 @@
+diff --exclude-from=/home/dang/bin/scripts/diffrc -up -ruN dasher-4.4.0.orig/Data/Help/Makefile.am dasher-4.4.0/Data/Help/Makefile.am
+--- dasher-4.4.0.orig/Data/Help/Makefile.am 2007-03-12 10:13:18.000000000 -0400
++++ dasher-4.4.0/Data/Help/Makefile.am 2007-03-15 15:43:50.000000000 -0400
+@@ -1 +1,5 @@
+-SUBDIRS = Gnome
++SUBDIRS =
++
++if GNOME_HELP
++SUBDIRS += Gnome
++endif
+diff --exclude-from=/home/dang/bin/scripts/diffrc -up -ruN dasher-4.4.0.orig/configure.in dasher-4.4.0/configure.in
+--- dasher-4.4.0.orig/configure.in 2007-03-12 13:27:10.000000000 -0400
++++ dasher-4.4.0/configure.in 2007-03-15 15:44:36.000000000 -0400
+@@ -348,6 +348,7 @@ AM_CONDITIONAL(DOGTK2, test x$BUILDGTK2
+ AM_CONDITIONAL(DOQTE, test x$WITHQTE = xtrue)
+ AM_CONDITIONAL(GNOME_SPEECH, test x$WITHSPEECH = xtrue)
+ AM_CONDITIONAL(GNOME_A11Y, test x$WITHA11Y = xtrue)
++AM_CONDITIONAL(GNOME_HELP, test x$WITHGNOME = xtrue)
+ AM_CONDITIONAL(WITH_GPE, test x$WITHGPE = xtrue)
+ AM_CONDITIONAL(WITH_MAEMO, test x$WITHMAEMO = xtrue)
+ AM_CONDITIONAL(WITH_MAEMOFULLSCREEN, test x$WITHMAEMOFULLSCREEN = xtrue)
+@@ -401,6 +402,7 @@ if [[ x"$WITHGNOME" = xtrue ]]; then
+ GNOME_DOC_INIT
+ else
+ AM_CONDITIONAL(ENABLE_SK, false)
++AM_CONDITIONAL(HAVE_GNOME_DOC_UTILS, false)
+ fi
+
+ AC_CONFIG_FILES([Makefile
diff --git a/app-accessibility/dasher/files/digest-dasher-4.4.0 b/app-accessibility/dasher/files/digest-dasher-4.4.0
new file mode 100644
index 000000000000..40091df00c00
--- /dev/null
+++ b/app-accessibility/dasher/files/digest-dasher-4.4.0
@@ -0,0 +1,3 @@
+MD5 e47684793d29904f64370393234cf604 dasher-4.4.0.tar.bz2 6741569
+RMD160 e07ea2fa977f08c83bec209505ee86018ab05729 dasher-4.4.0.tar.bz2 6741569
+SHA256 66fab7ac772fa1cb2fad1fe9183effa73d345fec364942e1dbc8084600d1d73a dasher-4.4.0.tar.bz2 6741569