summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-01-18 09:53:17 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-01-18 09:53:17 +0000
commit70028fc31206fef4830d900eaa77d9fce9040ffb (patch)
tree87cc80610871781633f15aaef2a53f8f96f9e8fe
parentFixed warnings, bug #301216, thank matt for report. (diff)
downloadgentoo-2-70028fc31206fef4830d900eaa77d9fce9040ffb.tar.gz
gentoo-2-70028fc31206fef4830d900eaa77d9fce9040ffb.tar.bz2
gentoo-2-70028fc31206fef4830d900eaa77d9fce9040ffb.zip
Version bump to 0.2.7 Bug #301292
(Portage version: 2.1.6.13/cvs/Linux i686)
-rw-r--r--games-action/violetland/ChangeLog9
-rw-r--r--games-action/violetland/violetland-0.2.7.ebuild55
2 files changed, 62 insertions, 2 deletions
diff --git a/games-action/violetland/ChangeLog b/games-action/violetland/ChangeLog
index ad996f776ee0..3cd9e6838082 100644
--- a/games-action/violetland/ChangeLog
+++ b/games-action/violetland/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-action/violetland
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/violetland/ChangeLog,v 1.1 2009/11/30 19:25:50 mr_bones_ Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/violetland/ChangeLog,v 1.2 2010/01/18 09:53:17 tupone Exp $
+
+*violetland-0.2.7 (18 Jan 2010)
+
+ 18 Jan 2010; Tupone Alfredo <tupone@gentoo.org> +violetland-0.2.7.ebuild:
+ Version bump to 0.2.7 Bug #301292 by Azamat H. Hackimov
*violetland-0.2.4 (30 Nov 2009)
diff --git a/games-action/violetland/violetland-0.2.7.ebuild b/games-action/violetland/violetland-0.2.7.ebuild
new file mode 100644
index 000000000000..cdc310166aab
--- /dev/null
+++ b/games-action/violetland/violetland-0.2.7.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/violetland/violetland-0.2.7.ebuild,v 1.1 2010/01/18 09:53:17 tupone Exp $
+
+EAPI=2
+inherit eutils cmake-utils games
+
+DESCRIPTION="Help a girl by name of Violet to struggle with hordes of monsters."
+HOMEPAGE="http://code.google.com/p/violetland/"
+SRC_URI="http://violetland.googlecode.com/files/${PN}-v${PV}-src.zip"
+
+LICENSE="GPL-3 CCPL-Attribution-ShareAlike-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libsdl[audio,video]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-ttf
+ x11-libs/libXext
+ x11-libs/libSM
+ virtual/opengl
+ virtual/glu"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+
+
+S=${WORKDIR}/${PN}-v${PV}
+
+src_prepare() {
+ sed -i \
+ -e "/README_EN.TXT/d" \
+ -e "/README_RU.TXT/d" \
+ CMakeLists.txt || die "sed failed"
+}
+
+src_configure() {
+ local mycmakeargs="\
+ -DCMAKE_INSTALL_PREFIX=${GAMES_PREFIX} \
+ -DDATA_INSTALL_DIR=${GAMES_DATADIR}"
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ DOCS="README_EN.TXT" cmake-utils_src_install
+ newicon icon-light.png ${PN}.png
+ make_desktop_entry ${PN} VioletLand
+ prepgamesdirs
+}