summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2010-07-11 14:06:56 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2010-07-11 14:06:56 +0000
commit71ae6f8262d2ca7c5537a921946b4c1a3660345b (patch)
tree62a3e36f2216965e1036d8f4acf632535b5c8f2e
parentMask eds USE flag for pidgin due bug 324511 (diff)
downloadgentoo-2-71ae6f8262d2ca7c5537a921946b4c1a3660345b.tar.gz
gentoo-2-71ae6f8262d2ca7c5537a921946b4c1a3660345b.tar.bz2
gentoo-2-71ae6f8262d2ca7c5537a921946b4c1a3660345b.zip
Bump to 0.9.0
(Portage version: 2.1.8.3/cvs/Linux i686)
-rw-r--r--dev-libs/gobject-introspection/ChangeLog8
-rw-r--r--dev-libs/gobject-introspection/gobject-introspection-0.9.0.ebuild48
2 files changed, 55 insertions, 1 deletions
diff --git a/dev-libs/gobject-introspection/ChangeLog b/dev-libs/gobject-introspection/ChangeLog
index 23b93d4fe594..e5e5a159f42f 100644
--- a/dev-libs/gobject-introspection/ChangeLog
+++ b/dev-libs/gobject-introspection/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/gobject-introspection
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gobject-introspection/ChangeLog,v 1.5 2010/06/11 06:51:51 ford_prefect Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gobject-introspection/ChangeLog,v 1.6 2010/07/11 14:06:56 nirbheek Exp $
+
+*gobject-introspection-0.9.0 (11 Jul 2010)
+
+ 11 Jul 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
+ +gobject-introspection-0.9.0.ebuild:
+ Bump to 0.9.0
11 Jun 2010; Arun Raghavan <ford_prefect@gentoo.org>
-gobject-introspection-0.6.7.ebuild, -gobject-introspection-0.6.8.ebuild:
diff --git a/dev-libs/gobject-introspection/gobject-introspection-0.9.0.ebuild b/dev-libs/gobject-introspection/gobject-introspection-0.9.0.ebuild
new file mode 100644
index 000000000000..103ac86f06ab
--- /dev/null
+++ b/dev-libs/gobject-introspection/gobject-introspection-0.9.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gobject-introspection/gobject-introspection-0.9.0.ebuild,v 1.1 2010/07/11 14:06:56 nirbheek Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2:2.5"
+
+inherit python gnome2
+
+DESCRIPTION="Introspection infrastructure for gobject library bindings"
+HOMEPAGE="http://live.gnome.org/GObjectIntrospection/"
+
+LICENSE="LGPL-2 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=">=dev-libs/glib-2.19.0
+ virtual/libffi"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/gtk-doc-1.12 )
+ dev-util/pkgconfig
+ sys-devel/flex
+ test? ( x11-libs/cairo )"
+
+src_prepare() {
+ G2CONF="${G2CONF} --disable-static"
+
+ # FIXME: Parallel compilation failure with USE=doc
+ use doc && MAKEOPTS="-j1"
+
+ # Don't pre-compile .py
+ ln -sf $(type -P true) py-compile
+}
+
+src_configure() {
+ econf $(use_enable test tests) || die "econf failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/$(get_libdir)/${PN}/giscanner
+ python_need_rebuild
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/lib*/${PN}/giscanner
+}