summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2013-09-29 21:15:29 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2013-09-29 21:15:29 +0000
commit7769ccde863b314813c8a09298af0704a9be413b (patch)
treebf9153198d2af931501851df31cfb3f3edc58b3a
parentAdd arm keyword (bug #486258). (diff)
downloadgentoo-2-7769ccde863b314813c8a09298af0704a9be413b.tar.gz
gentoo-2-7769ccde863b314813c8a09298af0704a9be413b.tar.bz2
gentoo-2-7769ccde863b314813c8a09298af0704a9be413b.zip
Version bump.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key C6085806)
-rw-r--r--media-plugins/gst-plugins-libav/ChangeLog8
-rw-r--r--media-plugins/gst-plugins-libav/gst-plugins-libav-1.2.0.ebuild65
2 files changed, 72 insertions, 1 deletions
diff --git a/media-plugins/gst-plugins-libav/ChangeLog b/media-plugins/gst-plugins-libav/ChangeLog
index 5ecd2bbdeaf8..36921ab6eee6 100644
--- a/media-plugins/gst-plugins-libav/ChangeLog
+++ b/media-plugins/gst-plugins-libav/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-plugins/gst-plugins-libav
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/gst-plugins-libav/ChangeLog,v 1.27 2013/08/06 19:54:13 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gst-plugins-libav/ChangeLog,v 1.28 2013/09/29 21:15:29 eva Exp $
+
+*gst-plugins-libav-1.2.0 (29 Sep 2013)
+
+ 29 Sep 2013; Gilles Dartiguelongue <eva@gentoo.org>
+ +gst-plugins-libav-1.2.0.ebuild:
+ Version bump.
*gst-plugins-libav-1.1.0_pre20130128-r1 (06 Aug 2013)
diff --git a/media-plugins/gst-plugins-libav/gst-plugins-libav-1.2.0.ebuild b/media-plugins/gst-plugins-libav/gst-plugins-libav-1.2.0.ebuild
new file mode 100644
index 000000000000..4f461642de01
--- /dev/null
+++ b/media-plugins/gst-plugins-libav/gst-plugins-libav-1.2.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gst-plugins-libav/gst-plugins-libav-1.2.0.ebuild,v 1.1 2013/09/29 21:15:29 eva Exp $
+
+EAPI="5"
+
+inherit eutils flag-o-matic
+
+MY_PN="gst-libav"
+DESCRIPTION="FFmpeg based gstreamer plugin"
+HOMEPAGE="http://gstreamer.freedesktop.org/modules/gst-libav.html"
+SRC_URI="http://gstreamer.freedesktop.org/src/${MY_PN}/${MY_PN}-${PV}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="1.0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="+orc"
+
+RDEPEND="
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ >=virtual/ffmpeg-9
+ orc? ( >=dev-lang/orc-0.4.16 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_prepare() {
+ sed -e 's/sleep 15//' -i configure.ac configure || die
+}
+
+src_configure() {
+ GST_PLUGINS_BUILD=""
+ # always use system ffmpeg/libav if possible
+ econf \
+ --disable-maintainer-mode \
+ --with-package-name="Gentoo GStreamer ebuild" \
+ --with-package-origin="http://www.gentoo.org" \
+ --disable-fatal-warnings \
+ --with-system-libav \
+ $(use_enable orc)
+}
+
+src_compile() {
+ # Don't build with -Werror
+ emake ERROR_CFLAGS=
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+ default
+ prune_libtool_files --modules
+}
+
+pkg_postinst() {
+ if has_version "media-video/ffmpeg"; then
+ elog "Please note that upstream uses media-video/libav"
+ elog "rather than media-video/ffmpeg. If you encounter any"
+ elog "issues try to move from ffmpeg to libav."
+ fi
+}