summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-12-14 09:41:22 +0000
committerHans de Graaff <graaff@gentoo.org>2010-12-14 09:41:22 +0000
commit7dc0e4a489ee0f5a9050da3f98b52fb3296ed23c (patch)
tree4c62d0a719af3f0d9f1f0d366e45f431fdd7d581
parentstable x86, security bug 348651 (diff)
downloadgentoo-2-7dc0e4a489ee0f5a9050da3f98b52fb3296ed23c.tar.gz
gentoo-2-7dc0e4a489ee0f5a9050da3f98b52fb3296ed23c.tar.bz2
gentoo-2-7dc0e4a489ee0f5a9050da3f98b52fb3296ed23c.zip
Actually install documentation with USE=doc.
(Portage version: 2.1.9.24/cvs/Linux x86_64)
-rw-r--r--dev-ruby/prawn-layout/ChangeLog8
-rw-r--r--dev-ruby/prawn-layout/prawn-layout-0.8.4-r2.ebuild32
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-ruby/prawn-layout/ChangeLog b/dev-ruby/prawn-layout/ChangeLog
index a2cc48aea494..74326d81c1fe 100644
--- a/dev-ruby/prawn-layout/ChangeLog
+++ b/dev-ruby/prawn-layout/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/prawn-layout
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/prawn-layout/ChangeLog,v 1.8 2010/09/24 14:57:12 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/prawn-layout/ChangeLog,v 1.9 2010/12/14 09:41:21 graaff Exp $
+
+*prawn-layout-0.8.4-r2 (14 Dec 2010)
+
+ 14 Dec 2010; Hans de Graaff <graaff@gentoo.org>
+ +prawn-layout-0.8.4-r2.ebuild:
+ Actually install documentation with USE=doc.
*prawn-layout-0.8.4-r1 (24 Sep 2010)
diff --git a/dev-ruby/prawn-layout/prawn-layout-0.8.4-r2.ebuild b/dev-ruby/prawn-layout/prawn-layout-0.8.4-r2.ebuild
new file mode 100644
index 000000000000..885e03eb5ed6
--- /dev/null
+++ b/dev-ruby/prawn-layout/prawn-layout-0.8.4-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/prawn-layout/prawn-layout-0.8.4-r2.ebuild,v 1.1 2010/12/14 09:41:22 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 jruby"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="An extension to Prawn offering table support, grid layouts and other things"
+HOMEPAGE="http://prawn.majesticseacreature.com/"
+
+LICENSE="|| ( GPL-2 Ruby )"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+ruby_add_bdepend test "dev-ruby/test-spec dev-ruby/mocha"
+
+ruby_add_rdepend "=dev-ruby/prawn-core-$(get_version_component_range 1-2)*"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}