summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2007-06-27 09:49:03 +0000
committerVlastimil Babka <caster@gentoo.org>2007-06-27 09:49:03 +0000
commit7f9deb63e542367b33fb734ca0990394c563829c (patch)
treedf3c02adcae2b169f657f7f79afceb0f7748ca65
parentdev-util/mono-debugger: added patch that allows building against kernel >=2.6.19 (diff)
downloadgentoo-2-7f9deb63e542367b33fb734ca0990394c563829c.tar.gz
gentoo-2-7f9deb63e542367b33fb734ca0990394c563829c.tar.bz2
gentoo-2-7f9deb63e542367b33fb734ca0990394c563829c.zip
Raise heap size for compiling also for other slots. Fixes bug #183356.
(Portage version: 2.1.3_rc5)
-rw-r--r--dev-java/fastutil/ChangeLog6
-rw-r--r--dev-java/fastutil/fastutil-4.3.1-r1.ebuild8
-rw-r--r--dev-java/fastutil/fastutil-4.4.2-r1.ebuild5
3 files changed, 13 insertions, 6 deletions
diff --git a/dev-java/fastutil/ChangeLog b/dev-java/fastutil/ChangeLog
index 0c9948337851..750fead9f959 100644
--- a/dev-java/fastutil/ChangeLog
+++ b/dev-java/fastutil/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/fastutil
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/fastutil/ChangeLog,v 1.31 2007/05/05 19:15:58 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/fastutil/ChangeLog,v 1.32 2007/06/27 09:49:03 caster Exp $
+
+ 27 Jun 2007; Vlastimil Babka <caster@gentoo.org> fastutil-4.3.1-r1.ebuild,
+ fastutil-4.4.2-r1.ebuild:
+ Raise heap size for compiling also for other slots. Fixes bug #183356.
*fastutil-5.0.9 (05 May 2007)
diff --git a/dev-java/fastutil/fastutil-4.3.1-r1.ebuild b/dev-java/fastutil/fastutil-4.3.1-r1.ebuild
index 667f97452dee..0114d6ffb7aa 100644
--- a/dev-java/fastutil/fastutil-4.3.1-r1.ebuild
+++ b/dev-java/fastutil/fastutil-4.3.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/fastutil/fastutil-4.3.1-r1.ebuild,v 1.1 2007/05/03 12:40:24 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/fastutil/fastutil-4.3.1-r1.ebuild,v 1.2 2007/06/27 09:49:03 caster Exp $
JAVA_PKG_IUSE="doc source"
@@ -18,11 +18,11 @@ DEPEND=">=virtual/jdk-1.4"
RDEPEND=">=virtual/jre-1.4"
src_compile() {
-
emake sources || die "failed to make sources"
-
+ # bug 162650 and #175578 and #183356
+ java-pkg_init-compiler_
+ [[ ${GENTOO_COMPILER} != "javac" ]] && export ANT_OPTS="-Xmx512m"
java-pkg-2_src_compile
-
}
src_install() {
diff --git a/dev-java/fastutil/fastutil-4.4.2-r1.ebuild b/dev-java/fastutil/fastutil-4.4.2-r1.ebuild
index 66140f45edb4..0edcb032dcdb 100644
--- a/dev-java/fastutil/fastutil-4.4.2-r1.ebuild
+++ b/dev-java/fastutil/fastutil-4.4.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/fastutil/fastutil-4.4.2-r1.ebuild,v 1.5 2007/05/03 12:40:24 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/fastutil/fastutil-4.4.2-r1.ebuild,v 1.6 2007/06/27 09:49:03 caster Exp $
JAVA_PKG_IUSE="doc source"
@@ -19,6 +19,9 @@ RDEPEND=">=virtual/jre-1.4"
src_compile() {
make sources || die "failed to make sources"
+ # bug 162650 and #175578 and #183356
+ java-pkg_init-compiler_
+ [[ ${GENTOO_COMPILER} != "javac" ]] && export ANT_OPTS="-Xmx512m"
java-pkg-2_src_compile
}