summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-06-09 11:42:34 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-06-09 11:42:34 +0000
commit800e3e208d4a0231bb0105345968ce3ef034bde5 (patch)
treed8c3c245cdb47fcea977e2028220127a206848b4
parentold (diff)
downloadgentoo-2-800e3e208d4a0231bb0105345968ce3ef034bde5.tar.gz
gentoo-2-800e3e208d4a0231bb0105345968ce3ef034bde5.tar.bz2
gentoo-2-800e3e208d4a0231bb0105345968ce3ef034bde5.zip
Add patch to build with GCC 4.3. Thanks to Marek Miller in bug #225335.
(Portage version: 2.1.5.4)
-rw-r--r--media-libs/tse3/ChangeLog6
-rw-r--r--media-libs/tse3/files/tse3-0.3.1+gcc-4.3.patch80
-rw-r--r--media-libs/tse3/tse3-0.3.1-r1.ebuild4
3 files changed, 88 insertions, 2 deletions
diff --git a/media-libs/tse3/ChangeLog b/media-libs/tse3/ChangeLog
index e9c9d5e0602c..479b3d7d9510 100644
--- a/media-libs/tse3/ChangeLog
+++ b/media-libs/tse3/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/tse3
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/tse3/ChangeLog,v 1.27 2008/02/15 16:13:02 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/tse3/ChangeLog,v 1.28 2008/06/09 11:42:33 flameeyes Exp $
+
+ 09 Jun 2008; Diego Pettenò <flameeyes@gentoo.org>
+ +files/tse3-0.3.1+gcc-4.3.patch, tse3-0.3.1-r1.ebuild:
+ Add patch to build with GCC 4.3. Thanks to Marek Miller in bug #225335.
15 Feb 2008; Samuli Suominen <drac@gentoo.org> -tse3-0.3.1.ebuild:
Remove old.
diff --git a/media-libs/tse3/files/tse3-0.3.1+gcc-4.3.patch b/media-libs/tse3/files/tse3-0.3.1+gcc-4.3.patch
new file mode 100644
index 000000000000..4581da9d0bf7
--- /dev/null
+++ b/media-libs/tse3/files/tse3-0.3.1+gcc-4.3.patch
@@ -0,0 +1,80 @@
+--- src/tse3/Serializable.h.orig 2008-06-08 12:17:05.000000000 +0200
++++ src/tse3/Serializable.h 2008-06-08 12:17:27.000000000 +0200
+@@ -20,6 +20,7 @@
+ #include <iosfwd>
+ #include <iomanip>
+ #include <cstddef>
++#include <fstream>
+
+ namespace TSE3
+ {
+
+--- src/tse3/TSE2MDL.h.orig 2008-06-08 12:17:41.000000000 +0200
++++ src/tse3/TSE2MDL.h 2008-06-08 12:18:02.000000000 +0200
+@@ -22,6 +22,7 @@
+ #include <string>
+ #include <iostream>
+ #include <cstddef>
++#include <cstring>
+
+ namespace TSE3
+ {
+
+--- src/tse3/MidiFile.h.orig 2008-06-08 12:18:26.000000000 +0200
++++ src/tse3/MidiFile.h 2008-06-08 12:18:42.000000000 +0200
+@@ -25,6 +25,7 @@
+ #include <string>
+ #include <iosfwd>
+ #include <cstddef>
++#include <cstring>
+
+ namespace TSE3
+ {
+--- src/examples/recording/recording.cpp.orig 2008-06-08 12:18:56.000000000 +0200
++++ src/examples/recording/recording.cpp 2008-06-08 12:19:18.000000000 +0200
+@@ -26,6 +26,7 @@
+ *
+ **************************************************************/
+
++#include <cstdlib>
+ #include <iostream>
+
+ // Used in step 1
+
+--- src/tse3play/tse3play.h.orig 2008-06-08 12:19:34.000000000 +0200
++++ src/tse3play/tse3play.h 2008-06-08 12:19:53.000000000 +0200
+@@ -19,6 +19,7 @@
+
+ #include <string>
+ #include <list>
++#include <cstdlib>
+
+ #include "tse3/Transport.h"
+
+--- src/tse3/plt/Alsa-0.9.cpp.orig 2008-06-08 12:39:53.000000000 +0200
++++ src/tse3/plt/Alsa-0.9.cpp 2008-06-08 12:40:25.000000000 +0200
+@@ -25,12 +25,11 @@
+ #define HAVE_SYS_ASOUNDLIB_H
+ #endif
+
+-#define _GNU_SOURCE
+ #include <sys/stat.h>
+ #include <errno.h>
+ #include <alloca.h>
+ #if HAVE_ALSA_ASOUNDLIB_H
+-#include <sys/asoundlib.h>
++#include <alsa/asoundlib.h>
+ #elif HAVE_SYS_ASOUNDLIB_H
+ #include <sys/asoundlib.h>
+ #endif
+
+--- src/tse3/plt/OSS.h.orig 2008-06-08 12:45:46.000000000 +0200
++++ src/tse3/plt/OSS.h 2008-06-08 12:46:06.000000000 +0200
+@@ -21,6 +21,7 @@
+
+ #include <string>
+ #include <list>
++#include <cstring>
+
+ #ifdef HAVE_CONFIG_H
+ #include "config.h"
diff --git a/media-libs/tse3/tse3-0.3.1-r1.ebuild b/media-libs/tse3/tse3-0.3.1-r1.ebuild
index 1289a2380468..6a31166d9463 100644
--- a/media-libs/tse3/tse3-0.3.1-r1.ebuild
+++ b/media-libs/tse3/tse3-0.3.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/tse3/tse3-0.3.1-r1.ebuild,v 1.5 2008/01/10 19:44:23 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/tse3/tse3-0.3.1-r1.ebuild,v 1.6 2008/06/09 11:42:33 flameeyes Exp $
inherit eutils flag-o-matic libtool autotools
@@ -36,6 +36,8 @@ src_unpack() {
epatch "${FILESDIR}/${P}-parallelmake.patch"
+ epatch "${FILESDIR}"/${P}+gcc-4.3.patch
+
eautoreconf
elibtoolize
}