summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-09-20 22:36:25 +0000
committerJeroen Roovers <jer@gentoo.org>2010-09-20 22:36:25 +0000
commit80217c1231d378d33b391375da97451f128ca748 (patch)
tree8a998aa2016b6cc97a92d46069e14fdce2147090
parentVersion bump #338215 by Dirkjan Ochtman. (diff)
downloadgentoo-2-80217c1231d378d33b391375da97451f128ca748.tar.gz
gentoo-2-80217c1231d378d33b391375da97451f128ca748.tar.bz2
gentoo-2-80217c1231d378d33b391375da97451f128ca748.zip
Respect LDFLAGS (bug #336820). Do not hard-wire AR. Set RDEPEND.
(Portage version: 2.2_rc85/cvs/Linux i686)
-rw-r--r--app-crypt/keynote/ChangeLog10
-rw-r--r--app-crypt/keynote/files/keynote-2.3-make.patch36
-rw-r--r--app-crypt/keynote/keynote-2.3-r1.ebuild50
3 files changed, 94 insertions, 2 deletions
diff --git a/app-crypt/keynote/ChangeLog b/app-crypt/keynote/ChangeLog
index 375ed5f5c63b..ce89d763a7a9 100644
--- a/app-crypt/keynote/ChangeLog
+++ b/app-crypt/keynote/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/keynote
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/keynote/ChangeLog,v 1.11 2009/12/28 11:59:51 flameeyes Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/keynote/ChangeLog,v 1.12 2010/09/20 22:36:24 jer Exp $
+
+*keynote-2.3-r1 (20 Sep 2010)
+
+ 20 Sep 2010; Jeroen Roovers <jer@gentoo.org> +keynote-2.3-r1.ebuild,
+ +files/keynote-2.3-make.patch:
+ Respect LDFLAGS (bug #336820). Do not hard-wire AR. Set RDEPEND.
28 Dec 2009; Diego E. Pettenò <flameeyes@gentoo.org> keynote-2.3.ebuild:
Use -j1 for build (bug #298669).
diff --git a/app-crypt/keynote/files/keynote-2.3-make.patch b/app-crypt/keynote/files/keynote-2.3-make.patch
new file mode 100644
index 000000000000..3b9d8a128841
--- /dev/null
+++ b/app-crypt/keynote/files/keynote-2.3-make.patch
@@ -0,0 +1,36 @@
+--- a/Makefile.in 2000-09-27 01:16:27.000000000 +0200
++++ b/Makefile.in 2010-09-21 00:30:37.000000000 +0200
+@@ -35,6 +35,7 @@
+ SED = @SED@
+ ECHO = @ECHO@
+ TR = @TR@
++AR = @AR@
+
+ TARFLAGS = -cvzf ${DISTFILE}
+ YACCFLAGS2 = -d -p kv -b z
+@@ -45,6 +46,7 @@
+ RMFLAGS2 = -rf
+ RMFLAGS = -f
+ NROFFFLAGS = -mandoc
++LDFLAGS = @LDFLAGS@
+
+ SSLCONF = testsuite/openssl.cnf
+ SSLCERT = testsuite/test.cert.pem
+@@ -83,7 +85,7 @@
+ $(RANLIB) $(TARGET)
+
+ $(TARGET2): $(TARGET) $(OBJS2)
+- $(CC) $(CFLAGS) -o $(TARGET2) $(OBJS2) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $(TARGET2) $(OBJS2) $(LIBS)
+
+ k.tab.c: keynote.y header.h keynote.h assertion.h config.h
+ $(YACC) $(YACCFLAGS) keynote.y
+@@ -131,7 +133,7 @@
+ -keyout $(SSLKEY)
+
+ test-sample: all $(OBJS3)
+- $(CC) $(CFLAGS) -o $(TARGET3) $(OBJS3) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $(TARGET3) $(OBJS3) $(LIBS)
+
+ test-sig: all $(SSLCERT) $(SSLKEY)
+ $(SED) -e 's/--.*//' < $(SSLCERT) > $(SSLCERT).1
diff --git a/app-crypt/keynote/keynote-2.3-r1.ebuild b/app-crypt/keynote/keynote-2.3-r1.ebuild
new file mode 100644
index 000000000000..d7ffe8789880
--- /dev/null
+++ b/app-crypt/keynote/keynote-2.3-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/keynote/keynote-2.3-r1.ebuild,v 1.1 2010/09/20 22:36:24 jer Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="The KeyNote Trust-Management System"
+HOMEPAGE="http://www1.cs.columbia.edu/~angelos/keynote.html"
+SRC_URI="http://www1.cs.columbia.edu/~angelos/Code/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ssl"
+
+DEPEND="ssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+cp -av Makefile.in{,.orig}
+ epatch "${FILESDIR}"/${P}-make.patch
+}
+
+src_configure() {
+ tc-export AR CC RANLIB
+ econf
+}
+
+src_compile() {
+ # bug #298669
+ if use ssl; then
+ emake -j1 || die
+ else
+ emake -j1 nocrypto || die
+ fi
+}
+
+src_install() {
+ dobin keynote || die
+
+ dolib.a libkeynote.a
+
+ insinto /usr/include
+ doins keynote.h
+
+ doman man/keynote.[1345]
+ dodoc README HOWTO.add.crypto TODO
+}