summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-04-21 13:03:58 +0000
committerPacho Ramos <pacho@gentoo.org>2012-04-21 13:03:58 +0000
commit84b405ec7fe849d96d73a84f48a94f8f2a46eeb8 (patch)
treefd9849d5498822dea52955be12031a957f148ff0
parentStable for X86, wrt bug #412411 (diff)
downloadgentoo-2-84b405ec7fe849d96d73a84f48a94f8f2a46eeb8.tar.gz
gentoo-2-84b405ec7fe849d96d73a84f48a94f8f2a46eeb8.tar.bz2
gentoo-2-84b405ec7fe849d96d73a84f48a94f8f2a46eeb8.zip
Initial commit from bumblebee overlay, this fixes bug #384083. Thanks a lot to mva and rei4dan for their work.
(Portage version: 2.1.10.56/cvs/Linux x86_64)
-rw-r--r--sys-power/bbswitch/ChangeLog11
-rw-r--r--sys-power/bbswitch/Manifest4
-rw-r--r--sys-power/bbswitch/bbswitch-0.4.1.ebuild37
-rw-r--r--sys-power/bbswitch/files/bbswitch.modprobe1
-rw-r--r--sys-power/bbswitch/metadata.xml20
5 files changed, 73 insertions, 0 deletions
diff --git a/sys-power/bbswitch/ChangeLog b/sys-power/bbswitch/ChangeLog
new file mode 100644
index 000000000000..6ed92e39cca9
--- /dev/null
+++ b/sys-power/bbswitch/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sys-power/bbswitch
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/bbswitch/ChangeLog,v 1.1 2012/04/21 13:03:57 pacho Exp $
+
+*bbswitch-0.4.1 (21 Apr 2012)
+
+ 21 Apr 2012; Pacho Ramos <pacho@gentoo.org> +bbswitch-0.4.1.ebuild,
+ +files/bbswitch.modprobe, +metadata.xml:
+ Initial commit from bumblebee overlay, this fixes bug #384083. Thanks a lot to
+ mva and rei4dan for their work.
+
diff --git a/sys-power/bbswitch/Manifest b/sys-power/bbswitch/Manifest
new file mode 100644
index 000000000000..2e64260eb434
--- /dev/null
+++ b/sys-power/bbswitch/Manifest
@@ -0,0 +1,4 @@
+AUX bbswitch.modprobe 46 RMD160 7daa4f14680a00fb5523a69fb664f9d7bddd6b94 SHA1 cb95cd1b9fa524d5093dfb5e68ba75fe129a5e34 SHA256 e87a481ce095be46efe970769b070d865cb26c91e3a672f61341421acb52e82f
+DIST bbswitch-0.4.1.tar.gz 7134 RMD160 26073da574ac7f8766aa5a6e569197677ec7716b SHA1 5d6139c4ba81042c14cb50814d2ccc6e16185f6a SHA256 d579c6efc5f6482f0cf0b2c1b1f1a127413218cdffdc8f2d5a946c11909bda23
+EBUILD bbswitch-0.4.1.ebuild 721 RMD160 f894a3f5587d4c86b799f532f0a12a94840b5991 SHA1 91efcf7ce013b092516a3ac2c3a3d6e1547b9980 SHA256 130f00b944cf4a0823a97d553f75b55609a3534c303a6a9b7146fd7949529b43
+MISC metadata.xml 602 RMD160 d26c066f190e271c3e58ba8e37ec09e5bf138922 SHA1 e4dd27529460ffcdbfdded255018be30ae2f6756 SHA256 b77cb32c3ace9b24045c0d59434ef67c0520d05dbe97b05d02b5e7348527a1a7
diff --git a/sys-power/bbswitch/bbswitch-0.4.1.ebuild b/sys-power/bbswitch/bbswitch-0.4.1.ebuild
new file mode 100644
index 000000000000..1326788fdb36
--- /dev/null
+++ b/sys-power/bbswitch/bbswitch-0.4.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/bbswitch/bbswitch-0.4.1.ebuild,v 1.1 2012/04/21 13:03:57 pacho Exp $
+
+EAPI="4"
+
+inherit linux-mod
+
+DESCRIPTION="Toggle discrete NVIDIA Optimus graphics card"
+HOMEPAGE="https://github.com/Bumblebee-Project/bbswitch"
+SRC_URI="https://github.com/downloads/Bumblebee-Project/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="virtual/linux-sources
+ sys-kernel/linux-headers"
+
+RDEPEND=""
+
+MODULE_NAMES="bbswitch(acpi)"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ BUILD_TARGETS="default"
+ BUILD_PARAMS="KVERSION=${KV_FULL}"
+}
+
+src_install() {
+ insinto /etc/modprobe.d
+ newins "${FILESDIR}"/bbswitch.modprobe bbswitch.conf
+
+ linux-mod_src_install
+}
diff --git a/sys-power/bbswitch/files/bbswitch.modprobe b/sys-power/bbswitch/files/bbswitch.modprobe
new file mode 100644
index 000000000000..dd6500c77131
--- /dev/null
+++ b/sys-power/bbswitch/files/bbswitch.modprobe
@@ -0,0 +1 @@
+options bbswitch load_state=-1 unload_state=-1 \ No newline at end of file
diff --git a/sys-power/bbswitch/metadata.xml b/sys-power/bbswitch/metadata.xml
new file mode 100644
index 000000000000..fe91799eba40
--- /dev/null
+++ b/sys-power/bbswitch/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>pacho@gentoo.org</email>
+ <name>Pacho Ramos</name>
+</maintainer>
+<maintainer>
+ <email>mva@mva.name</email>
+ <name>Vadim A. Misbakh-Soloviev</name>
+</maintainer>
+<maintainer>
+ <email>rei4dan@gmail.com</email>
+ <name>My Th</name>
+</maintainer>
+<longdescription>
+ Kernel module which automatically detects the required ACPI calls for two
+ kinds of Optimus laptops for safe disabling/enabling the discrete graphics card.
+</longdescription>
+</pkgmetadata>