summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2006-03-10 19:51:02 +0000
committerTim Yamin <plasmaroo@gentoo.org>2006-03-10 19:51:02 +0000
commit85d9d429d3e53d19cdb477455ffd586a6cba6cac (patch)
tree96f2c3490ff74a4a5fda55a1c8307c35aafcacb5
parentStable on ppc. Bug 125479 (diff)
downloadgentoo-2-85d9d429d3e53d19cdb477455ffd586a6cba6cac.tar.gz
gentoo-2-85d9d429d3e53d19cdb477455ffd586a6cba6cac.tar.bz2
gentoo-2-85d9d429d3e53d19cdb477455ffd586a6cba6cac.zip
Fix GCC4 compile issue (bug #125186).
(Portage version: 2.1_pre5-r4)
-rw-r--r--sci-electronics/gerbv/ChangeLog6
-rw-r--r--sci-electronics/gerbv/files/digest-gerbv-1.0.1-r12
-rw-r--r--sci-electronics/gerbv/files/gerbv-1.0.0-gcc-4.10.patch13
-rw-r--r--sci-electronics/gerbv/gerbv-1.0.1-r1.ebuild3
4 files changed, 22 insertions, 2 deletions
diff --git a/sci-electronics/gerbv/ChangeLog b/sci-electronics/gerbv/ChangeLog
index 7b4d390d0df8..19bd2ca9ab0f 100644
--- a/sci-electronics/gerbv/ChangeLog
+++ b/sci-electronics/gerbv/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-electronics/gerbv
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gerbv/ChangeLog,v 1.8 2006/01/22 15:51:29 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gerbv/ChangeLog,v 1.9 2006/03/10 19:51:02 plasmaroo Exp $
+
+ 10 Mar 2006; <plasmaroo@gentoo.org> gerbv-1.0.1-r1.ebuild,
+ +files/gerbv-1.0.0-gcc-4.10.patch:
+ Fix GCC4 compile issue (bug #125186).
22 Jan 2006; <plasmaroo@gentoo.org> gerbv-0.15.ebuild, gerbv-0.16-r1.ebuild,
-gerbv-0.16.ebuild, gerbv-1.0.1-r1.ebuild, -gerbv-1.0.1.ebuild:
diff --git a/sci-electronics/gerbv/files/digest-gerbv-1.0.1-r1 b/sci-electronics/gerbv/files/digest-gerbv-1.0.1-r1
index 5d895c82bb2e..2a324614fdde 100644
--- a/sci-electronics/gerbv/files/digest-gerbv-1.0.1-r1
+++ b/sci-electronics/gerbv/files/digest-gerbv-1.0.1-r1
@@ -1 +1,3 @@
MD5 e259ecec8b65b532a09b7c4ba31c8a08 gerbv-1.0.1.tar.gz 1033739
+RMD160 bc1564a43f0cf8d3052735bb424879bdc27ec95f gerbv-1.0.1.tar.gz 1033739
+SHA256 bc44b093874ef1dec59ef9646cb5282b1bebe5c68682ea8b540de06e04ddc0ad gerbv-1.0.1.tar.gz 1033739
diff --git a/sci-electronics/gerbv/files/gerbv-1.0.0-gcc-4.10.patch b/sci-electronics/gerbv/files/gerbv-1.0.0-gcc-4.10.patch
new file mode 100644
index 000000000000..b4ca2c0d6aea
--- /dev/null
+++ b/sci-electronics/gerbv/files/gerbv-1.0.0-gcc-4.10.patch
@@ -0,0 +1,13 @@
+--- gerbv-1.0.1/src/drill.c~ 2005-01-09 21:51:57.000000000 +0000
++++ gerbv-1.0.1/src/drill.c 2006-03-10 19:26:40.000000000 +0000
+@@ -217,8 +217,8 @@
+ /* KLUDGE. This function isn't allowed to return anything
+ but inches */
+ if(state->unit == MM) {
+- (double)curr_net->start_x /= 25.4;
+- (double)curr_net->start_y /= 25.4;
++ curr_net->start_x /= 25.4;
++ curr_net->start_y /= 25.4;
+ /* KLUDGE. All images, regardless of input format,
+ are returned in INCH format */
+ curr_net->unit = INCH;
diff --git a/sci-electronics/gerbv/gerbv-1.0.1-r1.ebuild b/sci-electronics/gerbv/gerbv-1.0.1-r1.ebuild
index 47b5dbdd5c0f..a120ddb75db2 100644
--- a/sci-electronics/gerbv/gerbv-1.0.1-r1.ebuild
+++ b/sci-electronics/gerbv/gerbv-1.0.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gerbv/gerbv-1.0.1-r1.ebuild,v 1.2 2006/01/22 15:51:29 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gerbv/gerbv-1.0.1-r1.ebuild,v 1.3 2006/03/10 19:51:02 plasmaroo Exp $
inherit eutils
@@ -23,6 +23,7 @@ src_compile() {
confOptions='--enable-gtk2'
use xinerama && epatch ${FILESDIR}/${PN}-1.0.0-Xinerama.patch
use png || confOptions="$confOptions --disable-exportpng"
+ epatch ${FILESDIR}/${PN}-1.0.0-gcc-4.10.patch
econf $confOptions || die
emake || die