summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Marlowe <mattm@gentoo.org>2006-06-30 01:50:08 +0000
committerMatthew Marlowe <mattm@gentoo.org>2006-06-30 01:50:08 +0000
commit860233a18ee365637e6dffe4aa5fffff2fe72218 (patch)
treec00a4e3cd4c7a3c274530497a0014bc2e56ada96
parentupstream bump (diff)
downloadgentoo-2-860233a18ee365637e6dffe4aa5fffff2fe72218.tar.gz
gentoo-2-860233a18ee365637e6dffe4aa5fffff2fe72218.tar.bz2
gentoo-2-860233a18ee365637e6dffe4aa5fffff2fe72218.zip
upstream bump
(Portage version: 2.1-r1)
-rw-r--r--net-analyzer/hyperic-hq-agent/hyperic-hq-agent-2.6.27.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-analyzer/hyperic-hq-agent/hyperic-hq-agent-2.6.27.ebuild b/net-analyzer/hyperic-hq-agent/hyperic-hq-agent-2.6.27.ebuild
new file mode 100644
index 000000000000..d8a2d7338a4e
--- /dev/null
+++ b/net-analyzer/hyperic-hq-agent/hyperic-hq-agent-2.6.27.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/hyperic-hq-agent/hyperic-hq-agent-2.6.27.ebuild,v 1.1 2006/06/30 01:50:08 mattm Exp $
+
+inherit eutils
+
+DESCRIPTION="Agent for HQ Monitoring Software by Hyperic LLC"
+HOMEPAGE="http://www.hyperic.com/"
+SRC_URI="x86? (
+http://dl.hyperic.net/2.6/hyperic-hq-agent-${PV}-x86-linux.tgz ) amd64? (
+http://dl.hyperic.net/2.6/hyperic-hq-agent-${PV}-amd64-linux.tgz )"
+
+LICENSE="hyperic"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+AGENT_HOME=/opt/hyperic-hq-agent-${PV}
+
+src_install() {
+
+ insinto /etc/init.d
+ insopts -m0750
+ newins ${FILESDIR}/hyperic-hq-agent.init-${PV} hyperic-hq-agent
+
+ dodir ${AGENT_HOME}
+ cp -pPR ${S}/* ${D}${AGENT_HOME}
+}
+
+pkg_postinst() {
+
+ einfo "You should perform the following before attempting to start the agent:"
+ einfo
+ einfo "1) read and agree to the _commercial license_ at /usr/portage/licenses/hyperic"
+ einfo "2) ensure that your server has a license key permitting an additional agent install."
+ einfo "3) have your server ip, admin username, and admin password available"
+ einfo "4) rc-update add hyperic-hq-agent default"
+ einfo "5) /etc/init.d/hyperic-hq-agent start"
+ einfo
+}