summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-10-06 22:23:29 +0000
committerTravis Tilley <lv@gentoo.org>2004-10-06 22:23:29 +0000
commit8740286b15af02dae8af18d92cfa222f4cb69100 (patch)
treea7ffcf4c56c83095f3350c5708c5ece2a9579209
parentfix those annoying QA messages about awk (Manifest recommit) (diff)
downloadgentoo-2-8740286b15af02dae8af18d92cfa222f4cb69100.tar.gz
gentoo-2-8740286b15af02dae8af18d92cfa222f4cb69100.tar.bz2
gentoo-2-8740286b15af02dae8af18d92cfa222f4cb69100.zip
fix those annoying QA messages about awk, part 2
-rw-r--r--sys-devel/gcc/gcc-3.3.3.ebuild10
-rw-r--r--sys-devel/gcc/gcc-3.4.1.ebuild10
2 files changed, 12 insertions, 8 deletions
diff --git a/sys-devel/gcc/gcc-3.3.3.ebuild b/sys-devel/gcc/gcc-3.3.3.ebuild
index 03ed2cb6ba87..54b3f29f5767 100644
--- a/sys-devel/gcc/gcc-3.3.3.ebuild
+++ b/sys-devel/gcc/gcc-3.3.3.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.3.ebuild,v 1.14 2004/08/25 13:55:48 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.3.ebuild,v 1.15 2004/10/06 22:23:29 lv Exp $
IUSE="static nls bootstrap java build X multilib gcj"
-inherit eutils flag-o-matic libtool
+inherit eutils flag-o-matic libtool versionator
# Compile problems with these (bug #6641 among others)...
#filter-flags "-fno-exceptions -fomit-frame-pointer -fforce-addr"
@@ -38,8 +38,10 @@ strip-flags
[ ! -n "${CCHOST}" ] && export CCHOST="${CHOST}"
LOC="/usr"
-MY_PV="`echo ${PV} | awk -F. '{ gsub(/_pre.*|_alpha.*/, ""); print $1 "." $2 }'`"
-MY_PV_FULL="`echo ${PV} | awk '{ gsub(/_pre.*|_alpha.*/, ""); print $0 }'`"
+#MY_PV="`echo ${PV} | awk -F. '{ gsub(/_pre.*|_alpha.*/, ""); print $1 "." $2 }'`"
+#MY_PV_FULL="`echo ${PV} | awk '{ gsub(/_pre.*|_alpha.*/, ""); print $0 }'`"
+MY_PV="$(get_version_component_range 1-2)"
+MY_PV_FULL="$(get_version_component_range 1-3)"
LIBPATH="${LOC}/lib/gcc-lib/${CCHOST}/${MY_PV_FULL}"
BINPATH="${LOC}/${CCHOST}/gcc-bin/${MY_PV}"
diff --git a/sys-devel/gcc/gcc-3.4.1.ebuild b/sys-devel/gcc/gcc-3.4.1.ebuild
index 0ac4e0dd28d3..1bdff2978893 100644
--- a/sys-devel/gcc/gcc-3.4.1.ebuild
+++ b/sys-devel/gcc/gcc-3.4.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.1.ebuild,v 1.26 2004/10/01 21:45:27 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.1.ebuild,v 1.27 2004/10/06 22:23:29 lv Exp $
-inherit eutils flag-o-matic libtool gnuconfig
+inherit eutils flag-o-matic libtool gnuconfig versionator
# Recently there has been a lot of stability problem in Gentoo-land. Many
# things can be the cause to this, but I believe that it is due to gcc3
@@ -52,8 +52,10 @@ do_filter_flags() {
[ ! -n "${CCHOST}" ] && export CCHOST="${CHOST}"
LOC="/usr"
-MY_PV="`echo ${PV} | awk -F. '{ gsub(/_pre.*|_alpha.*/, ""); print $1 "." $2 }'`"
-MY_PV_FULL="`echo ${PV} | awk '{ gsub(/_pre.*|_alpha.*/, ""); print $0 }'`"
+#MY_PV="`echo ${PV} | awk -F. '{ gsub(/_pre.*|_alpha.*/, ""); print $1 "." $2 }'`"
+#MY_PV_FULL="`echo ${PV} | awk '{ gsub(/_pre.*|_alpha.*/, ""); print $0 }'`"
+MY_PV="$(get_version_component_range 1-2)"
+MY_PV_FULL="$(get_version_component_range 1-3)"
# GCC 3.4 no longer uses gcc-lib. we'll rename this later for compatibility
# reasons, as a few things would break without gcc-lib.