summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-04-12 19:35:20 +0000
committerMichał Górny <mgorny@gentoo.org>2015-04-12 19:35:20 +0000
commit87c6578e2744652923405332f7a6b23b0c7a7803 (patch)
treead13a05fa064c3294c700eb75db49ae4855ae7c7
parentVersion bump with minor fixes. (diff)
downloadgentoo-2-87c6578e2744652923405332f7a6b23b0c7a7803.tar.gz
gentoo-2-87c6578e2744652923405332f7a6b23b0c7a7803.tar.bz2
gentoo-2-87c6578e2744652923405332f7a6b23b0c7a7803.zip
Version bump with minor fixes.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
-rw-r--r--xfce-extra/xfce4-sensors-plugin/ChangeLog11
-rw-r--r--xfce-extra/xfce4-sensors-plugin/xfce4-sensors-plugin-1.2.6.ebuild61
2 files changed, 69 insertions, 3 deletions
diff --git a/xfce-extra/xfce4-sensors-plugin/ChangeLog b/xfce-extra/xfce4-sensors-plugin/ChangeLog
index 9dcc50264d1f..ecf97745a03f 100644
--- a/xfce-extra/xfce4-sensors-plugin/ChangeLog
+++ b/xfce-extra/xfce4-sensors-plugin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-extra/xfce4-sensors-plugin
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-sensors-plugin/ChangeLog,v 1.43 2013/04/25 08:58:59 ssuominen Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-sensors-plugin/ChangeLog,v 1.44 2015/04/12 19:35:20 mgorny Exp $
+
+*xfce4-sensors-plugin-1.2.6 (12 Apr 2015)
+
+ 12 Apr 2015; Michał Górny <mgorny@gentoo.org>
+ +xfce4-sensors-plugin-1.2.6.ebuild:
+ Version bump with minor fixes.
25 Apr 2013; Samuli Suominen <ssuominen@gentoo.org>
xfce4-sensors-plugin-1.2.5.ebuild:
@@ -202,4 +208,3 @@
23 Aug 2009; Samuli Suominen <ssuominen@gentoo.org>
+xfce4-sensors-plugin-0.10.99.6.ebuild:
Rename xfce4-sensors to xfce4-sensors-plugin.
-
diff --git a/xfce-extra/xfce4-sensors-plugin/xfce4-sensors-plugin-1.2.6.ebuild b/xfce-extra/xfce4-sensors-plugin/xfce4-sensors-plugin-1.2.6.ebuild
new file mode 100644
index 000000000000..f4aa8ca41dc0
--- /dev/null
+++ b/xfce-extra/xfce4-sensors-plugin/xfce4-sensors-plugin-1.2.6.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-sensors-plugin/xfce4-sensors-plugin-1.2.6.ebuild,v 1.1 2015/04/12 19:35:20 mgorny Exp $
+
+EAPI=5
+EAUTORECONF=yes
+inherit multilib xfconf
+
+DESCRIPTION="A panel plug-in for different sensors using acpi, lm_sensors and hddtemp"
+HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-sensors-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+acpi debug hddtemp libnotify lm_sensors video_cards_nvidia"
+
+REQUIRED_USE="|| ( hddtemp lm_sensors acpi )"
+
+RDEPEND=">=x11-libs/gtk+-2.14:2=
+ >=xfce-base/libxfce4ui-4.8:=
+ >=xfce-base/xfce4-panel-4.8:=
+ hddtemp? ( app-admin/hddtemp net-analyzer/gnu-netcat )
+ libnotify? ( >=x11-libs/libnotify-0.7:= )
+ lm_sensors? ( >=sys-apps/lm_sensors-3.1.0:= )
+ video_cards_nvidia? ( media-video/nvidia-settings )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+ $(use_enable lm_sensors libsensors)
+ $(use_enable hddtemp)
+ $(use_enable hddtemp netcat)
+ $(use_enable acpi procacpi)
+ $(use_enable acpi sysfsacpi)
+ $(use_enable video_cards_nvidia xnvctrl)
+ $(use_enable libnotify notification)
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS NOTES README TODO )
+}
+
+src_prepare() {
+ sed -i -e '/-no-undefined/d' src/Makefile.am || die
+
+ # Use flags from xfce4-dev-tools instead of defining them again in
+ # configure.in wrt #386979
+ # Remove AC_PROG_LIBTOOL because LT_INIT([disable-static]) is also present:
+ # http://bugzilla.xfce.org/show_bug.cgi?id=8888
+ # Use AC_CONFIG_HEADERS for automake-1.13 compability, see:
+ # http://bugzilla.xfce.org/show_bug.cgi?id=10031
+ sed -i \
+ -e '/PLATFORM_CFLAGS/s:-Werror::' \
+ configure.ac || die
+
+ xfconf_src_prepare
+}