summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-05-09 17:52:10 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-05-09 17:52:10 +0000
commit87e58f0d834356b14ce4ab93148fc29912891c7b (patch)
tree88a3ae8a8681b3e47b2e3dcca96fc36a4f8b469c
parentAdd epatch_user wrt bug #447714. (diff)
downloadgentoo-2-87e58f0d834356b14ce4ab93148fc29912891c7b.tar.gz
gentoo-2-87e58f0d834356b14ce4ab93148fc29912891c7b.tar.bz2
gentoo-2-87e58f0d834356b14ce4ab93148fc29912891c7b.zip
Version bump.
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
-rw-r--r--app-arch/unrar/ChangeLog7
-rw-r--r--app-arch/unrar/unrar-5.0.3.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/app-arch/unrar/ChangeLog b/app-arch/unrar/ChangeLog
index d788960ceedd..072f3ce61a98 100644
--- a/app-arch/unrar/ChangeLog
+++ b/app-arch/unrar/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/unrar
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/unrar/ChangeLog,v 1.199 2013/05/01 11:35:06 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unrar/ChangeLog,v 1.200 2013/05/09 17:52:10 ssuominen Exp $
+
+*unrar-5.0.3 (09 May 2013)
+
+ 09 May 2013; Samuli Suominen <ssuominen@gentoo.org> +unrar-5.0.3.ebuild:
+ Version bump.
01 May 2013; Samuli Suominen <ssuominen@gentoo.org> -unrar-4.2.3.ebuild:
old
diff --git a/app-arch/unrar/unrar-5.0.3.ebuild b/app-arch/unrar/unrar-5.0.3.ebuild
new file mode 100644
index 000000000000..9ad761b26664
--- /dev/null
+++ b/app-arch/unrar/unrar-5.0.3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unrar/unrar-5.0.3.ebuild,v 1.1 2013/05/09 17:52:10 ssuominen Exp $
+
+EAPI=5
+inherit eutils flag-o-matic multilib toolchain-funcs
+
+MY_PN=${PN}src
+
+DESCRIPTION="Uncompress rar files"
+HOMEPAGE="http://www.rarlab.com/rar_add.htm"
+SRC_URI="http://www.rarlab.com/rar/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="unRAR"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~arm-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="!<=app-arch/unrar-gpl-0.0.1_p20080417"
+
+S=${WORKDIR}/unrar
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-5.0.2-build.patch
+ sed -i \
+ -e "/libunrar/s:.so:$(get_libname ${PV%.*.*}):" \
+ -e "s:-shared:& -Wl,-soname -Wl,libunrar$(get_libname ${PV%.*.*}):" \
+ makefile || die
+}
+
+src_compile() {
+ unrar_make() {
+ emake CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS}" STRIP=true "$@"
+ }
+
+ unrar_make CXXFLAGS+=" -fPIC" lib
+ ln -s libunrar$(get_libname ${PV%.*.*}) libunrar$(get_libname)
+ ln -s libunrar$(get_libname ${PV%.*.*}) libunrar$(get_libname ${PV})
+
+ # The stupid code compiles a lot of objects differently if
+ # they're going into a lib (-DRARDLL) or into the main app.
+ # So for now, we can't link the main app against the lib.
+ unrar_make clean
+ unrar_make
+}
+
+src_install() {
+ dobin unrar
+ dodoc readme.txt
+
+ dolib.so libunrar*
+
+ insinto /usr/include/libunrar${PV%.*.*}
+ doins *.hpp
+ dosym libunrar${PV%.*.*} /usr/include/libunrar
+}