summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-09-17 04:58:31 +0000
committerJeroen Roovers <jer@gentoo.org>2010-09-17 04:58:31 +0000
commit8ab9bddc8237ef12fc6cb4b24f3122943ab968f3 (patch)
tree70da37c23d210dc15c413e2fc4e25016523b9c1e
parentRemove zphoto (bug #332559). (diff)
downloadgentoo-2-8ab9bddc8237ef12fc6cb4b24f3122943ab968f3.tar.gz
gentoo-2-8ab9bddc8237ef12fc6cb4b24f3122943ab968f3.tar.bz2
gentoo-2-8ab9bddc8237ef12fc6cb4b24f3122943ab968f3.zip
Set RDEPEND. Introduce USE=debug. Respect LDFLAGS (bug #335379).
(Portage version: 2.2_rc82/cvs/Linux i686)
-rw-r--r--app-shells/esh/ChangeLog7
-rw-r--r--app-shells/esh/esh-0.8.5-r1.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/app-shells/esh/ChangeLog b/app-shells/esh/ChangeLog
index be8b111077a6..eb5853ce30bf 100644
--- a/app-shells/esh/ChangeLog
+++ b/app-shells/esh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-shells/esh
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/esh/ChangeLog,v 1.19 2010/06/15 16:31:28 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/esh/ChangeLog,v 1.20 2010/09/17 04:58:31 jer Exp $
+
+*esh-0.8.5-r1 (17 Sep 2010)
+
+ 17 Sep 2010; Jeroen Roovers <jer@gentoo.org> +esh-0.8.5-r1.ebuild:
+ Set RDEPEND. Introduce USE=debug. Respect LDFLAGS (bug #335379).
15 Jun 2010; Markos Chandras <hwoarang@gentoo.org> esh-0.8.5.ebuild:
Fix documentation typo wrt bug #314107.Keyworded for amd64
diff --git a/app-shells/esh/esh-0.8.5-r1.ebuild b/app-shells/esh/esh-0.8.5-r1.ebuild
new file mode 100644
index 000000000000..e6514ea6ba08
--- /dev/null
+++ b/app-shells/esh/esh-0.8.5-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/esh/esh-0.8.5-r1.ebuild,v 1.1 2010/09/17 04:58:31 jer Exp $
+
+EAPI="2"
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="A UNIX Shell with a simplified Scheme syntax"
+HOMEPAGE="http://slon.ttk.ru/esh/"
+SRC_URI="http://slon.ttk.ru/esh/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="debug"
+
+DEPEND=">=sys-libs/ncurses-5.1
+ >=sys-libs/readline-4.1"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ sed -i \
+ -e 's|-g ||' \
+ -e 's|-DMEM_DEBUG ||' \
+ -e 's|^CFLAGS|&+|g' \
+ -e 's|^LIB=|LIB= -lncurses |' \
+ -e 's|$(CC) |&$(CFLAGS) $(LDFLAGS) |g' \
+ -e 's:-ltermcap::' \
+ Makefile || die "sed Makefile"
+ }
+src_compile() {
+ # For some reason, this tarball has binary files in it for x86.
+ # Make clean so we can rebuild for our arch and optimization.
+ emake clean
+
+ use debug && append-flags -DMEM_DEBUG
+
+ emake \
+ CC="$(tc-getCC)" \
+ LDFLAGS="${LDFLAGS}" \
+ || die "emake failed"
+}
+
+src_install() {
+ dobin esh || die
+ doinfo doc/esh.info
+ dodoc CHANGELOG CREDITS GC_README HEADER READLINE-HACKS TODO
+ dohtml doc/*.html
+ docinto examples
+ dodoc examples/*
+ insinto /usr/share/emacs/site-lisp/
+ doins emacs/esh-mode.el
+}