summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-04-20 04:38:40 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-04-20 04:38:40 +0000
commit8b856b139ccbe21b2de189b4b24a3758201539f4 (patch)
treed51c220a93e7780326b1b6b327481ba11699e603
parentCleanup (diff)
downloadgentoo-2-8b856b139ccbe21b2de189b4b24a3758201539f4.tar.gz
gentoo-2-8b856b139ccbe21b2de189b4b24a3758201539f4.tar.bz2
gentoo-2-8b856b139ccbe21b2de189b4b24a3758201539f4.zip
Cleanup
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
-rw-r--r--app-admin/apache-tools/ChangeLog8
-rw-r--r--app-admin/apache-tools/apache-tools-2.2.14.ebuild92
-rw-r--r--app-admin/apache-tools/apache-tools-2.2.15.ebuild92
-rw-r--r--app-admin/apache-tools/apache-tools-2.2.16.ebuild92
-rw-r--r--app-admin/apache-tools/apache-tools-2.2.17.ebuild92
-rw-r--r--app-admin/apache-tools/apache-tools-2.2.20.ebuild89
-rw-r--r--app-admin/apache-tools/apache-tools-2.2.21.ebuild89
-rw-r--r--app-admin/apache-tools/apache-tools-2.4.1.ebuild80
8 files changed, 7 insertions, 627 deletions
diff --git a/app-admin/apache-tools/ChangeLog b/app-admin/apache-tools/ChangeLog
index deb16f4de93d..8db5b574b098 100644
--- a/app-admin/apache-tools/ChangeLog
+++ b/app-admin/apache-tools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/apache-tools
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/apache-tools/ChangeLog,v 1.116 2012/04/20 04:00:31 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/apache-tools/ChangeLog,v 1.117 2012/04/20 04:38:40 patrick Exp $
+
+ 20 Apr 2012; Patrick Lauer <patrick@gentoo.org> -apache-tools-2.2.14.ebuild,
+ -apache-tools-2.2.15.ebuild, -apache-tools-2.2.16.ebuild,
+ -apache-tools-2.2.17.ebuild, -apache-tools-2.2.20.ebuild,
+ -apache-tools-2.2.21.ebuild, -apache-tools-2.4.1.ebuild:
+ Cleanup
*apache-tools-2.4.2 (20 Apr 2012)
diff --git a/app-admin/apache-tools/apache-tools-2.2.14.ebuild b/app-admin/apache-tools/apache-tools-2.2.14.ebuild
deleted file mode 100644
index 7e7c19b04f4b..000000000000
--- a/app-admin/apache-tools/apache-tools-2.2.14.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/apache-tools/apache-tools-2.2.14.ebuild,v 1.9 2011/10/14 16:25:46 beandog Exp $
-
-inherit flag-o-matic eutils
-
-DESCRIPTION="Useful Apache tools - htdigest, htpasswd, ab, htdbm"
-HOMEPAGE="http://httpd.apache.org/"
-SRC_URI="mirror://apache/httpd/httpd-${PV}.tar.bz2"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="ssl"
-RESTRICT="test"
-
-RDEPEND="=dev-libs/apr-1*
- =dev-libs/apr-util-1*
- dev-libs/libpcre
- ssl? ( dev-libs/openssl )
- !<www-servers/apache-2.2.4"
-
-DEPEND="${RDEPEND}
- sys-devel/libtool"
-
-S="${WORKDIR}/httpd-${PV}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Apply these patches:
- # (1) apache-tools-Makefile.patch:
- # - fix up the `make install' for support/
- # - remove envvars from `make install'
- epatch "${FILESDIR}"/${PN}-Makefile.patch
-}
-
-src_compile() {
- local myconf=""
- cd "${S}"
-
- # Instead of filtering --as-needed (bug #128505), append --no-as-needed
- # Thanks to Harald van Dijk
- append-ldflags $(no-as-needed)
-
- if use ssl ; then
- myconf="${myconf} --with-ssl=/usr --enable-ssl"
- fi
-
- # econf overwrites the stuff from config.layout, so we have to put them into
- # our myconf line too
- econf \
- --sbindir=/usr/sbin \
- --with-z=/usr \
- --with-apr=/usr \
- --with-apr-util=/usr \
- --with-pcre=/usr \
- ${myconf} || die "econf failed!"
-
- cd support
- emake || die "emake support/ failed!"
-}
-
-src_install () {
- cd "${S}"/support
-
- make DESTDIR="${D}" install || die "make install failed!"
-
- # install manpages
- doman "${S}"/docs/man/{dbmmanage,htdigest,htpasswd,htdbm}.1 \
- "${S}"/docs/man/{ab,htcacheclean,logresolve,rotatelogs}.8
-
- # Providing compatiblity symlinks for #177697 (which we'll stop to install
- # at some point).
-
- for i in $(ls "${D}"/usr/sbin 2>/dev/null); do
- dosym /usr/sbin/${i} /usr/sbin/${i}2
- done
-
- # Provide a symlink for ab-ssl
- if use ssl ; then
- dosym /usr/sbin/ab /usr/sbin/ab-ssl
- dosym /usr/sbin/ab /usr/sbin/ab2-ssl
- fi
-
- # make htpasswd accessible for non-root users
- dosym /usr/sbin/htpasswd /usr/bin/htpasswd
- dosym /usr/sbin/htdigest /usr/bin/htdigest
-
- dodoc "${S}"/CHANGES
-}
diff --git a/app-admin/apache-tools/apache-tools-2.2.15.ebuild b/app-admin/apache-tools/apache-tools-2.2.15.ebuild
deleted file mode 100644
index af225e1e5b6a..000000000000
--- a/app-admin/apache-tools/apache-tools-2.2.15.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/apache-tools/apache-tools-2.2.15.ebuild,v 1.8 2011/10/14 16:25:46 beandog Exp $
-
-inherit flag-o-matic eutils
-
-DESCRIPTION="Useful Apache tools - htdigest, htpasswd, ab, htdbm"
-HOMEPAGE="http://httpd.apache.org/"
-SRC_URI="mirror://apache/httpd/httpd-${PV}.tar.bz2"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="ssl"
-RESTRICT="test"
-
-RDEPEND="=dev-libs/apr-1*
- =dev-libs/apr-util-1*
- dev-libs/libpcre
- ssl? ( dev-libs/openssl )
- !<www-servers/apache-2.2.4"
-
-DEPEND="${RDEPEND}
- sys-devel/libtool"
-
-S="${WORKDIR}/httpd-${PV}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Apply these patches:
- # (1) apache-tools-Makefile.patch:
- # - fix up the `make install' for support/
- # - remove envvars from `make install'
- epatch "${FILESDIR}"/${PN}-Makefile.patch
-}
-
-src_compile() {
- local myconf=""
- cd "${S}"
-
- # Instead of filtering --as-needed (bug #128505), append --no-as-needed
- # Thanks to Harald van Dijk
- append-ldflags $(no-as-needed)
-
- if use ssl ; then
- myconf="${myconf} --with-ssl=/usr --enable-ssl"
- fi
-
- # econf overwrites the stuff from config.layout, so we have to put them into
- # our myconf line too
- econf \
- --sbindir=/usr/sbin \
- --with-z=/usr \
- --with-apr=/usr \
- --with-apr-util=/usr \
- --with-pcre=/usr \
- ${myconf} || die "econf failed!"
-
- cd support
- emake || die "emake support/ failed!"
-}
-
-src_install () {
- cd "${S}"/support
-
- make DESTDIR="${D}" install || die "make install failed!"
-
- # install manpages
- doman "${S}"/docs/man/{dbmmanage,htdigest,htpasswd,htdbm}.1 \
- "${S}"/docs/man/{ab,htcacheclean,logresolve,rotatelogs}.8
-
- # Providing compatiblity symlinks for #177697 (which we'll stop to install
- # at some point).
-
- for i in $(ls "${D}"/usr/sbin 2>/dev/null); do
- dosym /usr/sbin/${i} /usr/sbin/${i}2
- done
-
- # Provide a symlink for ab-ssl
- if use ssl ; then
- dosym /usr/sbin/ab /usr/sbin/ab-ssl
- dosym /usr/sbin/ab /usr/sbin/ab2-ssl
- fi
-
- # make htpasswd accessible for non-root users
- dosym /usr/sbin/htpasswd /usr/bin/htpasswd
- dosym /usr/sbin/htdigest /usr/bin/htdigest
-
- dodoc "${S}"/CHANGES
-}
diff --git a/app-admin/apache-tools/apache-tools-2.2.16.ebuild b/app-admin/apache-tools/apache-tools-2.2.16.ebuild
deleted file mode 100644
index 78eb6d43ab20..000000000000
--- a/app-admin/apache-tools/apache-tools-2.2.16.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/apache-tools/apache-tools-2.2.16.ebuild,v 1.8 2011/10/14 16:25:46 beandog Exp $
-
-inherit flag-o-matic eutils
-
-DESCRIPTION="Useful Apache tools - htdigest, htpasswd, ab, htdbm"
-HOMEPAGE="http://httpd.apache.org/"
-SRC_URI="mirror://apache/httpd/httpd-${PV}.tar.bz2"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="ssl"
-RESTRICT="test"
-
-RDEPEND="=dev-libs/apr-1*
- =dev-libs/apr-util-1*
- dev-libs/libpcre
- ssl? ( dev-libs/openssl )
- !<www-servers/apache-2.2.4"
-
-DEPEND="${RDEPEND}
- sys-devel/libtool"
-
-S="${WORKDIR}/httpd-${PV}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Apply these patches:
- # (1) apache-tools-Makefile.patch:
- # - fix up the `make install' for support/
- # - remove envvars from `make install'
- epatch "${FILESDIR}"/${PN}-Makefile.patch
-}
-
-src_compile() {
- local myconf=""
- cd "${S}"
-
- # Instead of filtering --as-needed (bug #128505), append --no-as-needed
- # Thanks to Harald van Dijk
- append-ldflags $(no-as-needed)
-
- if use ssl ; then
- myconf="${myconf} --with-ssl=/usr --enable-ssl"
- fi
-
- # econf overwrites the stuff from config.layout, so we have to put them into
- # our myconf line too
- econf \
- --sbindir=/usr/sbin \
- --with-z=/usr \
- --with-apr=/usr \
- --with-apr-util=/usr \
- --with-pcre=/usr \
- ${myconf} || die "econf failed!"
-
- cd support
- emake || die "emake support/ failed!"
-}
-
-src_install () {
- cd "${S}"/support
-
- make DESTDIR="${D}" install || die "make install failed!"
-
- # install manpages
- doman "${S}"/docs/man/{dbmmanage,htdigest,htpasswd,htdbm}.1 \
- "${S}"/docs/man/{ab,htcacheclean,logresolve,rotatelogs}.8
-
- # Providing compatiblity symlinks for #177697 (which we'll stop to install
- # at some point).
-
- for i in $(ls "${D}"/usr/sbin 2>/dev/null); do
- dosym /usr/sbin/${i} /usr/sbin/${i}2
- done
-
- # Provide a symlink for ab-ssl
- if use ssl ; then
- dosym /usr/sbin/ab /usr/sbin/ab-ssl
- dosym /usr/sbin/ab /usr/sbin/ab2-ssl
- fi
-
- # make htpasswd accessible for non-root users
- dosym /usr/sbin/htpasswd /usr/bin/htpasswd
- dosym /usr/sbin/htdigest /usr/bin/htdigest
-
- dodoc "${S}"/CHANGES
-}
diff --git a/app-admin/apache-tools/apache-tools-2.2.17.ebuild b/app-admin/apache-tools/apache-tools-2.2.17.ebuild
deleted file mode 100644
index 7c6da8168c0e..000000000000
--- a/app-admin/apache-tools/apache-tools-2.2.17.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/apache-tools/apache-tools-2.2.17.ebuild,v 1.9 2011/10/14 16:25:46 beandog Exp $
-
-inherit flag-o-matic eutils
-
-DESCRIPTION="Useful Apache tools - htdigest, htpasswd, ab, htdbm"
-HOMEPAGE="http://httpd.apache.org/"
-SRC_URI="mirror://apache/httpd/httpd-${PV}.tar.bz2"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="ssl"
-RESTRICT="test"
-
-RDEPEND="=dev-libs/apr-1*
- =dev-libs/apr-util-1*
- dev-libs/libpcre
- ssl? ( dev-libs/openssl )
- !<www-servers/apache-2.2.4"
-
-DEPEND="${RDEPEND}
- sys-devel/libtool"
-
-S="${WORKDIR}/httpd-${PV}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Apply these patches:
- # (1) apache-tools-Makefile.patch:
- # - fix up the `make install' for support/
- # - remove envvars from `make install'
- epatch "${FILESDIR}"/${PN}-Makefile.patch
-}
-
-src_compile() {
- local myconf=""
- cd "${S}"
-
- # Instead of filtering --as-needed (bug #128505), append --no-as-needed
- # Thanks to Harald van Dijk
- append-ldflags $(no-as-needed)
-
- if use ssl ; then
- myconf="${myconf} --with-ssl=/usr --enable-ssl"
- fi
-
- # econf overwrites the stuff from config.layout, so we have to put them into
- # our myconf line too
- econf \
- --sbindir=/usr/sbin \
- --with-z=/usr \
- --with-apr=/usr \
- --with-apr-util=/usr \
- --with-pcre=/usr \
- ${myconf} || die "econf failed!"
-
- cd support
- emake || die "emake support/ failed!"
-}
-
-src_install () {
- cd "${S}"/support
-
- make DESTDIR="${D}" install || die "make install failed!"
-
- # install manpages
- doman "${S}"/docs/man/{dbmmanage,htdigest,htpasswd,htdbm}.1 \
- "${S}"/docs/man/{ab,htcacheclean,logresolve,rotatelogs}.8
-
- # Providing compatiblity symlinks for #177697 (which we'll stop to install
- # at some point).
-
- for i in $(ls "${D}"/usr/sbin 2>/dev/null); do
- dosym /usr/sbin/${i} /usr/sbin/${i}2
- done
-
- # Provide a symlink for ab-ssl
- if use ssl ; then
- dosym /usr/sbin/ab /usr/sbin/ab-ssl
- dosym /usr/sbin/ab /usr/sbin/ab2-ssl
- fi
-
- # make htpasswd accessible for non-root users
- dosym /usr/sbin/htpasswd /usr/bin/htpasswd
- dosym /usr/sbin/htdigest /usr/bin/htdigest
-
- dodoc "${S}"/CHANGES
-}
diff --git a/app-admin/apache-tools/apache-tools-2.2.20.ebuild b/app-admin/apache-tools/apache-tools-2.2.20.ebuild
deleted file mode 100644
index 4e8386cbd20e..000000000000
--- a/app-admin/apache-tools/apache-tools-2.2.20.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/apache-tools/apache-tools-2.2.20.ebuild,v 1.7 2011/10/14 16:25:46 beandog Exp $
-
-EAPI="4"
-inherit flag-o-matic eutils
-
-DESCRIPTION="Useful Apache tools - htdigest, htpasswd, ab, htdbm"
-HOMEPAGE="http://httpd.apache.org/"
-SRC_URI="mirror://apache/httpd/httpd-${PV}.tar.bz2"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="ssl"
-RESTRICT="test"
-
-RDEPEND="=dev-libs/apr-1*
- =dev-libs/apr-util-1*
- dev-libs/libpcre
- ssl? ( dev-libs/openssl )
- !<www-servers/apache-2.2.4"
-
-DEPEND="${RDEPEND}
- sys-devel/libtool"
-
-S="${WORKDIR}/httpd-${PV}"
-
-src_prepare() {
- # Apply these patches:
- # (1) apache-tools-2.2.20-Makefile.patch:
- # - fix up the `make install' for support/
- # - remove envvars from `make install'
- epatch "${FILESDIR}"/${PN}-2.2.20-Makefile.patch
-}
-
-src_configure() {
- local myconf=""
-
- # Instead of filtering --as-needed (bug #128505), append --no-as-needed
- append-ldflags $(no-as-needed)
-
- use ssl && myconf+=" --with-ssl=/usr --enable-ssl"
-
- # econf overwrites the stuff from config.layout, so we have to put them into
- # our myconf line too
- econf \
- --sbindir=/usr/sbin \
- --with-z=/usr \
- --with-apr=/usr \
- --with-apr-util=/usr \
- --with-pcre=/usr \
- ${myconf}
-}
-
-src_compile() {
- cd support || die
- emake
-}
-
-src_install () {
- cd support || die
-
- make DESTDIR="${D}" install
-
- # install manpages
- doman "${S}"/docs/man/{dbmmanage,htdigest,htpasswd,htdbm}.1 \
- "${S}"/docs/man/{ab,htcacheclean,logresolve,rotatelogs}.8
-
- # Providing compatiblity symlinks for #177697 (which we'll stop to install
- # at some point).
- pushd "${D}"/usr/sbin/ >/dev/null
- for i in *; do
- dosym /usr/sbin/${i} /usr/sbin/${i}2
- done
- popd "${D}"/usr/sbin/ >/dev/null
-
- # Provide a symlink for ab-ssl
- if use ssl; then
- dosym /usr/sbin/ab /usr/sbin/ab-ssl
- dosym /usr/sbin/ab /usr/sbin/ab2-ssl
- fi
-
- # make htpasswd accessible for non-root users
- dosym /usr/sbin/htpasswd /usr/bin/htpasswd
- dosym /usr/sbin/htdigest /usr/bin/htdigest
-
- dodoc "${S}"/CHANGES
-}
diff --git a/app-admin/apache-tools/apache-tools-2.2.21.ebuild b/app-admin/apache-tools/apache-tools-2.2.21.ebuild
deleted file mode 100644
index 2b597ef0fdba..000000000000
--- a/app-admin/apache-tools/apache-tools-2.2.21.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/apache-tools/apache-tools-2.2.21.ebuild,v 1.7 2011/10/14 16:25:46 beandog Exp $
-
-EAPI="4"
-inherit flag-o-matic eutils
-
-DESCRIPTION="Useful Apache tools - htdigest, htpasswd, ab, htdbm"
-HOMEPAGE="http://httpd.apache.org/"
-SRC_URI="mirror://apache/httpd/httpd-${PV}.tar.bz2"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="ssl"
-RESTRICT="test"
-
-RDEPEND="=dev-libs/apr-1*
- =dev-libs/apr-util-1*
- dev-libs/libpcre
- ssl? ( dev-libs/openssl )
- !<www-servers/apache-2.2.4"
-
-DEPEND="${RDEPEND}
- sys-devel/libtool"
-
-S="${WORKDIR}/httpd-${PV}"
-
-src_prepare() {
- # Apply these patches:
- # (1) apache-tools-2.2.20-Makefile.patch:
- # - fix up the `make install' for support/
- # - remove envvars from `make install'
- epatch "${FILESDIR}"/${PN}-2.2.20-Makefile.patch
-}
-
-src_configure() {
- local myconf=""
-
- # Instead of filtering --as-needed (bug #128505), append --no-as-needed
- append-ldflags $(no-as-needed)
-
- use ssl && myconf+=" --with-ssl=/usr --enable-ssl"
-
- # econf overwrites the stuff from config.layout, so we have to put them into
- # our myconf line too
- econf \
- --sbindir=/usr/sbin \
- --with-z=/usr \
- --with-apr=/usr \
- --with-apr-util=/usr \
- --with-pcre=/usr \
- ${myconf}
-}
-
-src_compile() {
- cd support || die
- emake
-}
-
-src_install () {
- cd support || die
-
- make DESTDIR="${D}" install
-
- # install manpages
- doman "${S}"/docs/man/{dbmmanage,htdigest,htpasswd,htdbm}.1 \
- "${S}"/docs/man/{ab,htcacheclean,logresolve,rotatelogs}.8
-
- # Providing compatiblity symlinks for #177697 (which we'll stop to install
- # at some point).
- pushd "${D}"/usr/sbin/ >/dev/null
- for i in *; do
- dosym /usr/sbin/${i} /usr/sbin/${i}2
- done
- popd "${D}"/usr/sbin/ >/dev/null
-
- # Provide a symlink for ab-ssl
- if use ssl; then
- dosym /usr/sbin/ab /usr/sbin/ab-ssl
- dosym /usr/sbin/ab /usr/sbin/ab2-ssl
- fi
-
- # make htpasswd accessible for non-root users
- dosym /usr/sbin/htpasswd /usr/bin/htpasswd
- dosym /usr/sbin/htdigest /usr/bin/htdigest
-
- dodoc "${S}"/CHANGES
-}
diff --git a/app-admin/apache-tools/apache-tools-2.4.1.ebuild b/app-admin/apache-tools/apache-tools-2.4.1.ebuild
deleted file mode 100644
index 3ca6dd5d13ce..000000000000
--- a/app-admin/apache-tools/apache-tools-2.4.1.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/apache-tools/apache-tools-2.4.1.ebuild,v 1.1 2012/04/01 04:51:41 patrick Exp $
-
-EAPI="2"
-inherit flag-o-matic eutils
-
-DESCRIPTION="Useful Apache tools - htdigest, htpasswd, ab, htdbm"
-HOMEPAGE="http://httpd.apache.org/"
-SRC_URI="mirror://apache/httpd/httpd-${PV}.tar.bz2"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="ssl"
-RESTRICT="test"
-
-RDEPEND="=dev-libs/apr-1*
- =dev-libs/apr-util-1*
- dev-libs/libpcre
- ssl? ( dev-libs/openssl )"
-
-DEPEND="${RDEPEND}
- sys-devel/libtool"
-
-S="${WORKDIR}/httpd-${PV}"
-
-src_configure() {
- local myconf=""
-
- # Instead of filtering --as-needed (bug #128505), append --no-as-needed
- append-ldflags $(no-as-needed)
-
- use ssl && myconf+=" --with-ssl=/usr --enable-ssl"
-
- # econf overwrites the stuff from config.layout, so we have to put them into
- # our myconf line too
- econf \
- --sbindir=/usr/sbin \
- --with-z=/usr \
- --with-apr=/usr \
- --with-apr-util=/usr \
- --with-pcre=/usr \
- ${myconf}
-}
-
-src_compile() {
- cd support || die
- emake
-}
-
-src_install () {
- cd support || die
-
- make DESTDIR="${D}" install
-
- # install manpages
- doman "${S}"/docs/man/{dbmmanage,htdigest,htpasswd,htdbm,ab,logresolve}.1 \
- "${S}"/docs/man/{htcacheclean,rotatelogs}.8
-
- # Providing compatiblity symlinks for #177697 (which we'll stop to install
- # at some point).
- pushd "${D}"/usr/sbin/ >/dev/null
- for i in *; do
- dosym /usr/sbin/${i} /usr/sbin/${i}2
- done
- popd "${D}"/usr/sbin/ >/dev/null
-
- # Provide a symlink for ab-ssl
- if use ssl; then
- dosym /usr/sbin/ab /usr/sbin/ab-ssl
- dosym /usr/sbin/ab /usr/sbin/ab2-ssl
- fi
-
- # make htpasswd accessible for non-root users
- dosym /usr/sbin/htpasswd /usr/bin/htpasswd
- dosym /usr/sbin/htdigest /usr/bin/htdigest
-
- dodoc "${S}"/CHANGES
-}