summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLance Albertson <ramereth@gentoo.org>2010-03-07 21:03:00 +0000
committerLance Albertson <ramereth@gentoo.org>2010-03-07 21:03:00 +0000
commit8bc8a750f615638463ef295baa234430cb31023a (patch)
tree1e3b88df36ed9edb3dc4ebfed13bafb955fbffda
parentInitial commit wrt #253200, thanks to Arthur Nascimento, Gary Hunt, Joshua Ri... (diff)
downloadgentoo-2-8bc8a750f615638463ef295baa234430cb31023a.tar.gz
gentoo-2-8bc8a750f615638463ef295baa234430cb31023a.tar.bz2
gentoo-2-8bc8a750f615638463ef295baa234430cb31023a.zip
Version bump
(Portage version: 2.1.7.16/cvs/Linux x86_64)
-rw-r--r--app-emulation/ganeti-instance-debootstrap/ChangeLog13
-rw-r--r--app-emulation/ganeti-instance-debootstrap/ganeti-instance-debootstrap-0.8.ebuild33
2 files changed, 42 insertions, 4 deletions
diff --git a/app-emulation/ganeti-instance-debootstrap/ChangeLog b/app-emulation/ganeti-instance-debootstrap/ChangeLog
index cc0acb3e31c2..0fce7bdf55d5 100644
--- a/app-emulation/ganeti-instance-debootstrap/ChangeLog
+++ b/app-emulation/ganeti-instance-debootstrap/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/ganeti-instance-debootstrap
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti-instance-debootstrap/ChangeLog,v 1.1 2009/10/02 22:41:27 ramereth Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti-instance-debootstrap/ChangeLog,v 1.2 2010/03/07 21:03:00 ramereth Exp $
+
+*ganeti-instance-debootstrap-0.8 (07 Mar 2010)
+
+ 07 Mar 2010; Lance Albertson <ramereth@gentoo.org>
+ +ganeti-instance-debootstrap-0.8.ebuild:
+ Version bump
*ganeti-instance-debootstrap-0.7 (02 Oct 2009)
@@ -10,7 +16,6 @@
+metadata.xml:
Initial ebuild
- Special thanks to Russell Haering <russell_h@osuosl.org> for submitting
- the
+ Special thanks to Russell Haering <russell_h@osuosl.org> for submitting the
ebuild.
diff --git a/app-emulation/ganeti-instance-debootstrap/ganeti-instance-debootstrap-0.8.ebuild b/app-emulation/ganeti-instance-debootstrap/ganeti-instance-debootstrap-0.8.ebuild
new file mode 100644
index 000000000000..047a8aec4703
--- /dev/null
+++ b/app-emulation/ganeti-instance-debootstrap/ganeti-instance-debootstrap-0.8.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti-instance-debootstrap/ganeti-instance-debootstrap-0.8.ebuild,v 1.1 2010/03/07 21:03:00 ramereth Exp $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="Scripts to build Ganeti VMs with debootstrap"
+HOMEPAGE="http://code.google.com/p/ganeti/"
+SRC_URI="http://ganeti.googlecode.com/files/ganeti-instance-debootstrap-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="app-arch/dpkg
+ app-arch/dump
+ app-emulation/ganeti
+ dev-util/debootstrap
+ || ( >=sys-apps/coreutils-6.10-r1 sys-apps/mktemp )
+ sys-apps/util-linux
+ sys-fs/e2fsprogs"
+
+src_configure() {
+ econf --docdir=/usr/share/doc/${P} || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+}