summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2006-11-05 17:54:22 +0000
committerDoug Goldstein <cardoe@gentoo.org>2006-11-05 17:54:22 +0000
commit8d298aef51e59faaef277c4cd59cea782f775829 (patch)
treea75c1e5fbdf48436e338b4ac46c7354cfedf91b0
parentThis also closes bug #110901. (diff)
downloadgentoo-2-8d298aef51e59faaef277c4cd59cea782f775829.tar.gz
gentoo-2-8d298aef51e59faaef277c4cd59cea782f775829.tar.bz2
gentoo-2-8d298aef51e59faaef277c4cd59cea782f775829.zip
Apply patch from FreeDesktop.org bug #8298 for FreeBSD support. Removed an unnecessary patch and comment from 0.62 since we switched to expat from libxml.
(Portage version: 2.1.2_rc1-r3)
-rw-r--r--sys-apps/dbus/ChangeLog9
-rw-r--r--sys-apps/dbus/dbus-0.62-r1.ebuild6
-rw-r--r--sys-apps/dbus/dbus-0.95.ebuild10
-rw-r--r--sys-apps/dbus/files/dbus-0.95-pass-context.patch11
4 files changed, 29 insertions, 7 deletions
diff --git a/sys-apps/dbus/ChangeLog b/sys-apps/dbus/ChangeLog
index 97a064aab277..ee44482965a8 100644
--- a/sys-apps/dbus/ChangeLog
+++ b/sys-apps/dbus/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/dbus
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/ChangeLog,v 1.143 2006/11/05 09:07:13 iluxa Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/ChangeLog,v 1.144 2006/11/05 17:54:22 cardoe Exp $
+
+ 05 Nov 2006; Doug Goldstein <cardoe@gentoo.org>
+ +files/dbus-0.95-pass-context.patch, dbus-0.62-r1.ebuild,
+ dbus-0.95.ebuild:
+ Apply patch from FreeDesktop.org bug #8298 for FreeBSD support. Removed an
+ unnecessary patch and comment from 0.62 since we switched to expat from
+ libxml.
*dbus-0.95 (05 Nov 2006)
diff --git a/sys-apps/dbus/dbus-0.62-r1.ebuild b/sys-apps/dbus/dbus-0.62-r1.ebuild
index 6da64eb0e08d..16f4a389fe2f 100644
--- a/sys-apps/dbus/dbus-0.62-r1.ebuild
+++ b/sys-apps/dbus/dbus-0.62-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/dbus-0.62-r1.ebuild,v 1.5 2006/11/03 02:14:41 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/dbus-0.62-r1.ebuild,v 1.6 2006/11/05 17:54:22 cardoe Exp $
WANT_AUTOCONF=2.5
inherit eutils mono python multilib debug qt3 autotools
@@ -23,7 +23,6 @@ RDEPEND=">=dev-libs/glib-2.6
qt4? ( =x11-libs/qt-4.1* )
selinux? ( sys-libs/libselinux )
>=dev-libs/expat-1.95.8"
- # expat code now sucks.. libxml2 is the default
DEPEND="${RDEPEND}
dev-util/pkgconfig
@@ -42,9 +41,6 @@ src_unpack() {
#fix mono-tools depend
epatch "${FILESDIR}"/${PN}-0.61-mono-tools-update.diff
- #fix libxml dep
- epatch "${FILESDIR}"/${PN}-0.61-libxml-dep.patch
-
eautoreconf
}
diff --git a/sys-apps/dbus/dbus-0.95.ebuild b/sys-apps/dbus/dbus-0.95.ebuild
index 4974a9cee9ca..3c5f6edb9252 100644
--- a/sys-apps/dbus/dbus-0.95.ebuild
+++ b/sys-apps/dbus/dbus-0.95.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/dbus-0.95.ebuild,v 1.1 2006/11/05 07:07:26 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/dbus-0.95.ebuild,v 1.2 2006/11/05 17:54:22 cardoe Exp $
WANT_AUTOCONF=2.5
inherit eutils multilib debug autotools
@@ -24,6 +24,14 @@ DEPEND="${RDEPEND}
doc? ( app-doc/doxygen
app-text/xmlto )"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ #Fix for FreeBSD
+ epatch "${FILESDIR}"/${P}-pass-context.patch
+}
+
src_compile() {
local myconf=""
diff --git a/sys-apps/dbus/files/dbus-0.95-pass-context.patch b/sys-apps/dbus/files/dbus-0.95-pass-context.patch
new file mode 100644
index 000000000000..1e5612198c19
--- /dev/null
+++ b/sys-apps/dbus/files/dbus-0.95-pass-context.patch
@@ -0,0 +1,11 @@
+--- /home/drizzt/dbus-0.95/bus/bus.c.old 2006-11-04 20:41:44 +0000
++++ /home/drizzt/dbus-0.95/bus/bus.c 2006-11-04 20:41:57 +0000
+@@ -517,7 +517,7 @@
+ /* Watch all conf directories */
+ _dbus_list_foreach (bus_config_parser_get_conf_dirs (parser),
+ (DBusForeachFunction) bus_watch_directory,
+- NULL);
++ context);
+
+ return TRUE;
+ }