summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2009-05-20 01:51:23 +0000
committerDenis Dupeyron <calchan@gentoo.org>2009-05-20 01:51:23 +0000
commit8d2afe247a1e1e2af8da9e99a71270d7637a8117 (patch)
treeca153021ac17349747fdb3ae7971fe14241e0080
parentDepend on SLOT=0 of dev-libs/libusb, bug 270039 (diff)
downloadgentoo-2-8d2afe247a1e1e2af8da9e99a71270d7637a8117.tar.gz
gentoo-2-8d2afe247a1e1e2af8da9e99a71270d7637a8117.tar.bz2
gentoo-2-8d2afe247a1e1e2af8da9e99a71270d7637a8117.zip
Rewritten ebuild, thanks a lot to Stefan Salewski (bug #266358).
(Portage version: 2.1.6.13/cvs/Linux i686)
-rw-r--r--sci-libs/libgeda/ChangeLog10
-rw-r--r--sci-libs/libgeda/libgeda-1.4.3-r1.ebuild57
-rw-r--r--sci-libs/libgeda/metadata.xml9
3 files changed, 73 insertions, 3 deletions
diff --git a/sci-libs/libgeda/ChangeLog b/sci-libs/libgeda/ChangeLog
index d73eda9e4c3b..ac5c8a550522 100644
--- a/sci-libs/libgeda/ChangeLog
+++ b/sci-libs/libgeda/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/libgeda
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libgeda/ChangeLog,v 1.47 2009/03/07 21:33:17 patrick Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libgeda/ChangeLog,v 1.48 2009/05/20 01:51:23 calchan Exp $
+
+*libgeda-1.4.3-r1 (20 May 2009)
+
+ 20 May 2009; Denis Dupeyron <calchan@gentoo.org> +libgeda-1.4.3-r1.ebuild,
+ metadata.xml:
+ Rewritten ebuild, thanks a lot to Stefan Salewski (bug #266358).
*libgeda-1.4.3 (07 Mar 2009)
diff --git a/sci-libs/libgeda/libgeda-1.4.3-r1.ebuild b/sci-libs/libgeda/libgeda-1.4.3-r1.ebuild
new file mode 100644
index 000000000000..3a2cd5cea998
--- /dev/null
+++ b/sci-libs/libgeda/libgeda-1.4.3-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libgeda/libgeda-1.4.3-r1.ebuild,v 1.1 2009/05/20 01:51:23 calchan Exp $
+
+EAPI="2"
+
+inherit fdo-mime versionator
+
+DESCRIPTION="GPL Electronic Design Automation: core library"
+HOMEPAGE="http://www.gpleda.org/"
+SRC_URI="http://geda.seul.org/release/v$(get_version_component_range 1-2)/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="nls threads"
+
+RDEPEND=">=dev-libs/glib-2.4
+ >=x11-libs/gtk+-2.4
+ || ( =dev-scheme/guile-1.6* =dev-scheme/guile-1.8*[deprecated] )
+ nls? ( virtual/libintl )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ # for gEDA 1.4.3 make doxygen does not work
+ sed -i -e 's/ docs / /' Makefile.in || die "sed failed"
+}
+
+src_configure() {
+ # nls may not work if LINGUAS is set -- upstream bug, they use only variants
+ # like de_DE.po. See Debian bug #336796
+ use nls && unset LINGUAS
+ econf \
+ $(use_enable threads threads posix) \
+ $(use_enable nls) \
+ --disable-dependency-tracking \
+ --disable-rpath \
+ --disable-update-mime-database
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc README AUTHORS NEWS BUGS
+}
+
+pkg_postinst() {
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_mime_database_update
+}
+
diff --git a/sci-libs/libgeda/metadata.xml b/sci-libs/libgeda/metadata.xml
index ce0e016bb307..f405e13a8b4a 100644
--- a/sci-libs/libgeda/metadata.xml
+++ b/sci-libs/libgeda/metadata.xml
@@ -1,5 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci-electronics</herd>
+ <herd>sci-electronics</herd>
+ <longdescription>
+ Core library for the GPL Electronic Design Automation tools (gEDA).
+ </longdescription>
+ <use>
+ <flag name='threads'>Enable (posix) threads for the GTK GUI</flag>
+ </use>
</pkgmetadata>
+