summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Meier <maekke@gentoo.org>2008-09-10 19:12:32 +0000
committerMarkus Meier <maekke@gentoo.org>2008-09-10 19:12:32 +0000
commit8e52fd25c69f582ec1d1898cf5a86369aaf362ba (patch)
treef2825bea5e3316fcc9124214e0c9a136d29f060f
parentRemove mymake="/usr". Cleanup (diff)
downloadgentoo-2-8e52fd25c69f582ec1d1898cf5a86369aaf362ba.tar.gz
gentoo-2-8e52fd25c69f582ec1d1898cf5a86369aaf362ba.tar.bz2
gentoo-2-8e52fd25c69f582ec1d1898cf5a86369aaf362ba.zip
bump to version 3.2, reported in bug #237261
(Portage version: 2.2_rc8/cvs/Linux 2.6.27-rc5 i686)
-rw-r--r--media-gfx/enblend/ChangeLog7
-rw-r--r--media-gfx/enblend/enblend-3.2.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/media-gfx/enblend/ChangeLog b/media-gfx/enblend/ChangeLog
index 5a1ef13fd7be..39785a5df1a2 100644
--- a/media-gfx/enblend/ChangeLog
+++ b/media-gfx/enblend/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/enblend
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/enblend/ChangeLog,v 1.23 2008/08/16 11:12:22 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/enblend/ChangeLog,v 1.24 2008/09/10 19:12:32 maekke Exp $
+
+*enblend-3.2 (10 Sep 2008)
+
+ 10 Sep 2008; Markus Meier <maekke@gentoo.org> +enblend-3.2.ebuild:
+ bump to version 3.2, reported in bug #237261
*enblend-3.0_p20080807 (16 Aug 2008)
diff --git a/media-gfx/enblend/enblend-3.2.ebuild b/media-gfx/enblend/enblend-3.2.ebuild
new file mode 100644
index 000000000000..a351684eb5a7
--- /dev/null
+++ b/media-gfx/enblend/enblend-3.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/enblend/enblend-3.2.ebuild,v 1.1 2008/09/10 19:12:32 maekke Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="Image Blending with Multiresolution Splines"
+HOMEPAGE="http://enblend.sourceforge.net/"
+SRC_URI="mirror://sourceforge/enblend/${PN}-enfuse-${PV}.tar.gz"
+
+LICENSE="GPL-2 VIGRA"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-libs/boost-1.31.0
+ media-libs/lcms
+ media-libs/glew
+ media-libs/plotutils
+ media-libs/tiff
+ virtual/glut"
+
+S="${WORKDIR}/${PN}-enfuse-${PV}"
+
+pkg_setup() {
+ # bug 202476
+ if ! built_with_use media-libs/plotutils X ; then
+ eerror
+ eerror "media-gfx/plotutils has to be built with USE=\"X\""
+ eerror
+ die "emerge plotutils with USE=\"X\""
+ fi
+
+ ewarn
+ ewarn "The compilation of enblend needs a lot of RAM. If you have less"
+ ewarn "than 1GB RAM (and swap) you probably won't be able to compile it."
+ ewarn
+}
+
+_src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ AT_M4DIR="${S}/m4" eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}