summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2010-02-19 17:27:15 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2010-02-19 17:27:15 +0000
commit8eacfa1ef47f5d6d66e3a4b9a27885e52f380881 (patch)
tree11d0cff0fb82eca9ffad5184ac097b111f499585
parentBump for new rc (diff)
downloadgentoo-2-8eacfa1ef47f5d6d66e3a4b9a27885e52f380881.tar.gz
gentoo-2-8eacfa1ef47f5d6d66e3a4b9a27885e52f380881.tar.bz2
gentoo-2-8eacfa1ef47f5d6d66e3a4b9a27885e52f380881.zip
Fix documentation install path, bug #305579, EAPI2, and remove old
(Portage version: 2.2_rc62/cvs/Linux x86_64)
-rw-r--r--net-misc/nxcl/ChangeLog10
-rw-r--r--net-misc/nxcl/nxcl-0.9-r2.ebuild46
-rw-r--r--net-misc/nxcl/nxcl-0.9.ebuild39
3 files changed, 54 insertions, 41 deletions
diff --git a/net-misc/nxcl/ChangeLog b/net-misc/nxcl/ChangeLog
index 001651f00617..7412ec4409e2 100644
--- a/net-misc/nxcl/ChangeLog
+++ b/net-misc/nxcl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/nxcl
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/nxcl/ChangeLog,v 1.9 2009/03/08 15:31:48 maekke Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nxcl/ChangeLog,v 1.10 2010/02/19 17:27:15 voyageur Exp $
+
+*nxcl-0.9-r2 (19 Feb 2010)
+
+ 19 Feb 2010; Bernard Cafarelli <voyageur@gentoo.org> -nxcl-0.9.ebuild,
+ +nxcl-0.9-r2.ebuild:
+ Fix documentation install path, bug #305579, EAPI2, and remove old
08 Mar 2009; Markus Meier <maekke@gentoo.org> nxcl-0.9-r1.ebuild:
amd64/x86 stable, bug #256414
diff --git a/net-misc/nxcl/nxcl-0.9-r2.ebuild b/net-misc/nxcl/nxcl-0.9-r2.ebuild
new file mode 100644
index 000000000000..2f64b1365584
--- /dev/null
+++ b/net-misc/nxcl/nxcl-0.9-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nxcl/nxcl-0.9-r2.ebuild,v 1.1 2010/02/19 17:27:15 voyageur Exp $
+
+EAPI=2
+
+inherit autotools
+
+MY_P="freenx-client-${PV}"
+DESCRIPTION="A library for building NX clients"
+HOMEPAGE="http://developer.berlios.de/projects/freenx/"
+SRC_URI="mirror://berlios/freenx/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus doc nxclient"
+
+RDEPEND=">=net-misc/nx-3.2.0-r5
+ dbus? ( sys-apps/dbus )
+ nxclient? ( net-misc/nxclient )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+S="${WORKDIR}/${MY_P}/${PN}"
+
+src_prepare() {
+ # Incorrect version
+ sed -i -e "s#1.0#0.9#" configure.ac || die "version sed failed"
+ # And doc path
+ sed -i -e "/^docdir =/s#doc/.*#share/doc/${PF}#" doc/Makefile.am ||
+ die "doc path sed failed"
+ if ! use nxclient; then
+ # Patch to use standard ssh instead of nxssh from nxclient
+ epatch "${FILESDIR}"/${P}-no_nxssh.patch
+ fi
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with doc doxygen) || die "configure failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+}
diff --git a/net-misc/nxcl/nxcl-0.9.ebuild b/net-misc/nxcl/nxcl-0.9.ebuild
deleted file mode 100644
index 228793629ec0..000000000000
--- a/net-misc/nxcl/nxcl-0.9.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/nxcl/nxcl-0.9.ebuild,v 1.6 2008/09/10 09:12:14 voyageur Exp $
-
-inherit autotools
-
-MY_P="freenx-client-${PV}"
-DESCRIPTION="A library for building NX clients"
-HOMEPAGE="http://developer.berlios.de/projects/freenx/"
-SRC_URI="mirror://berlios/freenx/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="dbus doc"
-
-RDEPEND="net-misc/nx
- net-misc/nxclient
- dbus? ( sys-apps/dbus )"
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )"
-S="${WORKDIR}/${MY_P}/${PN}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/${P}-gcc43.patch
- eautoreconf
-}
-
-src_compile() {
- econf $(use_with doc doxygen) || die "configure failed"
- emake || die "make failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "install failed"
-}