summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Jackson <mjolnir@gentoo.org>2007-07-28 16:51:51 +0000
committerMartin Jackson <mjolnir@gentoo.org>2007-07-28 16:51:51 +0000
commit91b2c9ed139fd196eb074fcc119cc1289cfff416 (patch)
treef6ab7295bf2c5a9d90b98d4bedd56351c6d0763b
parentVersion bump thanks to Jose daLuz in bug #177571 (diff)
downloadgentoo-2-91b2c9ed139fd196eb074fcc119cc1289cfff416.tar.gz
gentoo-2-91b2c9ed139fd196eb074fcc119cc1289cfff416.tar.bz2
gentoo-2-91b2c9ed139fd196eb074fcc119cc1289cfff416.zip
Bump to 1.2 for #184764
(Portage version: 2.1.2.9)
-rw-r--r--net-analyzer/snmptt/ChangeLog7
-rw-r--r--net-analyzer/snmptt/files/digest-snmptt-1.23
-rw-r--r--net-analyzer/snmptt/snmptt-1.2.ebuild60
3 files changed, 69 insertions, 1 deletions
diff --git a/net-analyzer/snmptt/ChangeLog b/net-analyzer/snmptt/ChangeLog
index f2e1cb6c19b2..3776393a8c31 100644
--- a/net-analyzer/snmptt/ChangeLog
+++ b/net-analyzer/snmptt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/snmptt
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snmptt/ChangeLog,v 1.15 2007/07/09 17:22:35 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snmptt/ChangeLog,v 1.16 2007/07/28 16:51:51 mjolnir Exp $
+
+*snmptt-1.2 (28 Jul 2007)
+
+ 28 Jul 2007; Martin Jackson <mjolnir@gentoo.org> +snmptt-1.2.ebuild:
+ Bump to 1.2 for 184764
09 Jul 2007; Raúl Porcel <armin76@gentoo.org> snmptt-1.1.ebuild:
x86 stable
diff --git a/net-analyzer/snmptt/files/digest-snmptt-1.2 b/net-analyzer/snmptt/files/digest-snmptt-1.2
new file mode 100644
index 000000000000..e1cab49ea856
--- /dev/null
+++ b/net-analyzer/snmptt/files/digest-snmptt-1.2
@@ -0,0 +1,3 @@
+MD5 5200502b7058c9e2cbe3816bf0fe27d0 snmptt_1.2.tgz 135132
+RMD160 3c166b42903b4ff7a61086dc81397abd538a42f1 snmptt_1.2.tgz 135132
+SHA256 0e2756e3d75c59020af7eba668fc834f688330dc14401a6ec43f63ade6baa3b8 snmptt_1.2.tgz 135132
diff --git a/net-analyzer/snmptt/snmptt-1.2.ebuild b/net-analyzer/snmptt/snmptt-1.2.ebuild
new file mode 100644
index 000000000000..b308fde4bd18
--- /dev/null
+++ b/net-analyzer/snmptt/snmptt-1.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snmptt/snmptt-1.2.ebuild,v 1.1 2007/07/28 16:51:51 mjolnir Exp $
+
+MY_P="${P/-/_}"
+
+DESCRIPTION="SNMP Trap Translator"
+SRC_URI="mirror://sourceforge/snmptt/${MY_P}.tgz"
+HOMEPAGE="http://www.snmptt.org/"
+
+LICENSE="GPL-2"
+
+KEYWORDS="~ppc ~sparc ~x86"
+SLOT="0"
+IUSE="mysql postgres"
+
+S="${WORKDIR}/${MY_P}"
+
+RDEPEND=">=dev-lang/perl-5.6.1
+ dev-perl/Config-IniFiles
+ >=net-analyzer/net-snmp-5.1
+ mysql? ( dev-perl/DBD-mysql )
+ postgres? ( dev-perl/DBD-Pg )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # bug 105354, daemonize this thing
+ sed -i -e "s:mode = standalone:mode = daemon:g" snmptt.ini || die
+
+ echo "traphandle default /usr/sbin/snmptt" >examples/snmptrapd.conf.sample
+}
+
+src_install() {
+ into /usr
+ dosbin snmptt
+ dosbin snmptthandler
+ dosbin snmptt-net-snmp-test
+ dosbin snmpttconvert
+ dosbin snmpttconvertmib
+
+ insinto /etc/snmp
+ doins snmptt.ini
+ doins examples/snmptt.conf.generic
+ cp -pPR ${D}/etc/snmp/snmptt.conf.generic ${D}/etc/snmp/snmptt.conf
+ doins examples/snmptrapd.conf.sample
+
+ dodoc BUGS ChangeLog README sample-trap
+ dohtml docs/faqs.html docs/index.html docs/layout1.css docs/snmptt.html docs/snmpttconvert.html docs/snmpttconvertmib.html
+
+ newinitd "${FILESDIR}"/snmptt.initd snmptt
+}
+
+pkg_postinst() {
+ if ( use mysql || use postgres ); then
+ elog "Read the html documentation to configure your database."
+ fi
+ elog "Please configure /etc/snmp/snmptt.conf before running."
+}