summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-03-30 11:11:13 +0000
committerMichał Górny <mgorny@gentoo.org>2014-03-30 11:11:13 +0000
commit924dcf54f211ee8cca4d9363808934d391145055 (patch)
treee6f41cdf5091caa643511d8ddcf38d34dc24024a
parentAdd USE=alsa support to policy (diff)
downloadgentoo-2-924dcf54f211ee8cca4d9363808934d391145055.tar.gz
gentoo-2-924dcf54f211ee8cca4d9363808934d391145055.tar.bz2
gentoo-2-924dcf54f211ee8cca4d9363808934d391145055.zip
Enable multilib support. Install to proper perl libdir.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
-rw-r--r--dev-util/pkgconfig-openbsd/ChangeLog11
-rw-r--r--dev-util/pkgconfig-openbsd/pkgconfig-openbsd-20130507-r1.ebuild73
2 files changed, 81 insertions, 3 deletions
diff --git a/dev-util/pkgconfig-openbsd/ChangeLog b/dev-util/pkgconfig-openbsd/ChangeLog
index ce77a4011d97..471e7278a6e3 100644
--- a/dev-util/pkgconfig-openbsd/ChangeLog
+++ b/dev-util/pkgconfig-openbsd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/pkgconfig-openbsd
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig-openbsd/ChangeLog,v 1.14 2013/05/07 14:01:46 ssuominen Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig-openbsd/ChangeLog,v 1.15 2014/03/30 11:11:13 mgorny Exp $
+
+*pkgconfig-openbsd-20130507-r1 (30 Mar 2014)
+
+ 30 Mar 2014; Michał Górny <mgorny@gentoo.org>
+ +pkgconfig-openbsd-20130507-r1.ebuild:
+ Enable multilib support. Install to proper perl libdir.
07 May 2013; Samuli Suominen <ssuominen@gentoo.org>
-pkgconfig-openbsd-20130225.ebuild:
@@ -70,4 +76,3 @@
16 Jan 2012; Samuli Suominen <ssuominen@gentoo.org>
+pkgconfig-openbsd-20120116.ebuild:
Initial commit.
-
diff --git a/dev-util/pkgconfig-openbsd/pkgconfig-openbsd-20130507-r1.ebuild b/dev-util/pkgconfig-openbsd/pkgconfig-openbsd-20130507-r1.ebuild
new file mode 100644
index 000000000000..6ae1aee75105
--- /dev/null
+++ b/dev-util/pkgconfig-openbsd/pkgconfig-openbsd-20130507-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig-openbsd/pkgconfig-openbsd-20130507-r1.ebuild,v 1.1 2014/03/30 11:11:13 mgorny Exp $
+
+EAPI=5
+
+inherit eutils multilib multilib-minimal
+
+# cvs -d anoncvs@anoncvs.openbsd.org:/cvs get src/usr.bin/pkg-config
+
+PKG_M4_VERSION=0.28
+
+DESCRIPTION="A perl based version of pkg-config from OpenBSD"
+HOMEPAGE="http://www.openbsd.org/cgi-bin/cvsweb/src/usr.bin/pkg-config/"
+SRC_URI="http://dev.gentoo.org/~ssuominen/${P}.tar.xz
+ pkg-config? ( http://pkgconfig.freedesktop.org/releases/pkg-config-${PKG_M4_VERSION}.tar.gz )"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+pkg-config"
+
+DEPEND="dev-lang/perl:="
+RDEPEND="${DEPEND}
+ virtual/perl-Getopt-Long
+ pkg-config? (
+ !dev-util/pkgconfig
+ !dev-util/pkgconf[pkg-config]
+ )"
+
+S=${WORKDIR}/src
+
+src_prepare() {
+ epatch_user
+ ecvs_clean
+
+ # Config.pm from dev-lang/perl doesn't set ARCH, only archname
+ sed -i -e '/Config/s:ARCH:archname:' usr.bin/pkg-config/pkg-config || die
+
+ if use pkg-config; then
+ MULTILIB_CHOST_TOOLS=( /usr/bin/pkg-config )
+ else
+ MULTILIB_CHOST_TOOLS=( /usr/bin/pkg-config-openbsd )
+ fi
+}
+
+multilib_src_install() {
+ local pc_bin=pkg-config
+ use pkg-config || pc_bin+=-openbsd
+
+ newbin "${S}"/usr.bin/pkg-config/pkg-config ${pc_bin}
+ newman "${S}"/usr.bin/pkg-config/pkg-config.1 ${pc_bin}.1
+
+ # insert proper paths
+ local pc_paths=(
+ /usr/$(get_libdir)/pkgconfig
+ /usr/share/pkgconfig
+ )
+ sed -i -e "/my @PKGPATH/,/;/{s@(.*@( ${pc_paths[*]} );@p;d}" \
+ "${ED%/}/usr/bin/${pc_bin}" || die
+}
+
+multilib_src_install_all() {
+ if use pkg-config; then
+ insinto /usr/share/aclocal
+ doins "${WORKDIR}"/pkg-config-*/pkg.m4
+ fi
+
+ local perl_version=$(perl -e 'printf "%vd", $^V')
+
+ insinto /usr/$(get_libdir)/perl5/vendor_perl/${perl_version}
+ doins -r "${S}"/usr.bin/pkg-config/OpenBSD
+}