summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2008-02-13 10:34:49 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2008-02-13 10:34:49 +0000
commit9689b187c4417c522c7597fef32b95ceaa777dab (patch)
tree85816525348d084d6b1fe2635dff311706fc8fe3
parentStable on ppc64 (diff)
downloadgentoo-2-9689b187c4417c522c7597fef32b95ceaa777dab.tar.gz
gentoo-2-9689b187c4417c522c7597fef32b95ceaa777dab.tar.bz2
gentoo-2-9689b187c4417c522c7597fef32b95ceaa777dab.zip
Cleanup
(Portage version: 2.1.4.3)
-rw-r--r--app-crypt/johntheripper/ChangeLog5
-rw-r--r--app-crypt/johntheripper/johntheripper-1.7.2.ebuild125
2 files changed, 4 insertions, 126 deletions
diff --git a/app-crypt/johntheripper/ChangeLog b/app-crypt/johntheripper/ChangeLog
index c4615ec4197f..1a410bef5861 100644
--- a/app-crypt/johntheripper/ChangeLog
+++ b/app-crypt/johntheripper/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-crypt/johntheripper
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/johntheripper/ChangeLog,v 1.82 2008/01/11 07:10:26 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/johntheripper/ChangeLog,v 1.83 2008/02/13 10:34:49 alonbl Exp $
+
+ 13 Feb 2008; Alon Bar-Lev <alonbl@gentoo.org> -johntheripper-1.7.2.ebuild:
+ Cleanup
*johntheripper-1.7.2-r4 (11 Jan 2008)
diff --git a/app-crypt/johntheripper/johntheripper-1.7.2.ebuild b/app-crypt/johntheripper/johntheripper-1.7.2.ebuild
deleted file mode 100644
index 21035d1df596..000000000000
--- a/app-crypt/johntheripper/johntheripper-1.7.2.ebuild
+++ /dev/null
@@ -1,125 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/johntheripper/johntheripper-1.7.2.ebuild,v 1.16 2008/02/04 18:47:56 grobian Exp $
-
-inherit eutils flag-o-matic toolchain-funcs pax-utils
-
-MY_PBASE=${P/theripper/}
-MY_PNBASE=${PN/theripper/}
-S=${WORKDIR}/${MY_PBASE}
-DESCRIPTION="fast password cracker"
-HOMEPAGE="http://www.openwall.com/john/"
-SRC_URI="http://www.openwall.com/john/f/${MY_PBASE}.tar.gz
- http://www.openwall.com/john/contrib/${MY_PNBASE}-1.7-all-4.diff.gz"
-
-# banquise-to-bigpatch-17.patch.bz2"
-# based off /var/tmp/portage/johntheripper-1.6.40
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa mips ppc ppc64 sparc x86"
-IUSE="mmx altivec"
-
-RDEPEND="virtual/libc
- >=dev-libs/openssl-0.9.7"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${WORKDIR}"/${MY_PNBASE}-1.7-all-4.diff
-
- for p in params.h sha1-memset stackdef.S stripping; do
- epatch "${FILESDIR}/${P}-${p}.patch"
- done
-
- ebegin "Applying ${P}-Makefile.patch"
- sed -i -e "s|^CFLAGS.*|CFLAGS= -c -Wall ${CFLAGS}|" \
- -e 's|^LDFLAGS.*|LDFLAGS= -lm|' "${S}"/src/Makefile
- eend $?
-
- ebegin "Applying ${P}-john.conf.patch"
- sed -i -e 's:$JOHN:/usr/share/john:g' "${S}"/run/john.conf
- eend $?
-}
-
-src_compile() {
- cd "${S}"/src
- # Note this program uses AS and LD incorrectly
- OPTIONS="CPP=$(tc-getCXX) CC=$(tc-getCC) AS=$(tc-getCC) LD=$(tc-getCC) \
- OPT_NORMAL= OPT_INLINE= JOHN_SYSTEMWIDE=1
- CFG_FULL_NAME=/etc/john/john.conf
- CFG_ALT_NAME=/etc/john/john.ini"
-
- if use x86 ; then
- if use mmx ; then
- emake ${OPTIONS} linux-x86-mmx || die "Make failed"
- else
- emake ${OPTIONS} linux-x86-any || die "Make failed"
- fi
- elif use amd64 ; then
- emake ${OPTIONS} generic || die "Make failed"
- elif use alpha ; then
- emake ${OPTIONS} linux-alpha || die "Make failed"
- elif use sparc; then
- emake ${OPTIONS} linux-sparc || die "Make failed"
- elif use amd64; then
- emake ${OPTIONS} linux-x86-64 || die "Make failed"
- elif use ppc64; then
- if use altivec; then
- emake ${OPTIONS} linux-ppc32-altivec || die "Make failed"
- else
- emake ${OPTIONS} linux-ppc64 || die "Make failed"
- fi
- # linux-ppc64-altivec is slightly slower than linux-ppc32-altivec for most hash types.
- # as per the Makefile comments
- elif use ppc; then
- if use altivec; then
- emake ${OPTIONS} linux-ppc32-altivec || die "Make failed"
- else
- emake ${OPTIONS} linux-ppc32 || die "Make failed"
- fi
- else
- emake ${OPTIONS} generic || die "Make failed"
- fi
-
- # currently broken
- #emake bench || die "make failed"
-}
-
-src_test() {
- cd run
- if [[ -f /etc/john/john.conf || -f /etc/john/john.ini ]]
- then
- ./john --test || die 'self test failed'
- else
- ewarn "selftest requires /etc/john/john.conf or /etc/john/john.ini"
- fi
-}
-
-src_install() {
- # config files
- insinto /etc/john
- doins run/john.conf
-
- # executables
- dosbin run/john
- newsbin run/mailer john-mailer
-
- pax-mark -m "${D}"/usr/sbin/john
-
- dosym john /usr/sbin/unafs
- dosym john /usr/sbin/unique
- dosym john /usr/sbin/unshadow
-
- # for EGG only
- dosym john /usr/sbin/undrop
-
- #newsbin src/bench john-bench
-
- # share
- insinto /usr/share/john/
- doins run/*.chr run/password.lst
-
- # documentation
- dodoc doc/*
-}