summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Auty <ikelos@gentoo.org>2010-02-01 11:23:06 +0000
committerMike Auty <ikelos@gentoo.org>2010-02-01 11:23:06 +0000
commit9a49044b33d8248e0476d9c9171b9b60bade7a0f (patch)
tree59b1454603ebfe08896621eb6cebd087a702f050
parentDepend on texlive-pictures for epic.sty needed by overpic, by Michal Terepeta... (diff)
downloadgentoo-2-9a49044b33d8248e0476d9c9171b9b60bade7a0f.tar.gz
gentoo-2-9a49044b33d8248e0476d9c9171b9b60bade7a0f.tar.bz2
gentoo-2-9a49044b33d8248e0476d9c9171b9b60bade7a0f.zip
Version bump libnfc to 1.3.2.
(Portage version: 2.2_rc61/cvs/Linux i686)
-rw-r--r--dev-libs/libnfc/ChangeLog7
-rw-r--r--dev-libs/libnfc/libnfc-1.3.2.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/dev-libs/libnfc/ChangeLog b/dev-libs/libnfc/ChangeLog
index ff6a09c3d047..abb790238a2e 100644
--- a/dev-libs/libnfc/ChangeLog
+++ b/dev-libs/libnfc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libnfc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libnfc/ChangeLog,v 1.2 2010/01/23 22:02:13 ikelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libnfc/ChangeLog,v 1.3 2010/02/01 11:23:06 ikelos Exp $
+
+*libnfc-1.3.2 (01 Feb 2010)
+
+ 01 Feb 2010; Mike Auty <ikelos@gentoo.org> +libnfc-1.3.2.ebuild:
+ Version bump libnfc to 1.3.2.
*libnfc-1.3.1 (23 Jan 2010)
diff --git a/dev-libs/libnfc/libnfc-1.3.2.ebuild b/dev-libs/libnfc/libnfc-1.3.2.ebuild
new file mode 100644
index 000000000000..61bf570c1532
--- /dev/null
+++ b/dev-libs/libnfc/libnfc-1.3.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libnfc/libnfc-1.3.2.ebuild,v 1.1 2010/02/01 11:23:06 ikelos Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Near Field Communications (NFC) library"
+HOMEPAGE="http://www.libnfc.org/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="doc"
+
+CDEPEND="sys-apps/pcsc-lite
+ dev-libs/libusb"
+DEPEND="${CDEPEND}
+ doc? ( app-doc/doxygen )"
+RDEPEND="${CDEPEND}"
+
+src_compile() {
+ emake || die "Failed to compile."
+ use doc && doxygen
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "Failed to install properly."
+ use doc && dohtml "${S}"/doc/html/*
+}