summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSandro Bonazzola <sanchan@gentoo.org>2006-11-06 21:11:25 +0000
committerSandro Bonazzola <sanchan@gentoo.org>2006-11-06 21:11:25 +0000
commit9f1b7a81b47901fd09cac5d1f8b837c5ea9e1a52 (patch)
tree173adccbd0b8c79fff360a0b326e72bd8e6ce4ae
parentNew version with compressed disk image support. (diff)
downloadgentoo-2-9f1b7a81b47901fd09cac5d1f8b837c5ea9e1a52.tar.gz
gentoo-2-9f1b7a81b47901fd09cac5d1f8b837c5ea9e1a52.tar.bz2
gentoo-2-9f1b7a81b47901fd09cac5d1f8b837c5ea9e1a52.zip
Security fix from upstream, patch from https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=139715. Should fix bug #154218. Re-taking over maintainership.
(Portage version: 2.1.2_rc1-r4)
-rw-r--r--app-arch/rpm/ChangeLog12
-rw-r--r--app-arch/rpm/files/digest-rpm-4.4.6-r33
-rw-r--r--app-arch/rpm/files/digest-rpm-4.4.7-r13
-rw-r--r--app-arch/rpm/rpm-4.4.6-r3.ebuild100
-rw-r--r--app-arch/rpm/rpm-4.4.7-r1.ebuild100
5 files changed, 214 insertions, 4 deletions
diff --git a/app-arch/rpm/ChangeLog b/app-arch/rpm/ChangeLog
index 8513633d5b48..d01a4e251b94 100644
--- a/app-arch/rpm/ChangeLog
+++ b/app-arch/rpm/ChangeLog
@@ -1,13 +1,17 @@
# ChangeLog for app-arch/rpm
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/ChangeLog,v 1.76 2006/11/06 20:58:28 sanchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/ChangeLog,v 1.77 2006/11/06 21:11:24 sanchan Exp $
- 06 Nov 2006; Sandro Bonazzola <sanchan@gentoo.org>
- +files/rpm-4.4.6-buffer-overflow.patch, metadata.xml, rpm-4.4.6-r2.ebuild,
- rpm-4.4.7.ebuild:
+*rpm-4.4.7-r1 (06 Nov 2006)
+*rpm-4.4.6-r3 (06 Nov 2006)
+
+ 06 Nov 2006; Sandro Bonazzola <sanchan@gentoo.org> -rpm-4.4.6-r2.ebuild,
+ +rpm-4.4.6-r3.ebuild, -rpm-4.4.7.ebuild, +rpm-4.4.7-r1.ebuild,
+ +files/rpm-4.4.6-buffer-overflow.patch, metadata.xml:
Security fix from upstream, patch from
https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=139715. Should fix
bug #154218.
+ Re-taking over maintainership.
26 Oct 2006; Peter Volkov <pva@gentoo.org> metadata.xml:
herd tag in metadata.xml is required. Returning it back.
diff --git a/app-arch/rpm/files/digest-rpm-4.4.6-r3 b/app-arch/rpm/files/digest-rpm-4.4.6-r3
new file mode 100644
index 000000000000..8dae251f56e0
--- /dev/null
+++ b/app-arch/rpm/files/digest-rpm-4.4.6-r3
@@ -0,0 +1,3 @@
+MD5 baa6f371446c65b4080d1cd1f194a7ae rpm-4.4.6.tar.gz 17157249
+RMD160 6b433d20a63fb2542244ae62eff0a8b5fe290439 rpm-4.4.6.tar.gz 17157249
+SHA256 1e1da50af2b9dfe34c79315eae7520e7e57087671e17ce26107d779ae2b0b595 rpm-4.4.6.tar.gz 17157249
diff --git a/app-arch/rpm/files/digest-rpm-4.4.7-r1 b/app-arch/rpm/files/digest-rpm-4.4.7-r1
new file mode 100644
index 000000000000..8ad784707d6f
--- /dev/null
+++ b/app-arch/rpm/files/digest-rpm-4.4.7-r1
@@ -0,0 +1,3 @@
+MD5 d012c81b5169f7377ea4a36607e1445e rpm-4.4.7.tar.gz 14125623
+RMD160 9002eb0fe1d680d8bff447d6918f9726c9a4e34c rpm-4.4.7.tar.gz 14125623
+SHA256 18fde4195e4ac21a4290327336948f8c4fc58a680395edbb5f2f31bae67b18b5 rpm-4.4.7.tar.gz 14125623
diff --git a/app-arch/rpm/rpm-4.4.6-r3.ebuild b/app-arch/rpm/rpm-4.4.6-r3.ebuild
new file mode 100644
index 000000000000..b67487186a0c
--- /dev/null
+++ b/app-arch/rpm/rpm-4.4.6-r3.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/rpm-4.4.6-r3.ebuild,v 1.1 2006/11/06 21:11:24 sanchan Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+inherit eutils autotools distutils perl-module
+
+DESCRIPTION="Red Hat Package Management Utils"
+HOMEPAGE="http://www.rpm.org/"
+SRC_URI="http://wraptastic.org/pub/rpm-4.4.x/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86"
+IUSE="nls python perl doc sqlite"
+
+RDEPEND="=sys-libs/db-3.2*
+ >=sys-libs/zlib-1.1.3
+ >=app-arch/bzip2-1.0.1
+ >=dev-libs/popt-1.7
+ >=app-crypt/gnupg-1.2
+ dev-libs/elfutils
+ virtual/libintl
+ >=dev-libs/beecrypt-3.1.0-r1
+ python? ( >=dev-lang/python-2.2 )
+ perl? ( >=dev-lang/perl-5.8.8 )
+ nls? ( virtual/libintl )
+ sqlite? ( >=dev-db/sqlite-3.3.5 )
+ net-misc/neon"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ doc? ( app-doc/doxygen )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/rpm-4.4.6-with-sqlite.patch
+ epatch "${FILESDIR}"/rpm-4.4.6-stupidness.patch
+ epatch "${FILESDIR}"/rpm-4.4.6-autotools.patch
+ epatch "${FILESDIR}"/rpm-4.4.6-buffer-overflow.patch
+
+ # rpm uses AM_GNU_GETTEXT() but fails to actually
+ # include any of the required gettext files
+ cp /usr/share/gettext/config.rpath . || die
+
+ # the following are additional libraries that might be packaged with
+ # the rpm sources. grep for "test -d" in configure.ac
+ cp file/src/{file,patchlevel}.h tools/
+ rm -rf beecrypt elfutils neon popt sqlite zlib intl file
+
+ sed -i -e "s:intl ::" Makefile.am
+ sed -i -e "s:intl/Makefile ::" configure.ac
+ AT_NO_RECURSIVE="yes" eautoreconf
+ # TODO Get rid of internal copies of lua, db and db3
+}
+
+src_compile() {
+ python_version
+ econf \
+ --enable-posixmutexes \
+ --without-javaglue \
+ --without-selinux \
+ $(use_with python python ${PYVER}) \
+ $(use_with doc apidocs) \
+ $(use_with perl) \
+ $(use_with sqlite) \
+ $(use_enable nls) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ mv "${D}"/bin/rpm "${D}"/usr/bin
+ rmdir "${D}"/bin
+
+ use nls || rm -rf "${D}"/usr/share/man/??
+
+ keepdir /usr/src/rpm/{SRPMS,SPECS,SOURCES,RPMS,BUILD}
+
+ dodoc CHANGES CREDITS GROUPS README* RPM*
+ use doc && dohtml -r apidocs/html/*
+
+ # Fix perllocal.pod file collision
+ use perl && fixlocalpod
+}
+
+pkg_postinst() {
+ if [[ -f ${ROOT}/var/lib/rpm/Packages ]] ; then
+ einfo "RPM database found... Rebuilding database (may take a while)..."
+ "${ROOT}"/usr/bin/rpm --rebuilddb --root=${ROOT}
+ else
+ einfo "No RPM database found... Creating database..."
+ "${ROOT}"/usr/bin/rpm --initdb --root=${ROOT}
+ fi
+
+ distutils_pkg_postinst
+}
diff --git a/app-arch/rpm/rpm-4.4.7-r1.ebuild b/app-arch/rpm/rpm-4.4.7-r1.ebuild
new file mode 100644
index 000000000000..2a63e1692ebb
--- /dev/null
+++ b/app-arch/rpm/rpm-4.4.7-r1.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/rpm-4.4.7-r1.ebuild,v 1.1 2006/11/06 21:11:24 sanchan Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+inherit eutils autotools distutils perl-module
+
+DESCRIPTION="Red Hat Package Management Utils"
+HOMEPAGE="http://www.rpm.org/"
+SRC_URI="http://wraptastic.org/pub/rpm-4.4.x/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="nls python perl doc sqlite"
+
+RDEPEND="=sys-libs/db-3.2*
+ >=sys-libs/zlib-1.2.3-r1
+ >=app-arch/bzip2-1.0.1
+ >=dev-libs/popt-1.7
+ >=app-crypt/gnupg-1.2
+ dev-libs/elfutils
+ virtual/libintl
+ >=dev-libs/beecrypt-3.1.0-r1
+ python? ( >=dev-lang/python-2.2 )
+ perl? ( >=dev-lang/perl-5.8.8 )
+ nls? ( virtual/libintl )
+ sqlite? ( >=dev-db/sqlite-3.3.5 )
+ net-misc/neon"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ doc? ( app-doc/doxygen )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/rpm-4.4.6-with-sqlite.patch
+ epatch "${FILESDIR}"/rpm-4.4.7-stupidness.patch
+ epatch "${FILESDIR}"/rpm-4.4.6-autotools.patch
+ epatch "${FILESDIR}"/rpm-4.4.6-buffer-overflow.patch
+
+ # rpm uses AM_GNU_GETTEXT() but fails to actually
+ # include any of the required gettext files
+ cp /usr/share/gettext/config.rpath . || die
+
+ # the following are additional libraries that might be packaged with
+ # the rpm sources. grep for "test -d" in configure.ac
+ cp file/src/{file,patchlevel}.h tools/
+ rm -rf beecrypt elfutils neon popt sqlite zlib intl file
+
+ sed -i -e "s:intl ::" Makefile.am
+ sed -i -e "s:intl/Makefile ::" configure.ac
+ AT_NO_RECURSIVE="yes" eautoreconf
+ # TODO Get rid of internal copies of lua, db and db3
+}
+
+src_compile() {
+ python_version
+ econf \
+ --enable-posixmutexes \
+ --without-javaglue \
+ --without-selinux \
+ $(use_with python python ${PYVER}) \
+ $(use_with doc apidocs) \
+ $(use_with perl) \
+ $(use_with sqlite) \
+ $(use_enable nls) \
+ || die "econf failed"
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ mv "${D}"/bin/rpm "${D}"/usr/bin
+ rmdir "${D}"/bin
+
+ use nls || rm -rf "${D}"/usr/share/man/??
+
+ keepdir /usr/src/rpm/{SRPMS,SPECS,SOURCES,RPMS,BUILD}
+
+ dodoc CHANGES CREDITS GROUPS README* RPM*
+ use doc && dohtml -r apidocs/html/*
+
+ # Fix perllocal.pod file collision
+ use perl && fixlocalpod
+}
+
+pkg_postinst() {
+ if [[ -f ${ROOT}/var/lib/rpm/Packages ]] ; then
+ einfo "RPM database found... Rebuilding database (may take a while)..."
+ "${ROOT}"/usr/bin/rpm --rebuilddb --root=${ROOT}
+ else
+ einfo "No RPM database found... Creating database..."
+ "${ROOT}"/usr/bin/rpm --initdb --root=${ROOT}
+ fi
+
+ distutils_pkg_postinst
+}