summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Longinotti <chtekk@gentoo.org>2006-10-14 22:52:39 +0000
committerLuca Longinotti <chtekk@gentoo.org>2006-10-14 22:52:39 +0000
commita278a5c12472356c8ccc7a49ac32f5f437824b7f (patch)
treea8e862afb0aaad56326f83a4d8355d8a8a04829c
parentImproved 64bit support, fixed doc/help, fixed misc bugs. (diff)
downloadgentoo-2-a278a5c12472356c8ccc7a49ac32f5f437824b7f.tar.gz
gentoo-2-a278a5c12472356c8ccc7a49ac32f5f437824b7f.tar.bz2
gentoo-2-a278a5c12472356c8ccc7a49ac32f5f437824b7f.zip
Fix failure when using SysV semaphores.
(Portage version: 2.1.2_pre2-r9)
-rw-r--r--dev-php5/eaccelerator/ChangeLog6
-rw-r--r--dev-php5/eaccelerator/eaccelerator-0.9.5.ebuild4
2 files changed, 7 insertions, 3 deletions
diff --git a/dev-php5/eaccelerator/ChangeLog b/dev-php5/eaccelerator/ChangeLog
index 4d0676aab3bf..5305d784a738 100644
--- a/dev-php5/eaccelerator/ChangeLog
+++ b/dev-php5/eaccelerator/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-php5/eaccelerator
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/eaccelerator/ChangeLog,v 1.9 2006/10/14 22:07:22 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/eaccelerator/ChangeLog,v 1.10 2006/10/14 22:52:39 chtekk Exp $
+
+ 14 Oct 2006; Luca Longinotti <chtekk@gentoo.org>
+ eaccelerator-0.9.5.ebuild:
+ Fix failure when using SysV semaphores.
14 Oct 2006; Luca Longinotti <chtekk@gentoo.org>
eaccelerator-0.9.5.ebuild:
diff --git a/dev-php5/eaccelerator/eaccelerator-0.9.5.ebuild b/dev-php5/eaccelerator/eaccelerator-0.9.5.ebuild
index a9a13943bb8c..1cd5b596cff4 100644
--- a/dev-php5/eaccelerator/eaccelerator-0.9.5.ebuild
+++ b/dev-php5/eaccelerator/eaccelerator-0.9.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/eaccelerator/eaccelerator-0.9.5.ebuild,v 1.3 2006/10/14 22:07:22 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/eaccelerator/eaccelerator-0.9.5.ebuild,v 1.4 2006/10/14 22:52:39 chtekk Exp $
PHP_EXT_NAME="eaccelerator"
PHP_EXT_INI="yes"
@@ -42,7 +42,7 @@ pkg_setup() {
src_compile() {
has_php
- my_conf="--enable-eaccelerator=shared"
+ my_conf="--enable-eaccelerator=shared --with-eaccelerator-userid=`id -u ${HTTPD_USER}`"
use contentcache && my_conf="${my_conf} --with-eaccelerator-content-caching"
use debug && my_conf="${my_conf} --with-eaccelerator-debug"