summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2012-07-23 10:37:32 +0000
committerChristoph Mende <angelos@gentoo.org>2012-07-23 10:37:32 +0000
commita727939e341bcccd129aa3fff4ef647dfe648723 (patch)
tree29cf0d7713ff46634363ec1a8d864418f8b147c8
parentVersion bump. (diff)
downloadgentoo-2-a727939e341bcccd129aa3fff4ef647dfe648723.tar.gz
gentoo-2-a727939e341bcccd129aa3fff4ef647dfe648723.tar.bz2
gentoo-2-a727939e341bcccd129aa3fff4ef647dfe648723.zip
Version bump
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
-rw-r--r--xfce-extra/xfce4-weather-plugin/ChangeLog9
-rw-r--r--xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.8.0.ebuild33
2 files changed, 40 insertions, 2 deletions
diff --git a/xfce-extra/xfce4-weather-plugin/ChangeLog b/xfce-extra/xfce4-weather-plugin/ChangeLog
index 93f0fb82dbc2..4e99a97e20b3 100644
--- a/xfce-extra/xfce4-weather-plugin/ChangeLog
+++ b/xfce-extra/xfce4-weather-plugin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-extra/xfce4-weather-plugin
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-weather-plugin/ChangeLog,v 1.20 2012/06/27 14:20:01 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-weather-plugin/ChangeLog,v 1.21 2012/07/23 10:37:32 angelos Exp $
+
+*xfce4-weather-plugin-0.8.0 (23 Jul 2012)
+
+ 23 Jul 2012; Christoph Mende <angelos@gentoo.org>
+ +xfce4-weather-plugin-0.8.0.ebuild:
+ Version bump
*xfce4-weather-plugin-0.7.4-r2 (27 Jun 2012)
@@ -46,4 +52,3 @@
29 Jan 2011; Samuli Suominen <ssuominen@gentoo.org>
+xfce4-weather-plugin-0.7.3_p20110129.ebuild:
Initial commit.
-
diff --git a/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.8.0.ebuild b/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.8.0.ebuild
new file mode 100644
index 000000000000..e92464519dd1
--- /dev/null
+++ b/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.8.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.8.0.ebuild,v 1.1 2012/07/23 10:37:32 angelos Exp $
+
+EAPI=4
+inherit multilib xfconf
+
+DESCRIPTION="A weather plug-in for the Xfce desktop environment"
+HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-weather-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="x11-libs/gtk+:2
+ >=xfce-base/libxfce4util-4.8
+ >=xfce-base/libxfce4ui-4.8
+ >=xfce-base/xfce4-panel-4.8
+ dev-libs/libxml2"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README TODO )
+}