summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-11-27 05:02:50 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-11-27 05:02:50 +0000
commita8014ae5445ffaac743dd6be34198c67f0518eb0 (patch)
tree51684b4c6c87eb265c072cd0c405dda30703813b
parentStable for HPPA (bug #199740). (diff)
downloadgentoo-2-a8014ae5445ffaac743dd6be34198c67f0518eb0.tar.gz
gentoo-2-a8014ae5445ffaac743dd6be34198c67f0518eb0.tar.bz2
gentoo-2-a8014ae5445ffaac743dd6be34198c67f0518eb0.zip
version bump
(Portage version: 2.1.3.19)
-rw-r--r--games-strategy/outerspace/ChangeLog8
-rw-r--r--games-strategy/outerspace/files/digest-outerspace-0.5.663
-rw-r--r--games-strategy/outerspace/outerspace-0.5.66.ebuild41
3 files changed, 51 insertions, 1 deletions
diff --git a/games-strategy/outerspace/ChangeLog b/games-strategy/outerspace/ChangeLog
index 89a549ffc177..1f4e65a21d4e 100644
--- a/games-strategy/outerspace/ChangeLog
+++ b/games-strategy/outerspace/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/outerspace
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/outerspace/ChangeLog,v 1.9 2007/08/12 00:27:49 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/outerspace/ChangeLog,v 1.10 2007/11/27 05:02:50 mr_bones_ Exp $
+
+*outerspace-0.5.66 (27 Nov 2007)
+
+ 27 Nov 2007; Michael Sterrett <mr_bones_@gentoo.org>
+ +outerspace-0.5.66.ebuild:
+ version bump
*outerspace-0.5.65 (12 Aug 2007)
diff --git a/games-strategy/outerspace/files/digest-outerspace-0.5.66 b/games-strategy/outerspace/files/digest-outerspace-0.5.66
new file mode 100644
index 000000000000..17eae08d0926
--- /dev/null
+++ b/games-strategy/outerspace/files/digest-outerspace-0.5.66
@@ -0,0 +1,3 @@
+MD5 0fc55d1639ca62c42cd80c67e5482aa7 OuterSpace-0.5.66.tar.gz 2177297
+RMD160 80939e6a57ed7031c1834c271a1163ec897d1a0d OuterSpace-0.5.66.tar.gz 2177297
+SHA256 01d1e5ef7bbba8e4160f094e8a0951bd64c28af81791bd3d4b9bd97f97ab01ce OuterSpace-0.5.66.tar.gz 2177297
diff --git a/games-strategy/outerspace/outerspace-0.5.66.ebuild b/games-strategy/outerspace/outerspace-0.5.66.ebuild
new file mode 100644
index 000000000000..f1475961d673
--- /dev/null
+++ b/games-strategy/outerspace/outerspace-0.5.66.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/outerspace/outerspace-0.5.66.ebuild,v 1.1 2007/11/27 05:02:50 mr_bones_ Exp $
+
+inherit eutils games
+
+MY_PN=${PN/outerspace/OuterSpace}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="on-line strategy game taking place in the dangerous universe"
+HOMEPAGE="http://www.ospace.net/"
+SRC_URI="mirror://sourceforge/ospace/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/pygame-1.7
+ >=dev-lang/python-2.4"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
+ -e "s:@GENTOO_LIBDIR@:$(games_get_libdir)/${PN}:" \
+ "${FILESDIR}"/${PN} > ${PN} \
+ || die "sed failed"
+}
+
+src_install() {
+ insinto "$(games_get_libdir)"/${PN}
+ doins -r osc.py lib libsrvr || die "doins lib failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r res || die "doins data failed"
+ dogamesbin ${PN} || die "dogamesbin failed"
+ newicon res/icon32.png ${PN}.png
+ make_desktop_entry ${PN} ${MY_PN}
+ prepgamesdirs
+}