summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-04-13 09:21:45 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-04-13 09:21:45 +0000
commita88604a62d23e73cb59d702ce773485feda5e363 (patch)
tree860104a614c29066e299cb2fad6c5bcda7ded3b0
parentversion bump (diff)
downloadgentoo-2-a88604a62d23e73cb59d702ce773485feda5e363.tar.gz
gentoo-2-a88604a62d23e73cb59d702ce773485feda5e363.tar.bz2
gentoo-2-a88604a62d23e73cb59d702ce773485feda5e363.zip
Revision bump from overlay. Fix boost issues and bundled libform. Remove old.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
-rw-r--r--dev-util/cmake/ChangeLog10
-rw-r--r--dev-util/cmake/cmake-2.8.1-r1.ebuild (renamed from dev-util/cmake/cmake-2.8.0-r3.ebuild)14
-rw-r--r--dev-util/cmake/files/cmake-2.8.1-FindBoost.patch14
-rw-r--r--dev-util/cmake/files/cmake-2.8.1-libform.patch50
4 files changed, 80 insertions, 8 deletions
diff --git a/dev-util/cmake/ChangeLog b/dev-util/cmake/ChangeLog
index 9b3939ce3980..b806383c1b07 100644
--- a/dev-util/cmake/ChangeLog
+++ b/dev-util/cmake/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-util/cmake
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.132 2010/03/17 20:10:25 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.133 2010/04/13 09:21:44 scarabeus Exp $
+
+*cmake-2.8.1-r1 (13 Apr 2010)
+
+ 13 Apr 2010; Tomáš Chvátal <scarabeus@gentoo.org>
+ -cmake-2.8.0-r3.ebuild, +cmake-2.8.1-r1.ebuild,
+ +files/cmake-2.8.1-FindBoost.patch, +files/cmake-2.8.1-libform.patch:
+ Revision bump from overlay. Fix boost issues and bundled libform. Remove
+ old.
17 Mar 2010; Fabian Groffen <grobian@gentoo.org> cmake-2.8.1.ebuild,
+files/cmake-2.8.1-more-no_host_paths.patch:
diff --git a/dev-util/cmake/cmake-2.8.0-r3.ebuild b/dev-util/cmake/cmake-2.8.1-r1.ebuild
index 0020e090f984..eba8400356da 100644
--- a/dev-util/cmake/cmake-2.8.0-r3.ebuild
+++ b/dev-util/cmake/cmake-2.8.1-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-2.8.0-r3.ebuild,v 1.1 2010/03/17 12:07:00 scarabeus Exp $
+# $Header $
-EAPI="2"
+EAPI="3"
inherit elisp-common toolchain-funcs eutils versionator flag-o-matic base cmake-utils
@@ -45,19 +45,19 @@ PATCHES=(
"${FILESDIR}"/${PN}-FindPythonLibs.patch
"${FILESDIR}"/${PN}-FindPythonInterp.patch
"${FILESDIR}"/${PN}-2.6.0-interix.patch
- "${FILESDIR}"/${P}-more-no_host_paths.patch
"${FILESDIR}"/${PN}-2.6.3-darwin-bundle.patch
"${FILESDIR}"/${PN}-2.6.3-no-duplicates-in-rpath.patch
"${FILESDIR}"/${PN}-2.6.3-fix_broken_lfs_on_aix.patch
- "${FILESDIR}"/${P}-darwin-default-install_name.patch
- "${FILESDIR}"/${P}-darwin-no-app-with-qt.patch
+ "${FILESDIR}"/${PN}-2.8.0-darwin-default-install_name.patch
+ "${FILESDIR}"/${PN}-2.8.0-darwin-no-app-with-qt.patch
+ "${FILESDIR}"/${PN}-2.8.1-more-no_host_paths.patch
+ "${FILESDIR}"/${PN}-2.8.1-FindBoost.patch
+ "${FILESDIR}"/${PN}-2.8.1-libform.patch
)
src_prepare() {
base_src_prepare
- use prefix || EPREFIX=
-
# Add gcc libs to the default link paths
sed -i \
-e "s|@GENTOO_PORTAGE_GCCLIBDIR@|${EPREFIX}/usr/${CHOST}/lib|g" \
diff --git a/dev-util/cmake/files/cmake-2.8.1-FindBoost.patch b/dev-util/cmake/files/cmake-2.8.1-FindBoost.patch
new file mode 100644
index 000000000000..56fb152d663a
--- /dev/null
+++ b/dev-util/cmake/files/cmake-2.8.1-FindBoost.patch
@@ -0,0 +1,14 @@
+diff -u -r cmake-2.8.1.orig/Modules/FindBoost.cmake cmake-2.8.1/Modules/FindBoost.cmake
+--- cmake-2.8.1.orig/Modules/FindBoost.cmake 2010-03-16 21:29:29.000000000 +0100
++++ cmake-2.8.1/Modules/FindBoost.cmake 2010-04-04 19:52:50.000000000 +0200
+@@ -70,7 +70,9 @@
+ # omit the 3rd version number from include paths if it is 0 although not all
+ # binary Boost releases do so.
+ #
+-# SET(Boost_ADDITIONAL_VERSIONS "1.78" "1.78.0" "1.79" "1.79.0")
++SET(Boost_ADDITIONAL_VERSIONS "1.50.0" "1.50" "1.49.0" "1.49" "1.48.0" "1.48"
++ "1.47.0" "1.47" "1.46.0" "1.46" "1.45.0" "1.45" "1.44.0" "1.44" "1.43.0"
++ "1.43" "1.42.0" "1.42")
+ #
+ # ===================================== ============= ========================
+ #
diff --git a/dev-util/cmake/files/cmake-2.8.1-libform.patch b/dev-util/cmake/files/cmake-2.8.1-libform.patch
new file mode 100644
index 000000000000..87c724776e50
--- /dev/null
+++ b/dev-util/cmake/files/cmake-2.8.1-libform.patch
@@ -0,0 +1,50 @@
+diff -u -r cmake-2.8.1.medium/CMakeLists.txt cmake-2.8.1/CMakeLists.txt
+--- cmake-2.8.1.medium/CMakeLists.txt 2010-03-16 21:29:28.000000000 +0100
++++ cmake-2.8.1/CMakeLists.txt 2010-04-04 20:04:47.000000000 +0200
+@@ -314,9 +314,6 @@
+ ELSE (UNIX)
+ SET(BUILD_CursesDialog 0)
+ ENDIF (UNIX)
+- IF(BUILD_CursesDialog)
+- ADD_SUBDIRECTORY(Source/CursesDialog/form)
+- ENDIF(BUILD_CursesDialog)
+ ENDMACRO (CMAKE_BUILD_UTILITIES)
+
+
+diff -u -r cmake-2.8.1.medium/Source/CursesDialog/CMakeLists.txt cmake-2.8.1/Source/CursesDialog/CMakeLists.txt
+--- cmake-2.8.1.medium/Source/CursesDialog/CMakeLists.txt 2010-03-16 21:29:34.000000000 +0100
++++ cmake-2.8.1/Source/CursesDialog/CMakeLists.txt 2010-04-04 20:01:38.000000000 +0200
+@@ -25,13 +25,18 @@
+ CursesDialog/ccmake
+ )
+
+-INCLUDE_DIRECTORIES(${CMake_SOURCE_DIR}/Source/CursesDialog/form
+- ${CMake_BINARY_DIR}/Source/CursesDialog/form)
+ INCLUDE_DIRECTORIES(${CURSES_INCLUDE_PATH})
+
+
+ ADD_EXECUTABLE(ccmake ${CURSES_SRCS} )
+ TARGET_LINK_LIBRARIES(ccmake CMakeLib)
+-TARGET_LINK_LIBRARIES(ccmake cmForm)
++TARGET_LINK_LIBRARIES(ccmake form)
++TARGET_LINK_LIBRARIES(ccmake ${CURSES_LIBRARY})
++IF(CURSES_EXTRA_LIBRARY)
++ TARGET_LINK_LIBRARIES(ccmake ${CURSES_EXTRA_LIBRARY})
++ENDIF(CURSES_EXTRA_LIBRARY)
++
+
+ INSTALL_TARGETS(/bin ccmake)
++
++
+diff -u -r cmake-2.8.1.medium/Source/CursesDialog/cmCursesStandardIncludes.h cmake-2.8.1/Source/CursesDialog/cmCursesStandardIncludes.h
+--- cmake-2.8.1.medium/Source/CursesDialog/cmCursesStandardIncludes.h 2010-03-16 21:29:35.000000000 +0100
++++ cmake-2.8.1/Source/CursesDialog/cmCursesStandardIncludes.h 2010-04-04 20:01:38.000000000 +0200
+@@ -15,8 +15,6 @@
+ #define _MSE_INT_H
+ #endif
+
+-#include <cmFormConfigure.h>
+-
+ #if defined(__hpux)
+ # define _BOOL_DEFINED
+ # include <sys/time.h>