summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-06-18 03:48:30 +0000
committerMike Frysinger <vapier@gentoo.org>2005-06-18 03:48:30 +0000
commita9c6f99dc3b0ae6e3369463c98ed2a29108cd2fa (patch)
tree358330f7b8e5c3ecb1b6dd7c48872fdba9d72994
parentVersion bump and reduction of the gdesklets-control-getid script (diff)
downloadgentoo-2-a9c6f99dc3b0ae6e3369463c98ed2a29108cd2fa.tar.gz
gentoo-2-a9c6f99dc3b0ae6e3369463c98ed2a29108cd2fa.tar.bz2
gentoo-2-a9c6f99dc3b0ae6e3369463c98ed2a29108cd2fa.zip
Version bump #96362 by Sheldon Hearn.
(Portage version: 2.0.51.22-r1)
-rw-r--r--sys-apps/logwatch/ChangeLog8
-rw-r--r--sys-apps/logwatch/files/digest-logwatch-6.1.21
-rw-r--r--sys-apps/logwatch/files/logwatch-6.1.2-emerge-applydate.patch16
-rw-r--r--sys-apps/logwatch/logwatch-6.1.2.ebuild67
4 files changed, 91 insertions, 1 deletions
diff --git a/sys-apps/logwatch/ChangeLog b/sys-apps/logwatch/ChangeLog
index 5abe912f1f1f..ae33b5c62153 100644
--- a/sys-apps/logwatch/ChangeLog
+++ b/sys-apps/logwatch/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/logwatch
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/logwatch/ChangeLog,v 1.22 2005/04/29 01:42:48 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/logwatch/ChangeLog,v 1.23 2005/06/18 03:48:30 vapier Exp $
+
+*logwatch-6.1.2 (18 Jun 2005)
+
+ 18 Jun 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/logwatch-6.1.2-emerge-applydate.patch, +logwatch-6.1.2.ebuild:
+ Version bump #96362 by Sheldon Hearn.
*logwatch-6.0.2 (29 Apr 2005)
diff --git a/sys-apps/logwatch/files/digest-logwatch-6.1.2 b/sys-apps/logwatch/files/digest-logwatch-6.1.2
new file mode 100644
index 000000000000..821cdb4c1f84
--- /dev/null
+++ b/sys-apps/logwatch/files/digest-logwatch-6.1.2
@@ -0,0 +1 @@
+MD5 a764bf80a31ab04ca788ac1303cba297 logwatch-6.1.2.tar.gz 168718
diff --git a/sys-apps/logwatch/files/logwatch-6.1.2-emerge-applydate.patch b/sys-apps/logwatch/files/logwatch-6.1.2-emerge-applydate.patch
new file mode 100644
index 000000000000..0cc6b3ac48c8
--- /dev/null
+++ b/sys-apps/logwatch/files/logwatch-6.1.2-emerge-applydate.patch
@@ -0,0 +1,16 @@
+Fix typo ... variable is named 'SearchDate' not 'date'
+
+patch by Sheldon Hearn
+http://bugs.gentoo.org/96362
+
+--- scripts/logfiles/emerge/applydate
++++ scripts/logfiles/emerge/applydate
+@@ -31,7 +31,7 @@
+
+ if ($Debug > 5) {
+ print STDERR "DEBUG: Inside applydate (emerge)...\n";
+- print STDERR "DEBUG: Looking For: $date\n";
++ print STDERR "DEBUG: Looking For: $SearchDate\n";
+ }
+
+ # Examine each line of the file, writing out only the lines that are within
diff --git a/sys-apps/logwatch/logwatch-6.1.2.ebuild b/sys-apps/logwatch/logwatch-6.1.2.ebuild
new file mode 100644
index 000000000000..4c5ea50eb653
--- /dev/null
+++ b/sys-apps/logwatch/logwatch-6.1.2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/logwatch/logwatch-6.1.2.ebuild,v 1.1 2005/06/18 03:48:30 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="Analyzes and Reports on system logs"
+HOMEPAGE="http://www.logwatch.org/"
+SRC_URI="ftp://ftp.kaybee.org/pub/linux/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="virtual/cron
+ virtual/mta
+ dev-lang/perl
+ dev-perl/Tie-IxHash
+ dev-perl/Date-Calc
+ virtual/mailx"
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-emerge-applydate.patch
+}
+
+src_install() {
+ dodir /etc/log.d/lib
+ dodir /etc/log.d/conf/logfiles
+ dodir /etc/log.d/conf/services
+ dodir /etc/log.d/scripts/services
+ dodir /etc/log.d/scripts/shared
+
+ newsbin scripts/logwatch.pl logwatch.pl
+
+ for i in scripts/logfiles/* ; do
+ exeinto /etc/log.d/$i
+ doexe $i/* || die "doexe $i failed"
+ done
+
+ exeinto /etc/log.d/lib
+ doexe lib/*.pm
+
+ exeinto /etc/log.d/scripts/services
+ doexe scripts/services/*
+
+ exeinto /etc/log.d/scripts/shared
+ doexe scripts/shared/*
+
+ insinto /etc/log.d/conf
+ doins conf/logwatch.conf
+
+ insinto /etc/log.d/conf/logfiles
+ doins conf/logfiles/*
+
+ insinto /etc/log.d/conf/services
+ doins conf/services/*
+
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/logwatch logwatch
+
+ doman logwatch.8
+ dodoc License project/CHANGES README HOWTO-Make-Filter
+}