summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Shakaryan <omp@gentoo.org>2006-10-22 00:05:32 +0000
committerDavid Shakaryan <omp@gentoo.org>2006-10-22 00:05:32 +0000
commitadb94c89e9cb2069eb59b3749ac009be7817ef39 (patch)
tree7f18021a8b08ef8811de46251f9542a2c0fd3b0f
parentEnable oss by default to have some audio support. (diff)
downloadgentoo-2-adb94c89e9cb2069eb59b3749ac009be7817ef39.tar.gz
gentoo-2-adb94c89e9cb2069eb59b3749ac009be7817ef39.tar.bz2
gentoo-2-adb94c89e9cb2069eb59b3749ac009be7817ef39.zip
Remove monolithic X from dependencies, use MY_P and fix quotes.
(Portage version: 2.1.2_pre3-r6)
-rw-r--r--x11-misc/fspanel/ChangeLog5
-rw-r--r--x11-misc/fspanel/fspanel-0.8_beta1-r2.ebuild36
2 files changed, 21 insertions, 20 deletions
diff --git a/x11-misc/fspanel/ChangeLog b/x11-misc/fspanel/ChangeLog
index b64eab228c00..12d2fb328612 100644
--- a/x11-misc/fspanel/ChangeLog
+++ b/x11-misc/fspanel/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-misc/fspanel
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/fspanel/ChangeLog,v 1.13 2006/10/11 11:17:53 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/fspanel/ChangeLog,v 1.14 2006/10/22 00:05:32 omp Exp $
+
+ 22 Oct 2006; David Shakaryan <omp@gentoo.org> fspanel-0.8_beta1-r2.ebuild:
+ Remove monolithic X from dependencies, use MY_P and fix quotes.
11 Oct 2006; Krzysiek Pawlik <nelchael@gentoo.org>
fspanel-0.8_beta1-r2.ebuild:
diff --git a/x11-misc/fspanel/fspanel-0.8_beta1-r2.ebuild b/x11-misc/fspanel/fspanel-0.8_beta1-r2.ebuild
index be0768dae1ed..e372510ee826 100644
--- a/x11-misc/fspanel/fspanel-0.8_beta1-r2.ebuild
+++ b/x11-misc/fspanel/fspanel-0.8_beta1-r2.ebuild
@@ -1,46 +1,44 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/fspanel/fspanel-0.8_beta1-r2.ebuild,v 1.7 2006/10/11 11:17:53 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/fspanel/fspanel-0.8_beta1-r2.ebuild,v 1.8 2006/10/22 00:05:32 omp Exp $
+
+MY_P=${P/_beta/beta}
-S=${WORKDIR}/fspanel-0.8beta1
DESCRIPTION="F***ing Small Panel. Good (and small) replacement for gnome-panel"
-SRC_URI="http://www.chatjunkies.org/fspanel/fspanel-0.8beta1.tar.gz"
HOMEPAGE="http://www.chatjunkies.org/fspanel"
+SRC_URI="http://www.chatjunkies.org/fspanel/${MY_P}.tar.gz"
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 sparc ppc ~amd64"
IUSE=""
-LICENSE="GPL-2"
-RDEPEND="|| ( (
- x11-libs/libX11
- x11-libs/libXpm
- x11-libs/libXft )
- virtual/x11 )"
+RDEPEND="x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXft"
DEPEND="${RDEPEND}
- || ( x11-proto/xproto virtual/x11 )
- dev-util/pkgconfig"
+ dev-util/pkgconfig
+ x11-proto/xproto"
-src_unpack() {
+S=${WORKDIR}/${MY_P}
+src_unpack() {
unpack ${A}
sed -i -e 's,/X11R6,,g' "${S}/configure"
-
}
src_compile() {
-
- if pkg-config xft
- then
+ if pkg-config xft; then
CFLAGS="${CFLAGS} -I/usr/include/freetype2"
fi
- ./configure
- emake || die
+
+ ./configure || die "configure failed"
+ emake || die "emake failed"
}
src_install () {
exeinto /usr/bin
- doexe ${S}/fspanel
+ doexe "${S}/fspanel"
dodoc README
}