summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-28 01:51:49 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-28 01:51:49 +0000
commitae504ef4d4a7456e9dc0885c3054ccb6d0964126 (patch)
tree2e77fce6621b91fec7fff28dd744c5da7b987869
parentQA - fix use invocation (Manifest recommit) (diff)
downloadgentoo-2-ae504ef4d4a7456e9dc0885c3054ccb6d0964126.tar.gz
gentoo-2-ae504ef4d4a7456e9dc0885c3054ccb6d0964126.tar.bz2
gentoo-2-ae504ef4d4a7456e9dc0885c3054ccb6d0964126.zip
touch the libc
-rw-r--r--app-i18n/jfbterm/jfbterm-0.4.4.ebuild6
-rw-r--r--app-i18n/jfbterm/jfbterm-0.4.5.ebuild6
-rw-r--r--app-i18n/jfbterm/jfbterm-0.4.6.ebuild6
-rw-r--r--app-i18n/jless-iso254/jless-iso254-358.ebuild5
-rw-r--r--app-i18n/jmode/jmode-0.6.7.ebuild14
-rw-r--r--app-i18n/kakasi/kakasi-2.3.4.ebuild11
-rw-r--r--app-i18n/kanjipad/kanjipad-1.2.3.ebuild14
-rw-r--r--app-i18n/kanjipad/kanjipad-2.0.0.ebuild14
-rw-r--r--app-i18n/kcc/kcc-1.0.ebuild6
-rw-r--r--app-i18n/kinput2/kinput2-3.1-r1.ebuild4
-rw-r--r--app-i18n/kon2/kon2-0.3.9b-r1.ebuild10
-rw-r--r--app-i18n/libjconv/libjconv-2.9.ebuild8
12 files changed, 46 insertions, 58 deletions
diff --git a/app-i18n/jfbterm/jfbterm-0.4.4.ebuild b/app-i18n/jfbterm/jfbterm-0.4.4.ebuild
index e339b9d83a7c..7906c9df05dd 100644
--- a/app-i18n/jfbterm/jfbterm-0.4.4.ebuild
+++ b/app-i18n/jfbterm/jfbterm-0.4.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/jfbterm/jfbterm-0.4.4.ebuild,v 1.6 2004/06/24 21:47:29 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/jfbterm/jfbterm-0.4.4.ebuild,v 1.7 2004/06/28 01:46:54 vapier Exp $
inherit flag-o-matic
@@ -13,12 +13,12 @@ SLOT="0"
KEYWORDS="x86 ppc sparc"
IUSE=""
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
>=sys-apps/sed-4
>=sys-devel/autoconf-2.58
sys-devel/automake
sys-libs/ncurses"
-RDEPEND="virtual/glibc"
+RDEPEND="virtual/libc"
src_compile() {
replace-flags -march=pentium3 -mcpu=pentium3
diff --git a/app-i18n/jfbterm/jfbterm-0.4.5.ebuild b/app-i18n/jfbterm/jfbterm-0.4.5.ebuild
index 9f36e32d2219..b69c9673942c 100644
--- a/app-i18n/jfbterm/jfbterm-0.4.5.ebuild
+++ b/app-i18n/jfbterm/jfbterm-0.4.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/jfbterm/jfbterm-0.4.5.ebuild,v 1.5 2004/06/24 21:47:29 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/jfbterm/jfbterm-0.4.5.ebuild,v 1.6 2004/06/28 01:46:54 vapier Exp $
inherit flag-o-matic
@@ -13,12 +13,12 @@ SLOT="0"
KEYWORDS="x86 ppc ~sparc"
IUSE=""
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
>=sys-apps/sed-4
>=sys-devel/autoconf-2.58
sys-devel/automake
sys-libs/ncurses"
-RDEPEND="virtual/glibc"
+RDEPEND="virtual/libc"
src_compile() {
replace-flags -march=pentium3 -mcpu=pentium3
diff --git a/app-i18n/jfbterm/jfbterm-0.4.6.ebuild b/app-i18n/jfbterm/jfbterm-0.4.6.ebuild
index c0962267f7b6..4f1eb747c8d4 100644
--- a/app-i18n/jfbterm/jfbterm-0.4.6.ebuild
+++ b/app-i18n/jfbterm/jfbterm-0.4.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/jfbterm/jfbterm-0.4.6.ebuild,v 1.4 2004/06/24 21:47:29 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/jfbterm/jfbterm-0.4.6.ebuild,v 1.5 2004/06/28 01:46:54 vapier Exp $
inherit flag-o-matic
@@ -13,12 +13,12 @@ SLOT="0"
KEYWORDS="x86 ppc ~sparc"
IUSE=""
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
>=sys-apps/sed-4
>=sys-devel/autoconf-2.58
sys-devel/automake
sys-libs/ncurses"
-RDEPEND="virtual/glibc"
+RDEPEND="virtual/libc"
src_compile() {
replace-flags -march=pentium3 -mcpu=pentium3
diff --git a/app-i18n/jless-iso254/jless-iso254-358.ebuild b/app-i18n/jless-iso254/jless-iso254-358.ebuild
index 3924fe431069..179dad545618 100644
--- a/app-i18n/jless-iso254/jless-iso254-358.ebuild
+++ b/app-i18n/jless-iso254/jless-iso254-358.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/jless-iso254/jless-iso254-358.ebuild,v 1.12 2004/06/24 21:47:40 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/jless-iso254/jless-iso254-358.ebuild,v 1.13 2004/06/28 01:47:21 vapier Exp $
inherit eutils
@@ -16,13 +16,12 @@ SLOT="0"
KEYWORDS="x86 ppc sparc alpha"
IUSE=""
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
>=sys-libs/ncurses-5.2"
S=${WORKDIR}/${LESS_P}
src_unpack() {
-
unpack ${LESS_P}.tar.gz
cd ${S}
epatch ${DISTDIR}/${LESS_P}-iso254.patch.gz
diff --git a/app-i18n/jmode/jmode-0.6.7.ebuild b/app-i18n/jmode/jmode-0.6.7.ebuild
index 6d1543acefc6..5ccfb2831509 100644
--- a/app-i18n/jmode/jmode-0.6.7.ebuild
+++ b/app-i18n/jmode/jmode-0.6.7.ebuild
@@ -1,32 +1,28 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/jmode/jmode-0.6.7.ebuild,v 1.3 2004/06/24 21:48:00 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/jmode/jmode-0.6.7.ebuild,v 1.4 2004/06/28 01:47:55 vapier Exp $
-IUSE="gnome"
-
-DESCRIPTION="Jmode is a Japanese IME supporting Anthy"
+DESCRIPTION="a Japanese IME supporting Anthy"
HOMEPAGE="http://anthy.sourceforge.jp/"
SRC_URI="mirror://sourceforge.jp/anthy/5467/${P}.tar.gz"
LICENSE="GPL-2"
-KEYWORDS="x86"
SLOT="0"
+KEYWORDS="x86"
+IUSE="gnome"
DEPEND="=x11-libs/gtk+-1.2*
app-i18n/anthy
gnome? ( gnome-base/gnome-panel )"
src_compile() {
-
# --with-skk and --with-engine=anthy are exclusive
econf `use_with gnome` \
--with-engine=anthy || die
emake CPPFLAGS="${CPPFLAGS} -DCONF_DIR=\\\"/etc/jmode/\\\"" || die
}
-src_install () {
-
+src_install() {
einstall pkgdatadir=${D}/etc/jmode || die
-
dodoc AUTHORS ChangeLog INSTALL NEWS README
}
diff --git a/app-i18n/kakasi/kakasi-2.3.4.ebuild b/app-i18n/kakasi/kakasi-2.3.4.ebuild
index cafe866260c0..8354ec82ec5c 100644
--- a/app-i18n/kakasi/kakasi-2.3.4.ebuild
+++ b/app-i18n/kakasi/kakasi-2.3.4.ebuild
@@ -1,20 +1,17 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/kakasi/kakasi-2.3.4.ebuild,v 1.5 2004/06/24 21:48:15 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/kakasi/kakasi-2.3.4.ebuild,v 1.6 2004/06/28 01:48:18 vapier Exp $
-DESCRIPTION="Converts Japanese text between kanji, kana, and romaji."
+DESCRIPTION="Converts Japanese text between kanji, kana, and romaji"
HOMEPAGE="http://kakasi.namazu.org/"
SRC_URI="http://kakasi.namazu.org/stable/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 amd64 ~ppc ~sparc alpha"
IUSE=""
-DEPEND="virtual/glibc"
-src_compile() {
- econf || die
- emake || die
-}
+DEPEND="virtual/libc"
src_install() {
make DESTDIR=${D} install || die
diff --git a/app-i18n/kanjipad/kanjipad-1.2.3.ebuild b/app-i18n/kanjipad/kanjipad-1.2.3.ebuild
index ffb908e863c0..4398138c97cb 100644
--- a/app-i18n/kanjipad/kanjipad-1.2.3.ebuild
+++ b/app-i18n/kanjipad/kanjipad-1.2.3.ebuild
@@ -1,19 +1,18 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/kanjipad/kanjipad-1.2.3.ebuild,v 1.6 2004/06/24 21:48:25 agriffis Exp $
-
-IUSE=""
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/kanjipad/kanjipad-1.2.3.ebuild,v 1.7 2004/06/28 01:48:40 vapier Exp $
DESCRIPTION="Japanese handwriting recognition tool"
HOMEPAGE="http://www.gtk.org/~otaylor/kanjipad/"
SRC_URI="ftp://ftp.gtk.org/pub/users/otaylor/kanjipad/${P}.tar.gz"
LICENSE="GPL-2"
-DEPEND=">=x11-libs/gtk+-1.2.10-r8
- >=dev-libs/glib-1.2.10-r4"
+SLOT="0"
KEYWORDS="x86"
+IUSE=""
-SLOT="0"
+DEPEND=">=x11-libs/gtk+-1.2.10-r8
+ >=dev-libs/glib-1.2.10-r4"
src_compile() {
mv Makefile Makefile.orig
@@ -22,9 +21,8 @@ src_compile() {
emake || die
}
-src_install () {
+src_install() {
dobin kanjipad kpengine || die
- dodir /usr/share/kanjipad || die
insinto /usr/share/kanjipad
doins jdata.dat || die
}
diff --git a/app-i18n/kanjipad/kanjipad-2.0.0.ebuild b/app-i18n/kanjipad/kanjipad-2.0.0.ebuild
index 6a05ba9ee60c..218b2638d69a 100644
--- a/app-i18n/kanjipad/kanjipad-2.0.0.ebuild
+++ b/app-i18n/kanjipad/kanjipad-2.0.0.ebuild
@@ -1,19 +1,18 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/kanjipad/kanjipad-2.0.0.ebuild,v 1.5 2004/06/24 21:48:25 agriffis Exp $
-
-IUSE=""
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/kanjipad/kanjipad-2.0.0.ebuild,v 1.6 2004/06/28 01:48:40 vapier Exp $
DESCRIPTION="Japanese handwriting recognition tool"
HOMEPAGE="http://fishsoup.net/software/kanjipad/"
SRC_URI="http://fishsoup.net/software/kanjipad/${P}.tar.gz"
LICENSE="GPL-2"
-
SLOT="0"
+KEYWORDS="x86 amd64"
+IUSE=""
+
DEPEND=">=x11-libs/gtk+-2
>=dev-libs/glib-2"
-KEYWORDS="x86 amd64"
src_compile() {
perl -i -pe "s|PREFIX=/usr/local|PREFIX=/usr|;
@@ -22,10 +21,9 @@ src_compile() {
emake || die
}
-src_install () {
+src_install() {
dobin kanjipad kpengine || die
- dodir /usr/share/kanjipad || die
insinto /usr/share/kanjipad
doins jdata.dat || die
- dodoc COPYING ChangeLog README TODO jstroke/README-kanjipad
+ dodoc ChangeLog README TODO jstroke/README-kanjipad
}
diff --git a/app-i18n/kcc/kcc-1.0.ebuild b/app-i18n/kcc/kcc-1.0.ebuild
index e42a837e36d1..bc831308252e 100644
--- a/app-i18n/kcc/kcc-1.0.ebuild
+++ b/app-i18n/kcc/kcc-1.0.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/kcc/kcc-1.0.ebuild,v 1.9 2004/06/24 21:48:40 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/kcc/kcc-1.0.ebuild,v 1.10 2004/06/28 01:49:02 vapier Exp $
inherit gcc eutils
DESCRIPTION="A Kanji code converter"
-HOMEPAGE="" #There doesn't seem to be a home page for this package!
+HOMEPAGE="" # There doesn't seem to be a home page for this package!
SRC_URI="ftp://ftp.jp.freebsd.org/pub/FreeBSD/ports/distfiles/${PN}.tar.gz"
LICENSE="GPL-2"
@@ -13,7 +13,7 @@ SLOT="0"
KEYWORDS="x86"
IUSE=""
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
S="${WORKDIR}/${PN}"
diff --git a/app-i18n/kinput2/kinput2-3.1-r1.ebuild b/app-i18n/kinput2/kinput2-3.1-r1.ebuild
index 1976fc1be66c..9df131c0b4e9 100644
--- a/app-i18n/kinput2/kinput2-3.1-r1.ebuild
+++ b/app-i18n/kinput2/kinput2-3.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/kinput2/kinput2-3.1-r1.ebuild,v 1.9 2004/06/24 21:48:51 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/kinput2/kinput2-3.1-r1.ebuild,v 1.10 2004/06/28 01:49:31 vapier Exp $
inherit eutils
@@ -14,7 +14,7 @@ SLOT="0"
KEYWORDS="x86 ~ppc sparc ~amd64"
IUSE="canna freewnn"
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
canna? ( >=app-i18n/canna-3.5_beta2-r1 )
!amd64? ( freewnn? ( >=app-i18n/freewnn-1.1.1_alpha19 ) )
!freewnn? ( >=app-i18n/canna-3.5_beta2-r1 )"
diff --git a/app-i18n/kon2/kon2-0.3.9b-r1.ebuild b/app-i18n/kon2/kon2-0.3.9b-r1.ebuild
index c217228ee1ca..719d2b8e9cc9 100644
--- a/app-i18n/kon2/kon2-0.3.9b-r1.ebuild
+++ b/app-i18n/kon2/kon2-0.3.9b-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/kon2/kon2-0.3.9b-r1.ebuild,v 1.7 2004/06/24 21:49:18 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/kon2/kon2-0.3.9b-r1.ebuild,v 1.8 2004/06/28 01:50:31 vapier Exp $
inherit eutils
@@ -13,11 +13,11 @@ SLOT="0"
KEYWORDS="x86"
IUSE=""
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
RDEPEND="${DEPEND}
>=media-fonts/konfont-0.1"
-src_unpack(){
+src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/${P}-gentoo.patch
@@ -26,13 +26,13 @@ src_unpack(){
epatch ${FILESDIR}/${P}-racecondition-fix3.patch
}
-src_compile(){
+src_compile() {
make config || die
make depend || die
make || die
}
-src_install(){
+src_install() {
make LIBDIR=${D}/etc \
MANDIR=${D}/usr/share/man/ja/man1 \
BINDIR=${D}/usr/bin install || die
diff --git a/app-i18n/libjconv/libjconv-2.9.ebuild b/app-i18n/libjconv/libjconv-2.9.ebuild
index d0fede1a22c2..416626f5f240 100644
--- a/app-i18n/libjconv/libjconv-2.9.ebuild
+++ b/app-i18n/libjconv/libjconv-2.9.ebuild
@@ -1,17 +1,17 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/libjconv/libjconv-2.9.ebuild,v 1.5 2004/06/24 21:49:54 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/libjconv/libjconv-2.9.ebuild,v 1.6 2004/06/28 01:51:49 vapier Exp $
DESCRIPTION="A library for converting between kanji encodings"
-SRC_URI="http://ghost.math.sci.hokudai.ac.jp/misc/${PN}/${P}.tar.gz"
HOMEPAGE="http://ghost.math.sci.hokudai.ac.jp/misc/${PN}"
+SRC_URI="http://ghost.math.sci.hokudai.ac.jp/misc/${PN}/${P}.tar.gz"
LICENSE="LGPL-2"
-KEYWORDS="x86"
IUSE=""
+KEYWORDS="x86"
SLOT="0"
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
src_compile() {
emake || die