summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-03-23 15:06:55 +0000
committerMark Wright <gienah@gentoo.org>2014-03-23 15:06:55 +0000
commitaeae6d571081be11eb652eccb1cb6d738f23f86b (patch)
tree54a327748dbd677a64bfb4da730c23645691bcf7
parentBump wxdirect to 0.13.1.3 and 0.90.1.1 (diff)
downloadgentoo-2-aeae6d571081be11eb652eccb1cb6d738f23f86b.tar.gz
gentoo-2-aeae6d571081be11eb652eccb1cb6d738f23f86b.tar.bz2
gentoo-2-aeae6d571081be11eb652eccb1cb6d738f23f86b.zip
Bump wxhaskell to 0.13.2.3 and 0.90.1.0
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
-rw-r--r--dev-haskell/wxhaskell/ChangeLog11
-rw-r--r--dev-haskell/wxhaskell/wxhaskell-0.13.2.3.ebuild37
-rw-r--r--dev-haskell/wxhaskell/wxhaskell-0.90.1.0.ebuild37
3 files changed, 83 insertions, 2 deletions
diff --git a/dev-haskell/wxhaskell/ChangeLog b/dev-haskell/wxhaskell/ChangeLog
index 81fdbc235a87..92aa4c6a5ede 100644
--- a/dev-haskell/wxhaskell/ChangeLog
+++ b/dev-haskell/wxhaskell/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-haskell/wxhaskell
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wxhaskell/ChangeLog,v 1.35 2013/04/02 05:06:41 gienah Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wxhaskell/ChangeLog,v 1.36 2014/03/23 15:06:55 gienah Exp $
+
+*wxhaskell-0.90.1.0 (23 Mar 2014)
+*wxhaskell-0.13.2.3 (23 Mar 2014)
+
+ 23 Mar 2014; Mark Wright <gienah@gentoo.org> +wxhaskell-0.13.2.3.ebuild,
+ +wxhaskell-0.90.1.0.ebuild:
+ Bump wxhaskell to 0.13.2.3 and 0.90.1.0
*wxhaskell-0.90.0.1 (02 Apr 2013)
diff --git a/dev-haskell/wxhaskell/wxhaskell-0.13.2.3.ebuild b/dev-haskell/wxhaskell/wxhaskell-0.13.2.3.ebuild
new file mode 100644
index 000000000000..7b19386920f1
--- /dev/null
+++ b/dev-haskell/wxhaskell/wxhaskell-0.13.2.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wxhaskell/wxhaskell-0.13.2.3.ebuild,v 1.1 2014/03/23 15:06:55 gienah Exp $
+
+EAPI=5
+
+WX_GTK_VER="2.8"
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN=wx
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="wxHaskell"
+HOMEPAGE="http://haskell.org/haskellwiki/WxHaskell"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="wxWinLL-3.1"
+SLOT="${WX_GTK_VER}/${PV}"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/stm:=[profile?]
+ >=dev-haskell/wxcore-0.13.2.3:${WX_GTK_VER}=[profile?] <dev-haskell/wxcore-0.90:${WX_GTK_VER}=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6.0.3
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=newbase
+}
diff --git a/dev-haskell/wxhaskell/wxhaskell-0.90.1.0.ebuild b/dev-haskell/wxhaskell/wxhaskell-0.90.1.0.ebuild
new file mode 100644
index 000000000000..8f849eef84f5
--- /dev/null
+++ b/dev-haskell/wxhaskell/wxhaskell-0.90.1.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wxhaskell/wxhaskell-0.90.1.0.ebuild,v 1.1 2014/03/23 15:06:55 gienah Exp $
+
+EAPI=5
+
+WX_GTK_VER="2.9"
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN=wx
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="wxHaskell"
+HOMEPAGE="http://haskell.org/haskellwiki/WxHaskell"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="wxWinLL-3.1"
+SLOT="${WX_GTK_VER}/${PV}"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/stm:=[profile?]
+ >=dev-haskell/wxcore-0.90.1.0:${WX_GTK_VER}=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6.0.3
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=newbase
+}