summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-07-04 09:32:15 +0000
committerJustin Lecher <jlec@gentoo.org>2012-07-04 09:32:15 +0000
commitaec48ab9df4df2a1145ced511c8d68477d8ee2ac (patch)
treee49072a0ef6f7eae5d5ac1b39c9e9755546a87b7
parentUpdate Manifest with new hashes. (diff)
downloadgentoo-2-aec48ab9df4df2a1145ced511c8d68477d8ee2ac.tar.gz
gentoo-2-aec48ab9df4df2a1145ced511c8d68477d8ee2ac.tar.bz2
gentoo-2-aec48ab9df4df2a1145ced511c8d68477d8ee2ac.zip
sci-mathematics/unuran: Move to autotool-utils.eclass
(Portage version: 2.2.0_alpha115/cvs/Linux x86_64)
-rw-r--r--sci-mathematics/unuran/ChangeLog6
-rw-r--r--sci-mathematics/unuran/metadata.xml12
-rw-r--r--sci-mathematics/unuran/unuran-1.8.1.ebuild26
3 files changed, 26 insertions, 18 deletions
diff --git a/sci-mathematics/unuran/ChangeLog b/sci-mathematics/unuran/ChangeLog
index 65e492764677..d89a2d9221a2 100644
--- a/sci-mathematics/unuran/ChangeLog
+++ b/sci-mathematics/unuran/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/unuran
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/unuran/ChangeLog,v 1.5 2012/06/26 21:19:33 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/unuran/ChangeLog,v 1.6 2012/07/04 09:32:15 jlec Exp $
+
+ 04 Jul 2012; Justin Lecher <jlec@gentoo.org> unuran-1.8.1.ebuild,
+ metadata.xml:
+ Move to autotool-utils.eclass
26 Jun 2012; Sebastien Fabbro <fabbros@gentoo.org> -unuran-1.8.0.ebuild,
unuran-1.8.1.ebuild:
diff --git a/sci-mathematics/unuran/metadata.xml b/sci-mathematics/unuran/metadata.xml
index 497acf9f54bd..2901b3b649b9 100644
--- a/sci-mathematics/unuran/metadata.xml
+++ b/sci-mathematics/unuran/metadata.xml
@@ -1,16 +1,16 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci-mathematics</herd>
-<longdescription lang="en">
+ <herd>sci-mathematics</herd>
+ <longdescription lang="en">
UNU.RAN is an ANSI C library licensed under GPL.
It contains universal (also called automatic or black-box) algorithms
that can generate random numbers from large classes of continuous or
discrete distributions, and also from practically all standard
distributions.
</longdescription>
-<use>
- <flag name="rngstreams">Use <pkg>sci-mathematics/rngstreams</pkg> library</flag>
- <flag name="prng">Use <pkg>sci-mathematics/prng</pkg> library</flag>
-</use>
+ <use>
+ <flag name="rngstreams">Use <pkg>sci-mathematics/rngstreams</pkg> library</flag>
+ <flag name="prng">Use <pkg>sci-mathematics/prng</pkg> library</flag>
+ </use>
</pkgmetadata>
diff --git a/sci-mathematics/unuran/unuran-1.8.1.ebuild b/sci-mathematics/unuran/unuran-1.8.1.ebuild
index c9b95488044d..4d15d0ae8cd4 100644
--- a/sci-mathematics/unuran/unuran-1.8.1.ebuild
+++ b/sci-mathematics/unuran/unuran-1.8.1.ebuild
@@ -1,19 +1,22 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/unuran/unuran-1.8.1.ebuild,v 1.2 2012/06/26 21:19:33 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/unuran/unuran-1.8.1.ebuild,v 1.3 2012/07/04 09:32:15 jlec Exp $
EAPI=4
-inherit eutils
+
+inherit autotools-utils
DESCRIPTION="Universal Non-Uniform Random number generator"
HOMEPAGE="http://statmath.wu.ac.at/unuran/"
SRC_URI="${HOMEPAGE}${P}.tar.gz"
-LICENSE="GPL-2"
+LICENSE="GPL-2"
SLOT=0
KEYWORDS="~amd64 ~x86 ~amd64 ~x86-linux"
IUSE="doc examples gsl prng +rngstreams static-libs"
-DEPEND="gsl? ( sci-libs/gsl )
+
+DEPEND="
+ gsl? ( sci-libs/gsl )
prng? ( sci-mathematics/prng )
rngstreams? ( sci-mathematics/rngstreams )"
RDEPEND="${DEPEND}"
@@ -21,17 +24,18 @@ RDEPEND="${DEPEND}"
src_configure() {
local udefault=builtin
use rngstreams && udefault=rngstream
- econf \
- --enable-shared \
- --with-urng-default=${udefault} \
- $(use_enable static-libs static) \
- $(use_with gsl urng-gsl) \
- $(use_with prng urng-prng) \
+ local myeconfargs=(
+ --enable-shared
+ --with-urng-default=${udefault}
+ $(use_with gsl urng-gsl)
+ $(use_with prng urng-prng)
$(use_with rngstreams urng-rngstream)
+ )
+ autotools-utils_src_configure
}
src_install() {
- default
+ autotools-utils_src_install
use doc && dodoc doc/${PN}.pdf
if use examples; then
emake distclean -C examples