summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-06-07 21:57:39 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-06-07 21:57:39 +0000
commitaf146d64bf09191e7e5b5e37031a91b065bd49eb (patch)
tree64cc9385d65d2aa507c8192eb73a2f0c46ff81fe
parentMarking netperf-2.5.0-r1 ppc for bug 419221 (diff)
downloadgentoo-2-af146d64bf09191e7e5b5e37031a91b065bd49eb.tar.gz
gentoo-2-af146d64bf09191e7e5b5e37031a91b065bd49eb.tar.bz2
gentoo-2-af146d64bf09191e7e5b5e37031a91b065bd49eb.zip
Version bump; new dependency, fixed tests.
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
-rw-r--r--dev-ruby/thor/ChangeLog7
-rw-r--r--dev-ruby/thor/thor-0.15.2.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/dev-ruby/thor/ChangeLog b/dev-ruby/thor/ChangeLog
index 052073d6684d..cf854e33ba97 100644
--- a/dev-ruby/thor/ChangeLog
+++ b/dev-ruby/thor/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/thor
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/thor/ChangeLog,v 1.14 2012/05/01 18:24:26 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/thor/ChangeLog,v 1.15 2012/06/07 21:57:39 flameeyes Exp $
+
+*thor-0.15.2 (07 Jun 2012)
+
+ 07 Jun 2012; Diego E. Pettenò <flameeyes@gentoo.org> +thor-0.15.2.ebuild:
+ Version bump; new dependency, fixed tests.
01 May 2012; Raúl Porcel <armin76@gentoo.org> thor-0.14.6.ebuild:
Drop ia64/sparc keywords
diff --git a/dev-ruby/thor/thor-0.15.2.ebuild b/dev-ruby/thor/thor-0.15.2.ebuild
new file mode 100644
index 000000000000..60a8ccc4a636
--- /dev/null
+++ b/dev-ruby/thor/thor-0.15.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/thor/thor-0.15.2.ebuild,v 1.1 2012/06/07 21:57:39 flameeyes Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc README.md"
+RUBY_FAKEGEM_BINWRAP="thor"
+
+RUBY_S="wycats-${PN}-*"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A scripting framework that replaces rake and sake"
+HOMEPAGE="http://github.com/wycats/thor"
+
+SRC_URI="http://github.com/wycats/${PN}/tarball/v${PV} -> ${PN}-git-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/fakeweb
+ dev-ruby/rspec:2
+ dev-ruby/childlabor
+ )
+ doc? (
+ dev-ruby/rdoc
+ )"
+
+all_ruby_prepare() {
+ # Remove rspec default options (as we might not have the last
+ # rspec).
+ rm .rspec || die
+
+ # Remove Bundler
+ rm Gemfile || die
+ sed -i -e '/[Bb]undler/d' Thorfile || die
+
+ # Remove mandatory coverage collection using simplecov which is not
+ # packaged.
+ sed -i -e '/require .simplecov/, /^end/ d' spec/spec_helper.rb || die
+}
+
+all_ruby_compile() {
+ if use doc; then
+ ruby -Ilib bin/thor rdoc || die "RDoc generation failed"
+ fi
+}
+
+each_ruby_test() {
+ ${RUBY} -S rspec spec || die "Tests for ${RUBY} failed"
+}