summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDawid Węgliński <cla@gentoo.org>2010-03-03 18:03:04 +0000
committerDawid Węgliński <cla@gentoo.org>2010-03-03 18:03:04 +0000
commitb2247ce27bb0a1bc4c022f6777ab28520dfdb8f8 (patch)
tree6bd1c56c6731f34ca6abc8e3e3b559888f1fecc1
parentInitial work on making ffmpeg support more sane wrt bug #306921. Used (diff)
downloadgentoo-2-b2247ce27bb0a1bc4c022f6777ab28520dfdb8f8.tar.gz
gentoo-2-b2247ce27bb0a1bc4c022f6777ab28520dfdb8f8.tar.bz2
gentoo-2-b2247ce27bb0a1bc4c022f6777ab28520dfdb8f8.zip
Version bump wrt bug #292389
(Portage version: 2.2_rc63/cvs/Linux x86_64)
-rw-r--r--app-portage/portato/ChangeLog9
-rw-r--r--app-portage/portato/portato-0.13.1.ebuild112
2 files changed, 119 insertions, 2 deletions
diff --git a/app-portage/portato/ChangeLog b/app-portage/portato/ChangeLog
index aa5c9cf34bb8..ddf09b77be76 100644
--- a/app-portage/portato/ChangeLog
+++ b/app-portage/portato/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-portage/portato
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/portato/ChangeLog,v 1.19 2009/09/01 11:01:51 patrick Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/portato/ChangeLog,v 1.20 2010/03/03 18:03:04 cla Exp $
+
+*portato-0.13.1 (03 Mar 2010)
+
+ 03 Mar 2010; Dawid Węgliński <cla@gentoo.org> +portato-0.13.1.ebuild:
+ Version bump wrt bug #292389
01 Sep 2009; Patrick Lauer <patrick@gentoo.org> -portato-0.10.ebuild,
-portato-0.11.1.ebuild:
diff --git a/app-portage/portato/portato-0.13.1.ebuild b/app-portage/portato/portato-0.13.1.ebuild
new file mode 100644
index 000000000000..20c5dd188d26
--- /dev/null
+++ b/app-portage/portato/portato-0.13.1.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/portato/portato-0.13.1.ebuild,v 1.1 2010/03/03 18:03:04 cla Exp $
+
+EAPI="2"
+
+NEED_PYTHON="2.5"
+inherit python eutils distutils
+
+DESCRIPTION="A GUI for Portage written in Python."
+HOMEPAGE="http://portato.origo.ethz.ch/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="kde +libnotify nls userpriv sqlite"
+LANGS="ca de es_ES pl pt_BR tr"
+for X in $LANGS; do IUSE="${IUSE} linguas_${X}"; done
+
+RDEPEND="app-portage/portage-utils
+ x11-libs/vte[python]
+ >=dev-lang/python-2.5[sqlite?,threads]
+ dev-python/pygtksourceview:2
+ >=dev-python/pygtk-2.14.0
+ dev-python/shm
+ >=sys-apps/portage-2.1.6
+
+ !userpriv? (
+ kde? ( kde-base/kdesu )
+ !kde? ( || ( x11-misc/ktsuss x11-libs/gksu ) ) )
+
+ libnotify? ( dev-python/notify-python )
+ nls? ( virtual/libintl )"
+
+# only needs gettext as build dependency
+# python should be set as DEPEND in the python-eclass
+DEPEND="nls? ( sys-devel/gettext )"
+
+CONFIG_DIR="etc/${PN}"
+DATA_DIR="usr/share/${PN}"
+LOCALE_DIR="usr/share/locale"
+PLUGIN_DIR="${DATA_DIR}/plugins"
+ICON_DIR="${DATA_DIR}/icons"
+TEMPLATE_DIR="${DATA_DIR}/templates"
+
+src_configure ()
+{
+ sed -i -e "s;^\(VERSION\s*=\s*\).*;\1\"${PV}\";" \
+ -e "s;^\(CONFIG_DIR\s*=\s*\).*;\1\"${ROOT}${CONFIG_DIR}/\";" \
+ -e "s;^\(DATA_DIR\s*=\s*\).*;\1\"${ROOT}${DATA_DIR}/\";" \
+ -e "s;^\(TEMPLATE_DIR\s*=\s*\).*;\1\"${ROOT}${TEMPLATE_DIR}/\";" \
+ -e "s;^\(ICON_DIR\s*=\s*\).*;\1\"${ROOT}${ICON_DIR}/\";" \
+ -e "s;^\(LOCALE_DIR\s*=\s*\).*;\1\"${ROOT}${LOCALE_DIR}/\";" \
+ "${PN}"/constants.py || die "sed failed"
+
+ if use userpriv; then
+ sed -i -e "s/Exec=.*/Exec=portato --no-fork/" portato.desktop || die "sed failed"
+ fi
+}
+
+src_compile ()
+{
+ if use nls; then
+ ./pocompile.sh -emerge ${LINGUAS} || die "pocompile failed"
+ fi
+
+ distutils_src_compile
+}
+
+src_install ()
+{
+ dodir ${DATA_DIR} || die
+
+ distutils_src_install
+
+ newbin portato.py portato || die
+ dodoc doc/*
+
+ # config
+ insinto ${CONFIG_DIR}
+ doins etc/* || die
+
+ # plugins
+ insinto ${PLUGIN_DIR}
+
+ # desktop
+ doicon icons/portato-icon.png || die
+ domenu portato.desktop || die
+
+ # nls
+ use nls && domo i18n/mo/*
+
+ # man page
+ doman portato.1
+}
+
+pkg_postinst ()
+{
+ distutils_pkg_postinst
+ python_mod_optimize "/${PLUGIN_DIR}"
+}
+
+pkg_postrm ()
+{
+ distutils_pkg_postrm
+ python_mod_cleanup "/${PLUGIN_DIR}"
+
+ # try to remove the DATA_DIR, because it may still reside there, as it was tried
+ # to remove it before plugin stuff was purged
+ rmdir "${ROOT}"${DATA_DIR} 2> /dev/null
+}