summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Stine <battousai@gentoo.org>2004-02-05 21:35:07 +0000
committerBryan Stine <battousai@gentoo.org>2004-02-05 21:35:07 +0000
commitb4488c3a7c7c59dfaafaa8fdf17bdac9fec68f17 (patch)
tree74a40f8ff62f69602992bec9059c38cec258d96a
parentupdate audiofile & buddy deps (diff)
downloadgentoo-2-b4488c3a7c7c59dfaafaa8fdf17bdac9fec68f17.tar.gz
gentoo-2-b4488c3a7c7c59dfaafaa8fdf17bdac9fec68f17.tar.bz2
gentoo-2-b4488c3a7c7c59dfaafaa8fdf17bdac9fec68f17.zip
Fix globbing in xfree sdk USE detection.
-rw-r--r--media-video/ati-gatos/ChangeLog9
-rw-r--r--media-video/ati-gatos/ati-gatos-4.3.0.ebuild4
2 files changed, 9 insertions, 4 deletions
diff --git a/media-video/ati-gatos/ChangeLog b/media-video/ati-gatos/ChangeLog
index 6af7e9128745..8e95ef18b26b 100644
--- a/media-video/ati-gatos/ChangeLog
+++ b/media-video/ati-gatos/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/ati-gatos
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ati-gatos/ChangeLog,v 1.9 2004/01/15 06:20:29 battousai Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/ati-gatos/ChangeLog,v 1.10 2004/02/05 21:35:07 battousai Exp $
+
+ 05 Feb 2004; Bryan Stine <battousai@gentoo.org>; :
+ Fix globbing in xfree sdk USE detection. If sdk was in USE when emerging
+ xfree-drm, this would catch that and accept it, which would allow it to
+ install without an actual SDK present.
*ati-gatos-4.3.0 (13 Jan 2004)
diff --git a/media-video/ati-gatos/ati-gatos-4.3.0.ebuild b/media-video/ati-gatos/ati-gatos-4.3.0.ebuild
index 70bce22bf759..afc0a59102e5 100644
--- a/media-video/ati-gatos/ati-gatos-4.3.0.ebuild
+++ b/media-video/ati-gatos/ati-gatos-4.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ati-gatos/ati-gatos-4.3.0.ebuild,v 1.4 2004/01/15 06:20:29 battousai Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ati-gatos/ati-gatos-4.3.0.ebuild,v 1.5 2004/02/05 21:35:07 battousai Exp $
inherit eutils
@@ -18,7 +18,7 @@ DEPEND="${DEPEND}
x11-base/xfree"
pkg_setup() {
- if [ ! "`grep gatos /var/db/pkg/x11-base/xfree*/USE`" ]
+ if [ ! "`grep gatos /var/db/pkg/x11-base/xfree-[0-9]*/USE`" ]
then
ewarn "This package requires that xfree was merged with the gatos USE flag enabled."
die "Please merge xfree with the gatos and sdk USE flags enabled."